
Getting Started 

Getting Started 
The Statistics application enables you to collect, monitor, and view statistical parameters for devices 
throughout the network. Statistical data can be graphed (as shown in the screen below), displayed in tables, 
or exported to a .csv file that can be opened in a spreadsheet for further analysis. The Statistics application 
performs its own independent polling to collect data, and this polling can be toggled on and off when 
desired. The polling rate can also be configured. 

 

Getting Started Graphing 

When you first open the Statistics application, the Profile Manager window appears. If you have already 
created profiles, they will be listed in the Profiles Table. To start graphing, you must create a profile and 
add the variables that you want to graph. Follow the steps below to create a profile and start graphing.  
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When you click the New button in the Profile Manager window, the Add Item window appears. You can 
monitor several variables on one switch, or a single variable on a group of switches, or any combination 
you want to include in the profile. To create a profile, follow the steps in the graphic below. 

Note: Most variables represent individual MIB objects and are identified by the  icon. 
For convenience, "group performance" variables have also been created. Group 
performance variables represent a collection of related MIB variables and are identified 
by the  icon. 
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If you add more than one variable to the profile, each new variable will be assigned a new line color; or you 
can select a line color from the Line Color drop-down list. You also have the option of entering a 
Description for each variable. See Getting Started with Profiles for more information on creating and 
saving profiles. 

Graphing starts when you click the Done button. Graph lines may not display until a few poll cycles have 
occurred. Read the graph from right to left. The most current data displays at the right of the graph window. 
The horizontal axis plots time intervals. The vertical axis plots the values received from network devices. 
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Chart Window 

Statistical data is displayed in graphical form in the Chart window. The most recent data is displayed on the 
right side of the graph. You can view a specific value on the graph by moving the cursor to any point on a 
line to display the time and the data value. 

Performance Summary 

The Performance Summary displays information about the variable that is currently selected in the 
Performance Summary Table. The fields in the Performance Summary are described below. 

Latest Value 
The latest (most recent) value received from the device being monitored. 

Avg Value 
The average value received from the device being monitored since the profile was created. 

Max Value 
The largest value ever received from the device being monitored since the profile was created. 

Mem Req'd 
The amount of client memory used when this profile is loaded. The amount of memory used depends of the 
number of variables in a profile and the length of the profile.  

Min Value 
The smallest value ever received from the device being monitored since the profile was created. 
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Profile 
The amount of data that is currently loaded on the server, in weeks. The default amount of data that can be 
stored on the server for a profile is 4.3 weeks (approximately 30 days). The maximum amount of data that 
can be stored on the server for a profile is 142.7 weeks (approximately 999 days). When the maximum 
amount is reached, the oldest data is dropped as new data is added. 

Client 
The amount of data that is currently loaded on the client. The default amount of data that can be stored on 
the client for a profile is 1 day The maximum amount of data that can be stored on the client for a profile is 
999 days. However, it is recommended that you load no more than 7 days of data at a high polling rate. 
When the maximum amount is reached, the oldest data is dropped as new data is added. 

Performance Summary Table 

The Performance Summary Table lists the variables being monitored in a profile. A pop-up functionality is 
available in the table, which allows you to add a new variable to the map, edit the description of existing 
variables, delete the variable  and export data. The Performance Summary Table allows for selection of 
individual or multiple items for export.  

The fields in the table are defined below. All the fields in the Performance Summary Table can be moved 
to any location within the table by drag and drop. For example, the Item Description field can be moved to 
the last column in the table and other fields are automatically adjusted.  

User Variable 
The "name" of the user variable in Add Item Window (a brief description of the variable). 

Item Description 
The description of the graphed variable that the user entered in the Item Description field of the Add Item 
Window. The item description can be edited in the Edit Item Window. 

Category 
The category in the Add Item Window from which the performance variable was selected (e.g., Switch 
Health). 

Device Name 
The user-defined device name. 

IP Address 
The IP address of the device. 

Slot  
If applicable, the slot number. 

Port 
If applicable, the port number. 

Scale 
A multiplier factor used to make individual items on the chart more visible. Multiplier values range from 
1.0E-6 to 10000, with the default being 1.0. Click here for more information on the scale. 

MIB Variable 
The name of the variable, as defined in the MIB. 
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Graphing Options 

Whenever data is displayed in Chart View, icons in the Statistics Toolbar provide different graphing 
options. You can graph the absolute (raw) value of the data, or the delta value of the data (the amount the 
value returned from the device changed since the last poll), or the rate-per-second value of the data. Click 
here for more information on Chart View. 

 

Performance Table View 

The Performance Table View table displays a row of data for each polling cycle that has taken place for 
the variable selected in the Performance Summary Table. Each row displays the data as an absolute (raw) 
value, a delta value (the change since the last poll), and a rate-per-second value, along with a time stamp. 
Click the Performance Table View icon in the Statistics Toolbar to display a Performance Table for the 
variable selected in the Performance Summary Table. Some of the fields can be edited in Performance 
table. Only selected items in Performance table can be exported.  Click here for more information on 
Performance Table View. 
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Summary Table View 

Summary Table View displays one row of the most current data for each variable in the profile. Each row 
provides the source device IP address, the variable name, the slot and port (if applicable) and the latest poll 
data for the variable as an absolute (raw) value, a delta value (the change since the last poll), and a rate-per-
second value, along with a time stamp. Click the Summary Table View icon on the Statistics Toolbar to 
display profile statistics in Summary Table View. Some of the fields can be edited in Summary table. Only 
selected items in Summary table can be exported. Click here for more information on Summary Table 
View. 
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Getting Started with Profiles 

When you first opened the Statistics Application, the Profile Manager Window was empty. When you 
displayed the Add Item Window and specified variables for graphing, you created a profile. A profile 
consists of the variables you specify and their graphing attributes such as line weights, colors, polling rate, 
and so on. (Click here for a list of the attributes saved with a profile.) However, the profile is only 
temporary unless you save it on the OmniVista server. If you exit the Statistics Application without saving 
the profile, you will be asked if you wish to save it and warned that the profile will otherwise be discarded. 
Saved profiles can be loaded and unloaded in the Statistics Application on any OmniVista client. 

Saving Profiles 

When you save a profile on the OmniVista server, the profile continues to run on the server, even when it is 
not loaded on a client. "Run" means that the variables in the profile continue to be polled and the resulting 
statistical data is saved on the server. The profile will continue to run on the server unless you explicitly 
disable its polling or stop it from running (which is the same as disabling its polling). When you stop a 
profile, all polling of the profile's variables stops and statistical data is not collected. 

The Save Profile window enables you to save profiles. When you are ready to save a profile, click on the 
File Menu and select Save Profile. You can also right-click on the Chart View, Performance Table, or 
Summary Table windows and select Save Profile from the pop-up menu. 
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The Save Profile window enables you to do two important things (besides saving the profile): 

• Assign a name to the profile. Assigning meaningful names to profiles is important because there is 
no way of knowing the devices and variables contained in a profile without loading the profile into 
the Statistics Application. When loaded, the devices and variables contained in the profile are 
listed in the Performance Summary Table. However, if you have many profiles, loading each one 
to determine its contents could be time-consuming.  

• Enable the Save Data File option (which is disabled by default). When a profile is running on the 
server, the variables in the profile are being polled, and the statistical data collected is saved on the 
server. However, if polling is disabled for the profile or the profile is stopped (which disables 
polling), the statistical data on the server is deleted, unless Save Data File on the Save Profile 
Window was enabled when the profile was saved. If Save Data File was enabled, statistical data 
on the server is not deleted when polling for the profile is disabled. Note, however, that if you 
disable polling for a profile, gaps in the saved data will result.  

Saved profiles can also be saved under a different name by clicking on the File menu and selecting Save 
Profile As. You can also use the Chart View, Performance Table, or Summary Table pop-up menus. When 
you use this command, the profile's variables and graphing attributes (line weights, colors, polling rate, and 
so on) are saved under the new profile name but the statistical data from the original profile is not saved. 

Profile Manager 

The Profile Manager enables you to manage profiles. To display the Profile Manager, click on the Profile 
Manager Tab. The Profile Manager Window lists all profiles that are saved on the server and enables you to 
load a saved profile on an OmniVista client, to unload a profile from the client, to delete saved profiles 
from the server, and to start and stop profiles running on the server. The Profile Manager also enables you 
to load a selected, partial portion of a profile's collected statistical data. Click here for more information on 
the Profile Manager. 
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Data Collection and Display Properties 

The Statistics Properties Window, shown below, contains two tabs, Data and Display, that enable you to 
specify how statistical data is collected and displayed. Display the Statistics Properties Window by clicking 
the Properties icon in the Statistics Toolbar or selecting Properties on the Chart View, Performance Table, 
or Summary Table Pop-Up menu. Click here for more information on the Data Properties tab. Click here 
for more information on the Display Properties tab. 
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Statistics Pop-Up Menus 

You can right-click anywhere in the Chart View window, a Performance Table, or a Summary Table to 
display a pop-up menu. Commands specific to each window are displayed. The Chart View Pop-Up Menu 
is shown below. Click here for information on pop-up menu commands. 
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You can also click right on any selected variable in the Performance Summary Table to display the 
Performance Summary Pop-Up Menu, shown below. Click here for information on Performance Summary 
Table Pop-Up Menu commands. 
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Statistics Toolbar 

The Statistics Toolbar is shown and defined below. 
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Icon  Tool Tip Description 

 Add item to profile Opens the Add Item Window, which enables you to add 
variables to be monitored to a profile. 

 Modify item 
Opens the Edit Item Window, which enables you to 
modify graphing attributes or the description of the 
variable selected in the Performance Summary Table. 

 Delete item in legend Deletes the variable currently selected in the Performance 
Summary Table from the profile. 

 Clear all data Clears all data from the client, but not from the server. 

 Open Properties dialog Opens the Statistics Properties Window, which enables 
you to specify data collection and display properties. 

 Toggle polling on/off Turns polling on/off for the profile that is currently 
loaded. 

  Poll manually Causes an immediate poll of the profile that is currently 
loaded (rather than waiting for the next polling period). 

 Chart View Displays data as a line graph. 

 Performance Table View 
Displays, in table format, a row of data for each polling 
cycle that has taken place for the variable selected in the 
Performance Summary Table. 

 Summary Table View Displays, in table format, the current values for all 
variables in the Performance Summary Table. 

 Show data as absolute value Graphs the absolute (raw) value of the data. This is the 
default. 

 
Show data as amount changed 
since last poll 

Graphs the delta value of the data - the amount of change 
since the last poll. 

 Show data as rate per second Graphs the data as rate per second. 

 Help Displays help for the Statistics Application. 

Exporting Statistics Data 

The Export Data command, which is available on the File menu and on the Chart View and Performance 
Table View Pop-Up Menus, enables you to export statistical data for a profile to a comma-separated value 
(.csv) file. Selecting Export Data displays the Export statistics data window, shown below, which 
enables you to navigate to the location where you want to save the .csv file. 
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Once the data is saved in a .csv file, the file can be viewed and analyzed through any text editor, 
spreadsheet, or database program. Below is an example of an exported .csv file viewed with Microsoft 
Excel. 
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Printing a Chart 

The Print Chart command, which is available on the File menu, enables you to create a printout of 
statistical data for the current profile in the form of a Chart View line graph. Selecting this command 
displays the Print Properties Window, shown below. If the Print Chart Legend checkbox is enabled on the 
Print Properties Window, the Performance Summary Table will be included in the printout. 

Note that the Background color field on the Print Properties window enables you to specify the 
background color used to print the chart. When the Print to file checkbox is enabled, the print job is output 
to a file, the format of which is determined by the printer driver you have installed. In most cases, the file 
produced will be in Post Script format. 
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Creating a Graph 
When you first open the Statistics application, the Profile Manager window appears. To start graphing, you 
must create a profile and add the variables that you want to graph. If you have already created profiles, they 
will be listed in the Profiles Table. Follow the steps below to create a profile and start graphing. 

 

When you click the New button in the Profile Manager window, the Add Item window appears. You can 
monitor several variables on one switch, or a single variable on a group of switches, or any combination 
you want to include in the profile. To create a profile, follow the steps in the graphic below. 

Note on Profiles: All variables you add for graphing are added to the current, open 
profile. If you wish to add variables to a different profile, you must first load that profile 
(select Load Profile on the File menu). If you wish to add variables to a new profile, you 
must first unload the current profile (select Unload Profile on the File Menu). 
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Adding Variables to a Graph 

1. Within the Network Devices pane of the Add Item window, click open the folder of the device to be 
monitored and drill down and select the category, module, or port in which you are interested. 

2. Select the variable you want to graph from the Performance Categories pane. 

Note: Certain non-AOS devices do not fully implement MIB2 variables. Therefor, certain variables 
may not be supported on these devices. Although, OmniVista will allow you to configure the 
unsupported variable, no values will be displayed. 

3. Set the Scale combo box to the scale you want used to graph the variable. 

Note: When two or more variables are being graphed simultaneously, the graph line for 
one variable may be disproportionately large (or small), making it difficult to view. If this 
situation occurs, you may wish to select a different scale for that variable. In this context, 
scale is really a multiplier. The range of scale values is 1.0E-6 to 10000. The default scale 
value is 1.0. The scale of a graphed variable is displayed in the Performance Summary 
table. Always note the scale of a graphed variable. If it is using a scale other than 1.0, the 
graph line may be misleading. 

4. Set the Line Width combo box to the line width you want used to graph the variable. 
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5. Set the Line Style combo box to the line style you want used to graph the variable. Note that you can 
select line styles that display a shape that marks each poll. These lines styles can only be used with the 
thinnest line width. 

 

6. Set the Line Color combo box to the color you want used to graph the variable. Note that each time you 
add a variable, the Statistics application displays a different default color in the Line Color combo box. 
This helps avoid two variables graphing with the same color. 

7. If desired, enter a brief description of the variable in the Item Description field. This description will 
display in the Performance Summary Table. 

8. Click the Add button to add the variable to the graph. Or, double-click the variable in the Performance 
Categories pane, which is the same as clicking Add. 

9. Continue adding variables as desired. When you are finished, click Done to exit the Add Item window. 
Graphing begins when Done is clicked. 

Group Performance Variables 

In general, each variable that can be graphed represents a single MIB variable. However, there are also 
"group performance" variables that represent a collection of related MIB variables. Group performance 
variables have been created as a convenience, and are identified by the  icon. The group performance 
variables are described below. 

AOS Group Performance Variables 

SNMP Traffic under Device > SNMP 
A group of SNMP traffic MIB variables, including the following: snmpInPkts, snmpOutPkts, 
snmpInTotalReqVars, snmpInTotalSetVars, snmpInGetNexts, snmpInSetRequests, snmpInGetResponses, 
snmpOutGetRequests, snmpOutSetRequests, and snmpOutGetResponses. 

Port Utilization under Device > Utilization 
Port utilization for every active port on the device. Includes the healthPortRxTxLatest MIB variable for 
every active port on the device. 

Physical Port under Device > Physical > Ethernet Module > Ethernet Port > Physical Port 
A default group of statistics that includes In Octets, Out Octets, In Unicast Packets, Out Unicast Packets, In 
Packets Discarded, Out Packets Discarded, In Packets Errors, Out Packets Errors, Unknown Protocol 
Packets. MIB variables include: ifInOctets, ifOutOctets, ifInUcastPkts, ifOutUcastPkts, ifInDiscards, 
ifOutDiscards, ifInErrors, ifOutErrors, ifInUnknownProtos. 

19 



Creating a Graph 

Interface Statistics under Device > Physical > Ethernet Module > Ethernet Port > Physical Port 
A default group of statistics that includes Alignment Errors, FCS Errors, Single Collision Frames, Multiple 
Collision Frames, Deferred Transmissions, Late Collisions, Excessive Collisions, Frame Too Long. MIB 
variables include: dot3StatsAlignmentErrors, dot3StatsFCSErrors, dot3StatsSingleCollisionFrames, 
dot3StatsMultipleCollisionFrames, dot3StatsDeferredTransmissions, dot3StatsLateCollisions, 
dot3StatsExcessiveCollisions, dot3StatsFrameTooLongs. 

Default RMON Statistics under Device > Physical > Ethernet Module > Ethernet Port > RMON 
A default group of ROM statistics that includes Total Packets Received, CRC Alignment Errors, 
Undersized Packets, Oversized Packets, Fragments, Jabbers, Collisions. MIB variables include: 
etherStatsPkts, etherStatsCRCAlignErrors, etherStatsUndersizePkts, etherStatsOversizePkts, 
etherStatsFragments, etherStatsJabbers, and etherStatsCollisions. 

Packet Sizes under Device > Physical > Ethernet Module > Ethernet Port > RMON 
Includes the total number of packets received (including bad packets) that were between 64 and 1518 octets 
in length, inclusive (excluding framing bits but including FCS octets). MIB variables include: 
etherStatsPkts64Octets, etherStatsPkts65to127Octets, etherStatsPkts128to255Octets, 
etherStatsPkts256to511Octets, etherStatsPkts512to1023Octets, and etherStatsPkts1024to1518Octets. 

Switch Health under Device > Health > Switch Health 
A default group of statistics that include RX TX Utilization, Memory Utilization, Switch CPU utilization, 
Switch Temperature, CMM CPU Temperature. MIB variables include: healthDeviceRxTxLatest, 
healthDeviceMemoryLatest, healthDeviceCpuLatest, healthDeviceTemperatureChasLatest, and 
healthDeviceTemperatureCmmCpuLatest. 

Module Health under Device > Health > Module Health > Module > Module Health 
A default group of statistics that includes Module Utilization, Memory Utilization, CPU Utilization. MIB 
variables include: healthModuleRxTxLatest, healthModuleMemoryLatest, and healthModuleCpuLatest. 

XOS Group Performance Variables 

Default Chassis Vars under Device > Chassis 
A group of chassis MIB default variables. MIB variables include: chasPhysicalChanges, 
chasLogicalChanges, and  chasNoOfResets. 

SNMP Traffic under Device > SNMP 
A group of SNMP traffic MIB variables. MIB variables include: snmpInPkts, snmpOutPkts, 
snmpInTotalReqVars, snmpInTotalSetVars, snmpInGetNexts, snmpInSetRequests, snmpInGetResponses, 
snmpOutGetRequests, snmpOutSetRequests, and snmpOutGetResponses. 

Port Utilization under Device > Utilization 
The port utilization for every active port on the device. Port Utilization is the average port-level I/O 
utilization over the latest sample period, as a percent. Depending on the device type, MIB variables may 
include health2PortRxTxLatest or ifInOctets, ifOutOctets, and ifSpeed. 

Physical Port under Device > Physical > Ethernet Module > Ethernet Port > Ethernet Ports > Physical 
Port 
A default group of statistics that includes In Frames, Out Frames, In Octets, Out Octets, In Unicast Packets, 
Out Unicast Packets, In NonUnicast Packets, Out NonUnicast Packets, In Buffer Discards, Out Buffer 
Discards, In Error Discards, Out Error Discards. MIB variables include: phyPortFrameIns, 
phyPortFrameOuts, phyPortInOctets, phyPortOutOctets, phyPortInUcastPkts, phyPortOutUcastPkts, 
phyPortInNUcastPkts, phyPortOutNUcastPkts, phyPortInBufDiscs, phyPortOutBufDiscs, 
phyPortInErrDiscs, and phyPortOutErrDiscs. 
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Default RMON Statistics under Device > Physical > Ethernet Module > Ethernet Port > Ethernet Ports 
> RMON 
A default group of statistics that includes Total Packets Received, CRC Alignment Errors, Undersized 
Packets, Oversized Packets, Fragments, Jabbers, Collisions. MIB variables include: etherStatsPkts, 
etherStatsCRCAlignErrors, etherStatsUndersizePkts, etherStatsOversizePkts, etherStatsFragments, 
etherStatsJabbers, and etherStatsCollisions. 

Packet Sizes under Device > Physical > Ethernet Module > Ethernet Port > Ethernet Ports > RMON 
The total number of packets received (including bad packets) that were between 64 and 1518 octets in 
length, inclusive (excluding framing bits but including FCS octets). MIB variables include: 
etherStatsPkts64Octets, etherStatsPkts65to127Octets, etherStatsPkts128to255Octets, 
etherStatsPkts256to511Octets, etherStatsPkts512to1023Octets, and etherStatsPkts1024to1518Octets. 

Switch Health under Device > Health > Switch Health 
A default group of statistics that includes RX TX Utilization, Backplane Utilization, Memory Utilization, 
Temperature, MPM CAM utilization as a percent, HRE CAM utilization as a percent, VCC Utilization, 
Virtual Port Utilization, HRE Collision Utilization. MIB variables include: health2DeviceRxTxLatest, 
health2DeviceBackplaneLatest, health2DeviceMemoryLatest, healthDeviceTemp, 
health2DeviceMpmCamLatest, health2DeviceHreCamLatest, health2DeviceVccLatest, 
health2DeviceVpLatest, and health2DeviceHreCollisionLatest. 

Module Health under Device > Health > Module Health > Ethernet Module > Module Health 
A default group of statistics that includes Module Utilization, Backplane Utilization, CAM Utilization, Vcc 
Utilization. MIB variables include: health2ModuleRxTxLatest, health2ModuleBackplaneLatest, 
health2ModuleCamLatest, and health2ModuleVccLatest. 

Interface Statistics under Device > Physical > Ethernet Module > Ethernet Port > Ethernet > Interface 
Statistics 
A default group of statistics that includes Alignment Errors, FCS Errors, Single Collision Frames, Multiple 
Collision Frames, Deferred Transmissions, Late Collisions, Excessive Collisions, Frame Too Long. MIB 
variables include: dot3StatsAlignmentErrors, dot3StatsFCSErrors, dot3StatsSingleCollisionFrames, 
dot3StatsMultipleCollisionFrames, dot3StatsDeferredTransmissions, dot3StatsLateCollisions, 
dot3StatsExcessiveCollisions, and dot3StatsFrameTooLongs. 

Default RMON Statistics under Device > Physical > Ethernet Module > Ethernet Port > RMON 
A default group of statistical variables that includes Total Packets Received, CRC Alignment Errors, 
Undersized Packets, Oversized Packets, Fragments, Jabbers, Collisions. MIB variables include: 
etherStatsPkts, etherStatsCRCAlignErrors, etherStatsUndersizePkts, etherStatsOversizePkts, 
etherStatsFragments, etherStatsJabbers, and etherStatsCollisions. 

Packet Sizes under Device > Physical > Ethernet Module > Ethernet Port > RMON  
The total number of packets received (including bad packets) that were between 64 and 1518 octets in 
length, inclusive (excluding framing bits but including FCS octets). MIB variables include: 
etherStatsPkts64Octets, etherStatsPkts65to127Octets, etherStatsPkts128to255Octets, 
etherStatsPkts256to511Octets, etherStatsPkts512to1023Octets, and etherStatsPkts1024to1518Octets. 

21 



Editing a Variable 

Editing a Variable 
To edit a variable, select the variable in the Statistics Legend Table and click the Modify Item icon on the 
Statistics Toolbar to display the Edit Item window. You can also double-click the variable in the Statistics 
Legend Table. The Edit Item Window enables you to modify the scale, line width, line style, or color used 
to graph a variable. It also enables you to edit the variable's description, which displays in the Statistics 
Legend Table. 
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Chart View 
Chart View (the default view) displays statistical data in the form of a line graph, as shown below. If 
necessary, click on the Chart View icon in the Statistics Toolbar to display data in Chart View. Graphing 
Icons in the toolbar enable you to shift between graphing the absolute value of the data, the delta value of 
the data (the amount of change in the data since the last poll), and the rate-per-second of the data. 

 

Read the graph from right to left. The most current data displays at the right of the graph window. The 
horizontal axis plots time intervals. The vertical axis plots the values received from network devices. 

Chart View Pop-Up Menu 

Whenever the Chart View window is displayed, you can right-click anywhere in the window to display the 
Chart View Pop-Up menu. Each menu item is described below.  
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Chart View 

 

Add New Item 
Displays the Add Item window, which enables you to add new variables to the graph and the profile. 

Profile Manager 
Displays the Profile Manager window, which enables you to load, unload, and perform other profile 
management tasks. 

Save Profile 
When the current profile is unsaved, this menu item displays the Save Profile window, which enables you 
to save the profile. 

Save Profile As 
Displays the Save Profile window, which enables you to save the profile under a new name. 

Export Data 
Enables you to save Statistics data to a comma-separated value (.csv) file. Once the data is saved in a .csv 
file, it can be viewed through any text editor, spreadsheet, or database program. Selecting this menu item 
displays the Export statistics data window, shown below, which enables you to navigate to the location 
where you want to save the .csv file. Click here for more information on exporting data. 
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Clear All Data 
Clears all current statistical data from the Chart View window and from the client. However, this does not 
clear or remove any data from the server (assuming that statistical data was being saved on the server in the 
first place - see Saving Profiles for more information). The Clear All Data menu item can be thought of as 
an "eraser" that wipes the client clean of all current statistical data but does not affect the server. 

Auto Scale 
Immediately enables/disables auto scaling. When auto scaling is enabled, the vertical scale is automatically 
adjusted to accommodate and display the maximum data value received. When auto scaling is disabled, the 
vertical scale is specified by the Vertical Scale Max field in the Display tab of the Statistics Properties 
Window. 

Table View 
Switches the display from Chart View to Performance Table View. Performance Table View displays a 
row of information for each polling cycle that has taken place for the variable selected in the Performance 
Summary Table. 

Properties 
Displays the Statistics Properties window, which enables you to specify properties for statistical data 
collection and display. 

Performance Summary Table Pop-Up Menu 

You can click right on any variable or multiple variable in the Performance Summary Table to display the 
Performance Summary Pop-Up menu. Each menu item is described below. 
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Chart View 

 

Add New Item 
Displays the Add Item window, which enables you to add new variables to the graph and the profile. 

Modify Item 
Displays the Edit Item window, which enables you to modify the scale, line width, line style, or color used 
to graph a variable. It also enables you to edit the variable's Item Description, which displays in the 
Performance Summary Table. If multiple variables are selected in the Performance Summary table, this 
option is not enabled in the pop-up as shown below: 

 

Highlight Item 
Highlights the selected variable in the Chart View Window. Highlighting an item is useful when the graph 
lines for multiple variables are closely bunched together, such as in the screen shown below. This option is 
not enabled when multiple variables are selected. When you highlight a variable, the graph line for that 
variable is doubled in thickness and displayed in white. If necessary, the display is auto scaled to that 
variable's highest value. 
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Remove Item 
Immediately deletes the selected variable from the graph and from the profile. 

Export Selected  
Save statistics data as a comma-separated value (.csv) file in the desired location. Selecting this menu item 
displays the Export Statistics Data window, which enables you to navigate to the location where you want 
to save the .csv file.  

Properties 
Displays the Statistics Properties window, which enables you to specify properties for statistical data 
collection and display. 
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Performance Table View 
The Performance Table View list displays a row of data for each polling cycle that has taken place for the 
variable selected in the Statistics Legend Table. Each row displays the data as an absolute (raw) value, a 
delta value (the change since the last poll), and a rate-per-second value, along with a time stamp. Click the 
Performance Table View icon in the Statistics Toolbar to display a Performance Table for the variable 
selected in the Statistics Legend Table. 

 

Performance Table View Pop-Up Menu 

Whenever a Performance Table is displayed, you can right-click anywhere in the table to display the 
Performance Table Pop-Up menu. Each menu item is described below. 
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Performance Table View 

 

Add Item 
Displays the Add Item window, which enables you to add new variables for monitoring. 

Profile Manager 
Displays the Profile Manager window, which enables you to load, unload, and perform other profile 
management tasks. 

Save Profile 
When the current profile is unsaved, this menu item displays the Save Profile window, which enables you 
to save the profile. 

Save Profile As 
Displays the Save Profile window, which enables you to save the profile under a new name. 

Export Data 
Enables you to save statistics data to a comma-separated value (.csv) file. Once the data is saved in a .csv 
file, it can be viewed through any text editor, spreadsheet, or database program. Selecting this menu item 
displays the Export Statistics Data Window, shown below, which enables you to navigate to the location 
where you want to save the .csv file. Note that when data is exported from Performance Table View, data 
for the entire profile is exported, not just data for the variable that is currently selected and displayed. 
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Clear All Data 
Clears all current statistical data from the Performance Table and from the client. However, this does not 
clear or remove any data from the server. The Clear All Data menu item can be thought of as an "eraser" 
that wipes the client clean of all current statistical data but does not affect data on the server. 

Chart View 
Switches the display from Performance Table View to Chart View. Chart View displays statistical data as a 
line graph. 

Properties 
Displays the Statistics Properties window, which enables you to specify properties for statistical data 
collection and display. 

Statistics Legend Table Pop-Up Menu 

You can right-click on any variable in the Statistics Legend Table to display the Statistics Legend Table 
Pop-Up menu. Each menu item is described below. 
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Add New Item 
Displays the Add Item window, which enables you to add new variables for monitoring.  

Modify Item 
Displays the Edit Item window, which enables you to modify the scale, line width, line style, or color used 
to graph a variable when in Chart View. It also enables you to edit the variable's Description, which 
displays in the Statistics Legend Table. 

Highlight Item 
This menu item is not applicable to Performance Table View.  

Remove Item 
Immediately deletes the selected variable. 

Properties 
Displays the Statistics Properties window, which enables you to specify properties for statistical data 
collection and display.   
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Summary Table View 
The Summary Table View list displays one row of data for each variable in the Performance Summary 
Table. Each row provides the source device IP address, the variable name, the slot and port (if applicable) 
and the latest poll data for the variable as an absolute (raw) value, a delta value (the change since the last 
poll), and a rate-per-second value, along with a time stamp. Click the Summary Table View icon in the 
Statistics Toolbar to display the Summary Table View list. 

 

Summary Table View Pop-Up Menu 

Whenever a Summary Table is displayed, you can right-click anywhere in the table to display the Summary 
Table Pop-Up menu. Each menu item is described below. 
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Summary Table View 

 

Add Item 
Displays the Add Item window, which enables you to add new variables for monitoring. 

Profile Manager 
Displays the Profile Manager window, which enables you to load, unload, and perform other profile 
management tasks. 

Save Profile 
When the current profile is unsaved, this menu item displays the Save Profile window, which enables you 
to save the profile. 

Save Profile As 
Displays the Save Profile window, which enables you to save the profile under a new name. 

Export Data 
This menu item is not applicable to Summary Table View. 

Clear All Data 
Clears all current statistical data from the Performance Table and from the client. However, this does not 
clear or remove any data from the server. The Clear All Data menu item can be thought of as an "eraser" 
that wipes the client clean of all current statistical data but does not affect data on the server. 

Chart View 
Switches the display from Performance Table View to Chart View. Chart View displays statistical data as a 
line graph. 
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Properties 
Displays the Statistics Properties window, which enables you to specify properties for statistical data 
collection and display. 

Performance Summary Pop-Up Menu 

You can right-click on any variable or multiple variables in the Performance Summary Table to display the 
Performance Summary Pop-Up Menu. Each menu item is described below. 

 

Add New Item 
Displays the Add Item window, which enables you to add new variables for monitoring. 

Modify Item 
Displays the Edit Item window, which enables you to modify the scale, line width, line style, or color used 
to graph a variable when in Chart View. It also enables you to edit the variable's description, which 
displays in the Performance Summary Table. If multiple variables are selected in the Performance 
Summary table, this option is not enabled in the pop-up. 

Highlight Item 
This menu item is not applicable to Summary Table View.  
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Remove Item 
Immediately deletes the selected variable. 

Export Selected 
Displays the Export Statistics Data window, which enables you to save the statistics data of a profile in 
comma-separated variable (.csv) file in a preferred location. 

Properties 
Displays the Statistics Properties window, which enables you to specify properties for statistical data 
collection and display.  
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Statistics Properties: Data Tab 
The Statistics Properties window, shown below, contains two tabs, Data and Display, that enable you to 
specify how statistical data is collected and displayed. Display the Statistics Properties Window by clicking 
the Properties icon in the Statistics Application Toolbar or selecting Properties on the Chart View, 
Performance Table, or Summary Table Pop-Up Menus. The sections below explain the fields in the Data 
tab. When you have set a field as desired, you can click the Apply button to apply your change. Clicking 
the OK button applies all changes and closes the window. 

 

Auto Polling 

The Auto Polling fields are used to enable or disable polling for the profile that is currently loaded. When 
automatic polling is enabled, you can also specify the polling rate. To disable automatic polling, click the 
Off button. To enable automatic polling, click the On button. When automatic polling is enabled, specify 
the desired polling rate, in seconds, by entering the desired rate in the Rate (seconds) field, or clicking the 
arrows until the desired rate is displayed. The automatic polling rate can be set to any value from 1 to 60 
seconds. 

Enabling automatic polling is the same as commanding a profile to run on the server (which is done by 
selecting the profile in the Profile Manager window and clicking the Run button), or toggling polling on 
with the Toggle Polling On/Off icon on the Statistics Application Toolbar. Disabling automatic polling 
performs the same function as stopping a profile from running on the server (which is done by selecting the 
profile in the Profile Manager window and clicking the Stop button), or toggling polling off with the 
Toggle Polling On/Off icon on the Statistics Application Toolbar. 
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Whether automatic polling is enabled or disabled, you can always perform a manual poll. A manual poll 
enables you to gather data immediately, rather than waiting for the next polling cycle (if automatic polling 
is enabled). To perform a manual poll, click the Poll Manually icon on the Statistics Application Toolbar. 

There may be times when you want to temporarily disable automatic polling. For example, if you wish to 
spend more time viewing and analyzing a certain group of statistics, automatic polling will interfere by 
updating these statistics when the next polling cycle is performed. To prevent such situations, you can 
toggle polling off and on with the Toggle Polling On/Off icon on the Statistics Application Toolbar. 

Note: The Auto Polling settings are saved with the profile and will be reloaded with the 
profile. 

Data Collection Size 

The Data Collection Size fields enable you to specify the amount of data (in days, hours, or minutes) that 
you want saved on the server. The maximum data collection size is 999 days. When the specified data 
collection size is reached, new incoming data will begin to overwrite the oldest data. For example, if you 
specify a data collection size of 23 hours, new incoming data will begin to overwrite the oldest data after 23 
hours of data have been saved to the server. 

Note: When the profile collection process is restarted, old data will be progressively 
erased and replaced with new data until, again, the profile's collection size is reached. 

To specify the Data Collection Size, set the Time Unit field to Hours, Days, or Minutes, as desired, then 
set the Time Value field to the desired time period. 

Important Note: The Data Collection Size settings are saved with the profile and will be 
reloaded with the profile. The Data Collection Size only increments during time periods 
when active polling is taking place. 

View Data As 

The View Data As fields enable you to specify the manner in which data is graphed. You can select the 
following: 

• Absolute Value (the default). The absolute, or raw, value of the data will be graphed.  
• Rate Value. Data will be graphed as rate per second.  
• Delta Value. The change between the data obtained in the previous poll and the data obtained in 

the current poll will be graphed.   

   

37 



Statistics Properties: Display Tab 

Statistics Properties: Display Tab 
The Statistics Properties window, shown below, contains two tabs, Data and Display, that enable you to 
specify how statistical data is collected and displayed. Display the Statistics Properties window by 
clicking the Properties icon in the Statistics Application Toolbar or selecting Properties on the Chart View, 
Performance Table, or Summary Table Pop-Up Menus. The sections below explain the fields in the Display 
tab. When you have set a field as desired, you can click the Apply button to apply your change. Clicking 
the OK button applies all changes and closes the window. 

 

Display Options 

The Display tab enables you to specify how statistical data displayed. 

Type 

The Type fields enable you to specify how statistical data is formatted and displayed. You can select the 
following: 

Line Chart. Statistical data is displayed as a line chart. An example is shown below. 
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Performance Table. Statistical data is displayed as a Performance Table. An example is shown below. The 
Performance Table displays a row for each polling cycle that has taken place for the variable selected in the 
Statistics Legend Table. Each row displays the data as an absolute (raw) value, a delta value (the change 
since the last poll), and a rate-per-second value, along with a time stamp. 

Note: There are no display options available for the Performance Table. 

 

Summary Table. Statistical data is displayed in a table that is summarized by variable. One row is 
displayed for each variable being graphed. Only the result of the latest poll is displayed in each row. Each 
row displays the source device, the variable name, the slot and port, and provides the data as an absolute 
(raw) value, a delta value (the change since the last poll), and a rate-per-second value, along with a time 
stamp. 

Note: There are no display options available for the Summary Table. 
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Color 

When Line Chart is selected, the Color box enables you to specify the background color of the graph 
window. 

Chart Options 

The Chart Options fields enable you to specify the appearance of the graph window when the Display 
Option Type is set to Line Chart. 

Show 

The Show fields enable you to specify the lines displayed in the Chart View Window. You can choose to 
display, or hide, the Vertical Grid, the Horizontal Grid, and the Vertical Labels. The Color box enables you 
to specify the color of the grid lines. 

Vertical Scale 

The Vertical Scale fields enable you to specify how the vertical scale functions. You can check the Auto 
Scale checkbox to enable auto scaling. When auto scaling is enabled, the vertical scale is automatically 
adjusted to accommodate and display the maximum data value received. 

If you want more control over the vertical scale, enter the value you want used as the upper limit of the 
scale in the Max field. In the screen shown below, the value in the Max field is 10, and 10 displays as the 
upper limit of the vertical scale. The vertical scale will remain at the Max value unless a monitored device 
returns a value that is greater than the Max value. If that occurs, the upper limit of the vertical scale will be 
shifted to the greater value received, the vertical display will be shifted accordingly, and a vertical scroll 
bar will display. An example of this is shown below. 

Note: The Vertical Scale settings are saved with the profile and will be reloaded with the 
profile. 
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Horizontal Scale 

The Horizontal Scale fields enable you to specify the amount of data that is displayed in the graph window 
at any one time. (The horizontal scroll bar enables you to scroll over the entire body of collected data.) For 
example, in the screen shown below, the horizontal scale is set to five minutes, and five minutes of data is 
displayed in the graph window. The maximum value you can specify for the horizontal scale is 24 hours. 
To specify the horizontal scale, set the Unit combo box to Hours, Minutes or Seconds, as desired. Then 
enter the desired number of hours, minutes, or seconds in the Value field, or click the arrows until the 
desired value is displayed.  

Note: The Horizontal Scale settings are saved with the profile and will be reloaded with 
the profile. 
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Saving Profiles 
When you select Save Profile (or Save Profile As) in the File menu or in the Chart View, Performance 
Table, or Summary Table Pop-Up Menus, the Save Profile (or Save Profile As) Window displays. When 
you save a profile, it continues to run on the server even when it is not loaded in the Statistics Application. 
"Run" means that the variables in the profile continue to be polled and the resulting statistical data 
continues to be saved on the server. When you save a profile, the following information is saved: 

• The performance variables, line widths, line styles, line colors, and item descriptions specified via 
the Add Item window.  

• The Auto Polling settings, Data Collection Size settings, Vertical Scale settings, and Horizontal 
Scale settings specified via the Statistics Properties window.  

• The statistical data gathered for the profile.  

 

A saved profile will continue to run on the server unless you: 

• Disable polling for the profile via the Statistics Properties window  
• Turn polling off for the profile via the Toggle Polling on/off icon on the Statistics Toolbar  
• Stop the profile from running via the Profile Manager window (which disables polling for the 

profile).  

Statistical data for a saved profile is saved on the server UNTIL polling for the profile is disabled or the 
profile is stopped (which disables polling for the profile). If polling for the profile is disabled, the statistical 
data saved on the server is deleted unless the Save Data File checkbox on the Save Profile Window was 
enabled when the profile was saved. Note, however, that if you disable polling for a profile, gaps in the 
saved data will result. 

A profile can only be saved once. Once it has been saved, any changes you make to the profile - for 
example adding or deleting variables, or altering the line widths, line styles, or colors used for graphing - 
are automatically saved to the profile without user intervention. 

Note that saved profiles can be saved under a different name using the Save Profile As command on the 
File menu or on the Chart View, Performance Table, or Summary Table Pop-Up Menus. When you use the 
Save Profile As command, the profile's variables and graphing attributes (e.g., line weights, colors, polling 
rate) are saved under the new profile name but the statistical data from the original profile is not saved. 

The Profile Manager enables you to rename saved profiles, delete them, or start/stop them running on the 
server (i.e., start/stop polling). Display the Profile Manager by selecting Profile Manager on the File menu 
or on the Chart View, Performance Table, or Summary Table Pop-Up Menus. 
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How to Save a Profile 

Follow the steps below to save a profile. 

1. Enter a name for the profile in the Profile Name field. It is advisable to use meaningful names for 
profiles, so that glancing at a list of Profiles will enable you to distinguish one from another. For example, 
in the Save Profile Window shown above, the Profiles List combo box displays the profile name "CPU 100, 
106, 116, 242." This means that the profile contains statistics for CPU utilization in switches 100, 106, 116, 
and 242. 

Assigning meaningful names to profiles is important because there is no way of knowing the devices and 
variables contained in a profile without loading the profile into the Statistics Application. (When loaded, 
the devices and variables contained in the profile are listed in the Statistics Legend Table.) However, if you 
have many profiles, loading each one to determine its contents could be time-consuming. 

2. If you want statistical data saved on the server even if polling for the profile is disabled, check the Save 
Data File checkbox. If you do not enable Save Data File, statistical data that is saved on the server will be 
deleted if polling for the profile is disabled or if the profile is stopped from running (which disables 
polling). 

Note: The data file that is saved to the server cannot be accessed or manipulated in any 
way. However, it can be exported to a comma separated value (.csv) file and then viewed 
through a text editor, spreadsheet, or database. An Export Data menu option is available 
on the File menu, on the Chart Window pop-up menu, and on the Performance Table 
pop-up menu. Click here for more information on exporting statistics data. 

3. Click OK to save the profile on the OmniVista server.  
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The Profile Manager 
The Profile Manager window lists all existing saved profiles and enables you to load/unload a selected 
profile on the client (in whole or in part), create a new profile, schedule a profile to run at a specific time, 
start/stop profiles running on the server, rename profiles, and to delete profiles from the server. (Note that 
profiles can be saved, saved as, or unloaded via commands on the File menu.) 

 

The Profiles Table 

The Profiles Table lists all existing saved profiles. The fields in the Profiles Table are as follows: 

Name 
The user-assigned name of the profile. 

Activity 
This field will display Running if the profile is currently running on the server. It will display Not 
Running if the profile is not currently running on the server. Multiple profiles can be running on the server 
at any one time. The Profile Manager enables you to stop a profile running on the server by selecting the 
profile and clicking the Stop button. You can start profiles running on the server by selecting the profile 
and clicking the Run button. Note that when a profile is stopped and is not running on the server, polling 
for the profile is disabled. 

Client Status 
This field will display Loaded if the profile is currently loaded on the client. It will display Not Loaded if 
the profile is not currently loaded on the client. The Profile Manager enables you to load and unload 
profiles from the client by selecting the profile and clicking the Load or Unload button. 
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Owner 
The login name of the user who created the profile. 

Modifiable 
This field displays true or false to indicate whether the user who is currently logged in can edit the profile. 
The user who created the profile can always edit the profile, as can other users that have the same security 
permissions. Users admin and netadmin (or users with equivalent security permissions) can edit any profile. 

Note: Take care when editing a profile, as the profile may be open on more than one 
client. Any changes made to the profile will be reflected on all clients. 

Start Time 
The date and time when the profile started running on the server. The start time will display as N/A (not 
available) if the Save Data File checkbox on the Save Profile window was disabled when the profile was 
saved and if polling for the profile was disabled or the profile was stopped on the server (which disables 
polling) 

End Time 
The date and time when the profile stopped running on the server. If this field displays Current, the profile 
is currently running on the server. The end time will display as N/A (not available) if the Save Data File 
checkbox on the Save Profile window was disabled when the profile was saved and if polling for the profile 
was disabled or the profile was stopped on the server (which disables polling). 

Creating a Profile 

Create a new profile by clicking the New button in the Profile Manager window. When you click the New 
button, the Add Item window appears. You can monitor several variables on one switch, or a single 
variable on a group of switches, or any combination you want to include in the profile. To create a profile, 
follow the steps in the graphic below. 

Note: Most variables represent individual MIB objects and are identified by the  icon. 
For convenience, "group performance" variables have also been created. Group 
performance variables represent a collection of related MIB variables and are identified 
by the  icon. 
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The Profile Manager 

 

If you add more than one variable to the profile, each new variable will be assigned a new line color; or you 
can select a line color from the Line Color drop-down list. You also have the option of entering a 
Description for each variable. Graphing starts when you click the Done button. 

Go to the Statistics Properties Data window to configure the profile data properties, then go to the Statistics 
Properties Display window to configure the profile display properties. When you are ready to save the 
profile, select Save Profile from the File menu. Click here for more information on saving profiles. 

Scheduling a Profile to Run 

The maximum data collection size is 999 days. When the specified data collection size is reached, new 
incoming data will begin to overwrite the oldest data. For example, if you specify a data collection size of 
23 hours, new incoming data will begin to overwrite the oldest data after 23 hours of data have been saved 
to the server. However, you can schedule profiles to start and stop at specific intervals by specifying a data 
collection size (e.g., 23 hours) and scheduling the profile to run regularly at a specified time. For example, 
you could specify a data collection size of 23 hours and schedule the profile to run at a specific time each 
week. 

Note: The data collection size for a profile is configured using the Statistics Properties 
Data window. 

Warning: When the profile collection process is restarted, old data is progressively 
erased and replaced with new data when the profile's collection size is reached. 
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You can run a regularly-scheduled sampling of the profile. When a profile is set up with this scheduling 
feature, the profile will actually stop running when the data collection interval is reached. The profile will 
then automatically re-start at the specified interval. 

To set up a schedule, select the profile and click on the Schedule button. On the Schedule Profile Window, 
set the beginning date and time (the default is the current date). To start the scheduling at a future date, 
click on the arrow in the Start Time field and select a date from the drop-down calendar. Select the interval 
from the Time Interval drop-down menu (days or weeks). Enter an interval in the Time Interval field (e.g., 
1 day). 

For example, if you schedule the profile to begin running on the current date, and set the Time Interval for 
1 week, the profile would run until is reached the maximum data collection interval for the profile (e.g., 23 
hours), and then stop. The profile would then automatically re-start after 1 week and run again for 23 hours. 

 

Restarting a Profile 

When a profile is not running on the server (that is, the variables in the profile are not being polled and no 
statistical data is being saved on the server), you can restart the profile by selecting it and clicking the Run 
button. When a profile is running on the server, the Activity field in the Profiles Table displays "Running." 

Note: When a profile is loaded on the client, enabling automatic polling for the profile 
via the Statistics Properties window, or turning polling on for the profile via the Toggle 
Polling On/Off icon on the Statistics Application Toolbar, is equivalent to starting the 
profile via the Profile Manager's Run button. 
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Stopping a Running Profile 

Whether profiles are loaded on the client or not, they continue to run on the server unless you stop them. 
"Run" means that the variables in the profile continue to be polled and the resulting statistical data is saved 
on the server. When you stop a profile, all polling of the profile's variables stops and statistical data is not 
collected. When a profile is stopped, all statistical data on the server is deleted, unless Save Data File on 
the Save Profile window was enabled when the profile was created. If Save Data File was enabled, 
statistical data on the server is not deleted when the profile is stopped. However, gaps in the saved data will 
result. 

To stop a profile that is running on the server, select the profile and click the Stop button. When a profile is 
stopped, the Activity field in the Profiles Table displays "Not Running." 

Note: When a profile is loaded on the client, disabling automatic polling for the profile 
via the Statistics Properties window, or turning polling off for the profile via the Toggle 
Polling On/Off icon on the Statistics Application Toolbar, is equivalent to stopping the 
profile via the Profile Manager's Stop button. 
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Renaming a Profile 

You can rename a profile by selecting the profile in the Profile Manger window and clicking the Rename 
button. The Rename Profile Window displays, as shown below. Enter the new profile name in the Name 
field and click the OK button. The profile is renamed on the client and on the server. You can only rename 
profiles via the Profile Manger Window. 
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Deleting a Profile 

You can delete a profile from the server (and from the client) by selecting the profile in the Profile Manager 
Window and clicking the Delete button. You can delete a profile when it is running (or not running) and 
when it is loaded on the client (or not loaded on the client). You can only delete profiles via the Profile 
Manger Window. Note that deleting a profile also deletes all statistical data associated with the profile. 
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Loading a Profile 

You can load any profile onto the client (as long as it was previously saved). To load a profile, select the 
profile and click the Load button. If another profile is currently loaded, it is automatically unloaded and the 
requested profile is loaded onto the client. If an unsaved profile is currently loaded, you are asked if you 
wish to save the profile before it is unloaded. The fields below enable you to specify the profile data that 
you want loaded. 

Load Latest Values (the default) 
These fields enable you to load the latest data collected on the server. Click the Load Latest Values button 
if it is not already selected, set the Unit field to Minutes, Hours, or Days, as desired, and set the Value 
field to the desired time value. Click the Load button. You can load a maximum of 999 days worth of data. 

Note: The Load Latest Values fields default to the data collection size for the profile. 
Remember that only time periods when active polling is taking place "count" toward the 
Data Collection Size, so gaps in the data will occur if polling was disabled. 

Load Selected Range 
These fields enable you to load profile data from a specified time period. Click the Load Selected Range 
button and set the From and To fields to the desired date and time before you click Load. 
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Unloading a Profile 

You can unload a profile from the client by selecting the profile that is currently loaded on the client in the 
Profile Manager window and clicking the Unload button. The profile is immediately unloaded from the 
client and the Chart View Window closes. The profile continues to run on the server, however, and can be 
reloaded when desired. You can also unload the current profile by selecting Unload Profile on the File 
menu. 
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Note that if you attempt to unload an unsaved profile, the following message displays: 

 

Click Yes to save the profile before unloading it. The Save Profile window will display, which enables you 
to assign a name to the profile and perform the save operation. Click No to unload the profile without 
saving it first. The following message will display: 

 

Click OK to close and discard the profile, but note that once you have done this there is no way to recover 
the profile.  
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Viewing Multiple Profiles 
A client can only have one Statistics profile open at a time. However, it is possible to view two or more 
profiles simultaneously by running the Statistics Application in additional instances of OmniVista.  

1. With the first profile displayed, right-click on the Statistics icon in the Task Bar and select Run in new 
Window. 

 

When you select Run in new Window, the Profile Manager window opens in a new instance of 
OmniVista, as shown below. Note that additional instances of OmniVista open with the Taskbar, Toolbar, 
and Status Panel hidden. To display these items, go to the View menu and select the item(s) you want to 
display. 
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2. Select the profile you want to open in the new instance of OmniVista, and then click Load. Data will 
start displaying in the new window. 
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3. Resize the windows, so you can see both charts at the same time. 

 

Note that any changes you make to a profile in one instance of OmniVista will be reflected in the other 
instances of OmniVista. For example, if you change one of the line colors in one window, and then open 
that profile in the second window, you will see the new line color. 
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