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1 Welcome to Keynote
Keynote is a robust tool for creating professional-quality presentations. Taking advantage of 
the superior graphics capabilities of Mac OS X, Keynote brings your presentations to life with 
crisp graphics and sleek text.

Keynote’s powerful and simple tools make it easy to build dynamic, media-rich presentations. 
Use the handsome and versatile themes that come with Keynote to create persuasive 
presentations. Or customize them to suit your specific needs. With Keynote, you can be as 
creative as you want.

The Power of Keynote

Keynote lets you make your point with a wide range of media. Incorporate a multitude of 
graphics types, text, movies, and sound. Present your data using any of the charts and tables 
built right into Keynote.
 7



     
Keynote’s Features at a Glance

Quality and Flexibility

Keynote lets you add most standard file types to your presentation—including PDF, GIF, TIFF, 
JPEG, PICT, and QuickTime—with drag-and-drop ease, and flawlessly displays crisp graphics, 
smoothed text, and different levels of transparency.

Set off your points with
formatted text or image bullets.

Add shadows and 
transparency to your 
images to create captivating 
visual effects.

Get smooth text in any
font size.

Drag items from your desktop to
add them to your slides. Resize

and manipulate graphics with
sharp results every time.
8 Chapter  1  



    
Tools for Making Your Point

Keynote gives you elegant charts, stylish tables, and animated object builds to display 
information in effective ways.

Formatting charts, 
tables, text, graphics, 
and more is a snap with 
the inspectors.

In the Chart Inspector, choose from
eight different chart types, including

pie charts, bar charts, and line charts.

Use the slide navigator 
to see your entire 
slideshow at a glance.

Type or paste your data into 
the Chart Data Editor.
 Welcome to Keynote 9



    
Ease of Use Features

Keynote’s theme-based designs let you create inventive presentations in a snap, and the 
alignment guides and slide navigator make it simple to keep your presentation organized.

Animate your slides with object 
builds, which draw your tables 
or other items onto the slide as 
you talk through them.

Live feedback when dragging 
objects makes it easy to resize 
and place graphics.

Use outline view to view 
and rearrange the bulleted 
points on each slide.

Alignment guides and position and size tags 
help you size and position objects precisely 
and consistently on the slide canvas.

A variety of handsome themes and 
master slides make it easy to create 
professional presentations with an 
elegant design.
10 Chapter  1  



                    
Installing Keynote

To install Keynote:

• Insert the Keynote disc in your computer’s optical drive, and then double-click the 
installation icon.

Learning to Use Keynote

To get the most from Keynote, consult these resources:

User’s Guide

This guide describes the features of Keynote and shows you how to use it. A full-color, PDF 
file of this guide can also be found at www.apple.com/support/keynote.

Onscreen Help

To see the help, choose Keynote Help from the Help menu in Keynote. You can browse 
through the table of contents to find a specific topic, or enter a question in the search field 
to find an answer about how to accomplish a task.

Help tags are also available for many of the items in the Keynote window and the inspectors. 
To see the help tags, let the pointer rest over an item for a couple of seconds.

Sample Document

Keynote comes with a sample document that demonstrates the robustness and flexibility of 
this application. You can use the designs and elements used in this document to enhance 
your own presentations by copying and pasting bullets, chart styles, and background images, 
or by employing the same layouts and object build styles.

To open the Keynote sample document:

m In Keynote, choose File > Open Samples.

Quick Reference Card

The quick reference card lists keyboard shortcuts for Keynote as well as at-a-glance notes 
about how to use the inspectors. You can also find keyboard shortcuts by choosing Help > 
Keyboard Shortcuts or searching for “keyboard shortcuts” in the onscreen help. A full-color, 
PDF of the quick reference card can also be found at www.apple.com/support/keynote.

Web Resources

Go to www.apple.com/keynote to get the latest software updates and information. Keynote 
products can also be purchased on the web.
 Welcome to Keynote 11



         
To find out about Keynote products and get up-to-date information:

m Choose Help > “Keynote on the Web.”

Technical Support

A variety of support options are available to Keynote users. For more information, see the 
AppleCare Software Service and Support Guide that comes with your Keynote 
documentation or visit www.apple.com/support on the web.

The Keynote Window

The Keynote window contains three sections—the slide canvas, slide organizer, and the notes 
field—that let you see detailed views of your slides and slideshow as you work. It’s easy to 
keep your slides organized and navigate through even long slideshows.

Organize your slides by creating a visual 
outline of your slide presentation. You can 
choose to view a graphical thumbnail of 
each slide or a text outline.

Add notes about individual slides in this 
field. You can refer to these notes during 
your presentation, though viewers won’t 
see them.

Customize the toolbar
to include the tools you

use most often.

The slide canvas is where you design
each individual slide. Type text or
drag files from other applications.
12 Chapter  1  



                
Slide Canvas

The slide canvas is where you design each slide. You can easily drag graphics files, movie 
files, and even sound files to the canvas to add them to your slideshow. You create a 
slideshow using a theme, which lets you work with a family of master slides to create a 
handsome and cohesive look throughout your presentation. Different master slides within 
each theme make it easy to add titles and bulleted text in effective visual layouts.

As you work on designing your slides, you may want to zoom in or out to get a better view at 
what you are doing.

To zoom in or out on the slide canvas:

m Choose a zoom level from the pop-up menu at the bottom left of the slide canvas. Or you 
can choose View > Zoom > [zoom level].

Slide Organizer

You can organize the slides in your presentation using the slide organizer at the left side of 
the Keynote window. The slide organizer allows you to “indent” your slides so that you can 
group them as you work. You can also choose to hide slides that you don’t want to appear in 
your slideshow. For more information about using the slide organizer, see “Organize your 
slides” on page 26.

The slide organizer has two views: navigator view, which is most useful for graphics-intensive 
presentations, and outline view, best for text-heavy presentations. 

Navigator View

In navigator view, the slide organizer displays a thumbnail image of each slide in your 
presentation, which makes it easy to see the flow of graphics-rich presentations.

To help you organize your presentation as you work, you can group slides by indenting them, 
creating a “visual outline” of the entire slideshow. Disclosure triangles allow you to show or 
hide groups of slides. You can also “skip” slides so that they will not appear when you present 
your slideshow.

To show navigator view:

m Choose View > Navigator (or click View and choose Navigator in the toolbar).
 Welcome to Keynote 13



             
You can also drag the bar at the top of the navigator view to see the master slides. Use the 
master slides to design your own themes and master slide layouts. For information about 
designing your own themes and master slide layouts, see Chapter 9, “Designing Your Own 
Master Slides and Themes.”

To indent slides:

1 In navigator view, select the slide you want to indent. To select multiple slides, hold down the 
Shift key and select the first and last slides in a range.

2 Drag the selected slides to the right until a blue triangle appears above them.

3 Drag the slides further to the right to indent them another level.

You can create as many outline levels as deep as you need by dragging slides further to the 
right.

To move slides to a higher outline level:

m Drag the selected slides to the left.

See the graphics on each of 
your slides at a glance.

Drag slides to indent them. This 
helps you organize them while 
working on your presentation.

Drag the bar at the top of 
navigator view to reveal the 
master slides above.

Click the disclosure triangles 
to show or hide groups of 
indented slides.
14 Chapter  1  



           
To show or hide a group of slides:

m Click the disclosure triangle to the left of the first slide in the group.

To skip or include selected slides when you play your slideshow:

m Choose Slide > Skip Slide to skip a slide.

m Choose Slide > Don’t Skip Slide to include a skipped slide.

Outline View

Outline view shows the text content of each slide in your slideshow. This view may be most 
useful for seeing the flow of text-rich presentations. All of the titles and bullet points appear 
legibly in the slide organizer.

Outline view provides an easy way to order and re-order your bulleted points as you organize 
your presentation. You can add bullet points to existing bulleted text directly in the slide 
organizer. You can also drag bullets from one slide to another, or drag them to a higher or 
lower level within the same slide.

In outline view, you see
an outline of the text in

your slideshow, with
titles and bulleted

points listed.

As in navigator view, you can skip 
slides so that they will not appear 
when you play your slideshow.

Drag bullets left or right to 
move them to a higher or 
lower outline level.

Drag bullets to another slide 
or drag them to create a 
new slide.

Double-click a slide icon to 
hide its bulleted text in the 
slide organizer.
 Welcome to Keynote 15



                               
To show outline view:

Choose View > Outline (or click View and choose Outline in the toolbar).

To add more bulleted points to a slide in outline view:

1 Select the slide in the slide organizer.

2 Select the bulleted line just above where you want to add new bulleted points.

3 Press the Return key to insert a new line and type your text.

To select bulleted text in outline view:

m Click a bullet to select the bullet and its text.

m Place the pointer to the left of text and drag down or to the right to select the bullet, its 
text, and all its subordinate bullets.

To move bullets to a higher outline level on the same slide:

m Drag the selected bullets to the left, staying within the same slide, until a blue arrow 
appears above them, or press Shift-Tab.

To move bullets to a lower outline level on the same slide:

m Drag the selected bullets below the bullets where you want to position them or press Tab.

To move bullets from one slide and create a new slide:

m Drag the selected text to the left of the other bullets on the slide until a blue triangle 
appears above it.

To move bullets to another slide:

m Drag the selected bullets out of the current slide to a different slide.

To place all slide bullets subordinate to the bullets on the previous slide:

m Drag the slide icon to the right.

All the bullets on the slide are moved to the previous slide. The top bullet is set to the same 
outline level as the last bullet on the previous slide.
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Notes Field

The notes field is an area in which you can type or view notes for each slide. These notes are 
not visible in the slideshow presentation but they can be viewed on an alternate display or 
printed as a talking aid to use during your slideshow presentation.

To see the notes field:

m Choose View > Show Notes (or click View in the toolbar and choose Show Notes from 
the pop-up menu).

To learn about how to print or view your notes during slideshow playback, see Chapter 8, 
“Viewing Your Slideshow.”

Toolbar

The Keynote toolbar gives you one-click access to many of the actions you’ll use when 
creating presentations in Keynote. As you work in Keynote and get to know which 
commands you use most often, you can add or remove buttons in the Keynote toolbar to 
make the most common commands easily available.

To customize the toolbar:

1 Choose View > Customize Toolbar.

2 To add an item to the toolbar, drag its icon to the location in the toolbar where you want to 
place it.

3 To remove an item from the toolbar, drag it out of the toolbar.

4 To make the toolbar icons smaller, select the Small Icons checkbox.

5 To display only icons or only text, choose an option from the Show pop-up menu.

You can restore the default set of toolbar buttons by dragging the default button box to the 
toolbar.

The notes field is an area where you 
can keep track of what you want to 
say as you show each slide.
 Welcome to Keynote 17



                             
Keynote Tools

Inspector Window

The Inspector window makes it easy to format your slides as you work. Most elements of 
your slideshow are formatted using the eight panes of the Inspector window.

To open the Inspector window:

m Choose View > Show Inspector (or click Inspector in the toolbar).

You can have several inspectors open at once to facilitate your working style.

To open more Inspector windows:

m Choose View > New Inspector.

Fonts Window

Keynote uses the standard Mac OS X font selection window, so you can select from any of the 
fonts available on your system.

To open the Fonts window:

m Choose Format > Font > Show Fonts (or click Fonts in the toolbar).

Colors Window

You can use the standard Mac OS X color selection window to choose any color for text, 
drawn objects, or shadows.

To open the Colors window:

m Choose View > Show Colors (or click Colors in the toolbar).

Shortcuts

Many of the menu commands and shortcuts for moving around the slide organizer or 
manipulating objects on the slide canvas can be accomplished using the keyboard. A 
comprehensive list of keyboard shortcuts is available in onscreen help.

To find the list of keyboard shortcuts:

m In Keynote, choose Help > Keynote Keyboard Shortcuts.

Many commands are also available in shortcut menus that you can access directly from the 
object you are working with.

To access shortcut menus:

m Hold down the Control key and click an object.

Shortcut menus are especially useful for working with tables and charts.
18 Chapter  1  
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2

2 Creating a Presentation

Keynote takes advantage of all the powerful graphics capabilities of Mac OS X, so you can 
design stunning and highly visual presentations. This chapter outlines the basic tasks and 
steps you might go through to complete a professional-quality slide presentation.

Keynote Documents

When you create a slide presentation in Keynote, you create a Keynote document. The entire 
slideshow, including all of the graphics and any chart data, is contained within this one 
document, which can be easily moved from one computer to another. If you add movies or 
sounds to your document, you can choose to save them as a part of your Keynote document 
by selecting an option in the Save dialog.

Your finished presentation can be viewed in several ways, including watching it on your 
computer, projecting it from your computer to a screen, printing it, or exporting it to 
QuickTime, PowerPoint, or PDF format so that it can be viewed on other computer 
platforms. For more information about viewing options, see Chapter 8, “Viewing Your 
Slideshow.”

Step 1: Select a theme

To start a Keynote project from scratch, double-click the Keynote icon to open Keynote, and 
then select a theme.

Keynote Themes

By using a Keynote theme, you can create a presentation with a cohesive look and feel with 
little or no design work of your own. Each Keynote theme includes a set of slide layouts or 
templates (called master slides) with styled text, bullets, and other formatting features 
already set for you. Choose a look from among a broad variety of textures and moods. It’s 
like having a great design house at your fingertips!
 19



To apply a theme to your slide presentation:

1 If the theme selection dialog does not appear when you first open Keynote, choose File > 
Choose Theme (or click Themes in the toolbar).

2 Select a theme in the theme selection dialog.

3 Choose a screen resolution from the pop-up menu labeled “Choose presentation size.” Most 
projectors work best with slides at the 800 x 600 size. Newer ones may be able to display 
slides well at 1024 x 768.

4 Click Choose Theme.

You can choose whether to have the theme selection dialog appear whenever you open a 
new Keynote document.

To choose whether the theme selection dialog appears when opening a new 
document:

1 Choose Keynote > Preferences.

2 Select the checkbox labeled “Show theme selection dialog when creating new documents” to 
make the dialog appear. Deselect the checkbox if you don’t want the dialog to appear.

If you want to modify themes or create your own, see Chapter 9, “Designing Your Own 
Master Slides and Themes.”

Importing a PowerPoint or AppleWorks Presentation

If you already have a slide presentation that you created in Microsoft PowerPoint or in 
AppleWorks, you can import it into Keynote and continue to work on it.

To import a PowerPoint or AppleWorks document:

m Drag the PowerPoint or AppleWorks document icon onto the Keynote application icon. 
The document opens in Keynote.

Keynote imports the slides in the PowerPoint or AppleWorks documents and creates a 
custom theme based on those slides.

You can also export Keynote documents back to PowerPoint. For more information, see 
“PowerPoint” on page 85.

Step 2: Design your slides using master slides

When you select a theme, a single slide appears in the slide organizer. You can begin working 
in this first slide, adding text, graphics, and sound. You can also add new slides to the project 
as you work.
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To add more slides:

m Choose Slide > New Slide (or click New in the toolbar). A new slide appears in the slide 
organizer.

Select a slide in the slide organizer to work on it.

As you work, you’ll want to use different slide layouts to place your text and graphics on 
individual slides. Master slides provide the layouts you are most likely to need.

Using Master Slides

Each Keynote theme includes a family of master slides. Each master slide has a different 
layout for title and body text, as well as blank areas for graphics.

Each theme comes with several different master slide layouts, such as the examples 
described here:

Each new slide you create takes on the master slide layout of the slide that was selected 
when you chose Add Slide.

You can change the master slide layout for any individual slide to best suit the content you 
want to place on that slide.

To change the master for a slide:

1 Select the slide whose master slide layout you want to change.

2 Click Masters in the toolbar.

3 Choose a master slide in the list.

For more information about modifying themes and master slides, see Chapter 9, “Designing 
Your Own Master Slides and Themes.”

Master slide Recommended use

Title Title page or section titles within your presentation

Body General content pages that require bulleted text; the entire slide 
is covered with a body text box

Blank Graphics-heavy layouts

Title & subtitle Title page or section titles requiring a subtitle

Title & Bullets - Left Content pages on which you can place bulleted text on the left 
and a graphic on the right

Title & Bullets - Right Content pages on which you can place bulleted text on the right 
and a graphic on the left
 Creating a Presentation 21



Adding Text

Depending on which master slide you use, you may see text boxes for title text or body text. 
Title text is generally large. Body text is generally bulleted text, although some master slides 
offer non-bulleted body text. Choose a master slide with the combination of title text and 
body text that best suits the slide’s content.

To add title text to a slide:

m Double-click in a title text box in the slide canvas and type your text.

To add bulleted text:

m Click in a bulleted body text box in the slide canvas and begin typing. Bullets automatically 
appear, styled to match the theme you’re working in. Press Return to move to the next 
bulleted line. Press Tab to indent a bulleted line. Press Shift-Tab to move the bulleted line 
to a higher indent level.

You can change the look of the text and bullets in any of your slides using the Text Inspector 
and the Graphic Inspector. For more details about how to use inspectors to change text, 
including how to change the style of text bullets or add text without bullets, see Chapter 3, 
“Working With Text, Graphics, and Other Media.”

Double-click in a title
text box and type a title.

The font and text size
are already set for you.

Double-click in a body
text box and type to

create bulleted text. The
bullet style, font, and

text size are already set.

Drag a graphic file from 
the Finder and place it 
on your slide.
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To open the Inspector window:

m Choose View > Show Inspector (or click Inspector in the toolbar).

Adding Graphics

To add a graphic to a slide:

m Drag the graphic file from the Finder to the slide canvas or choose Edit > Place > 
Choose and select the graphic file in the navigation dialog, and then click Place.

You can also drag a graphic file directly from the Finder to the slide organizer to automatically 
create a new slide with the graphic placed on it.

You can edit and manipulate graphics to get the look you want, including changing the 
colors, alignment, and orientation. You make these adjustments using the Inspector window. 
Object placement, size, and orientation are set in the Metrics Inspector. Shadow, fill color, 
and opacity are set using the Graphic Inspector. For more information about setting 
attributes using the inspectors, see Chapter 3, “Working With Text, Graphics, and Other 
Media.”

To present complex or numerical data in an easily digestible visual format, Keynote supplies 
smartly styled tables and charts that fit with each theme. For more information about adding 
tables and charts, see Chapter 5, “Creating Tables,” and Chapter 6, “Creating Charts.”

Using Alignment Guides and Rulers

As you move your text and graphics around on the slide canvas, you will notice alignment 
guides appearing and disappearing. These guides are built into the master slides to help you 
center and align objects on the canvas. They appear whenever the center or edge of an 
object aligns with the center or edge of another object, or with the center of the slide canvas. 
You can create your own alignment guides to help you place slide elements precisely in the 
same position from one slide to the next.

In addition to alignment guides, you will also notice position tags that display the X and Y 
coordinates of the top left corner of each object’s container box as you move it around the 
slide canvas, or its angle as you rotate it. If you resize an object, size tags appear, displaying 
the height and width of the object.

You can also turn on rulers to help you align objects on the slide canvas. Rulers show you 
how far (in inches, centimeters, pixels, or percentage of the distance across the slide) an 
object is from the top of the slide, and how far from the left edge of the slide.

To turn rulers on:

m Choose View > Show Rulers.

To change the units of measure in the rulers:

1 Choose Keynote > Preferences.
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2 Choose Pixels, Centimeters, Inches, or Percentage from the Ruler Units pop-up menu.

To place the ruler’s horizontal origin point at the left edge of the slide:

m In Keynote Preferences, deselect the checkbox labeled “Place origin at center of ruler.”

After you’ve placed graphics exactly where you want them on the slide, you can lock them to 
the slide canvas to prevent them from being accidentally moved as you work.

To lock an object to the slide canvas:

m Select the object and choose Arrange > Lock (or click the Lock button in the toolbar).

You cannot edit an object that has been locked to the slide canvas. To unlock an object, 
choose Arrange > Unlock (or click the Unlock button in the toolbar).

Changing the Behavior of Alignment Guides

You can place your own alignment guides on any slide to help you line up objects where you 
want them.

To place alignment guides on a slide:

1 Choose View > Show Rulers to make the rulers appear at the top and left side of the slide 
canvas.

2 To create a vertical alignment guide, place the pointer on the ruler on the left side of the 
slide canvas and drag to the right. A yellow alignment guide appears. Drag it to wherever you 
want on the slide canvas.

3 To create a horizontal alignment guide, place the pointer on the ruler at the top of the slide 
canvas and drag downward. Drag the alignment guide that appears to where you want it on 
the slide canvas.

Even if you place your own alignment guides on a slide canvas, they will not appear during 
the slideshow presentation. They are only visible when editing the slide.

You can also place your own alignment guides on a master slide so that they are available on 
any slide that is based on that master slide. To read about setting your own alignment guides 
on master slides, see “Adding Alignment Guides” on page 90.

To remove alignment guides that you have placed on a slide:

m Drag the alignment guide off the edge of the slide canvas.

If alignment guides are getting in the way as you work, you can temporarily disable them.

To temporarily disable alignment guides:

m Hold down the Command key while dragging an object.

You can turn alignment guides and size and position tags on or off in Keynote Preferences. 
You can also have alignment guides appear only when object edges are aligned, or only when 
object centers are aligned.
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To change the behavior of alignment guides and size and position tags:

1 Choose Keynote > Preferences.

2 Deselect the checkbox labeled “Show size and position when moving objects” to hide the 
size and position tags.

3 Deselect the checkbox labeled “Show guides at object center” to turn off the guides that 
appear when the center of the moving object aligns with another object or the center of the 
slide canvas.

4 Select the checkbox labeled “Show guides at object edges” to turn on the alignment guides 
that appear when the edges of the moving object align with another object or the center of 
the slide canvas.

If you want to change the color of alignment guides, you can do that, too.

To change the color of alignment guides:

m Click the Alignment Guides color well in Keynote Preferences, and then select a color in 
the Colors window.

Using the Sample Document and Image Library

For images and ideas in creating your presentations, look in the sample document and the 
Image Library. The sample document demonstrates how slide layouts, transitions, and object 
builds can be used for best effect. The Image Library contains a multitude of images that you 
can copy and paste into your own documents.

To use the sample documents:

1 Choose File > Open Samples. A Finder window opens containing the sample document.

2 Double-click the sample document icon.

3 Choose View > Play Slideshow (or click Play in the toolbar) and watch the sample 
presentation.

4 When the slideshow is over, click individual slides and read the text in the notes field to see a 
description of how the effects were created.

To learn more about slide transitions and object builds, see Chapter 7, “Slide Transitions and 
Object Builds.”

To use the Image Library:

1 Choose File > Open Image Library. A Finder window opens containing the Image Library.

2 Select an image and drag it to the slide canvas or the slide organizer.
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Step 3: Organize your slides

Change the order of slides in your presentation by dragging them to the place you want in 
the slide organizer.

Navigator View Versus Outline View

Keynote provides two ways to view the overall organization of your slideshow, depending on 
how you work best.

In navigator view, the slide organizer shows each slide as a thumbnail image. The thumbnails 
provide a graphical view of the contents of each slide.

In outline view, the slide organizer displays the title text and bulleted text on each slide.

To choose a view:

m Choose View > Outline View or View > Navigator View (or click View in the toolbar and 
choose Outline View or Navigator View from the pop-up menu).

Grouping Slides

You can organize your slides into an outline by indenting related sets of slides. You can also 
show or hide individual slides or groups of slides as you work. Indenting or hiding slides in 
the slide organizer does not affect the flow of the final slideshow presentation. It is only a 
tool to make it easier to organize and navigate through large sets of slides.

To indent a slide or group of slides:

1 Select the slide or set of slides you want to indent.

2 Press the Tab key or drag the selected slide(s) to the right until you see a blue triangle above 
them at the indentation level where you want to place them.

To show or hide a group of slides:

m Click the disclosure triangle to the left of the first slide in the group.

Click the disclosure
triangles to show

or collapse a group
of slides.

Indent slides as many 
levels deep as you want.

Drag slides or groups of 
slides to rearrange them 
in the slideshow.
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To delete a slide:

m Select the slide in the slide organizer and press the Delete key.

To move a group of slides:

m Select the first slide in the group and drag the group to a new location in the slide 
organizer. A blue triangle appears above the slides to show where they will be placed.

For more details about working in navigator view or outline view, see “Navigator View” on 
page 13 and “Outline View” on page 15.

You can also keep track of the details about each slide in the notes field. You can type 
anything you want in the notes field; for example, you can jot a quick summary describing 
each slide as you develop the narrative flow of your presentation.

To add notes to the slide:

m Choose View > Show Notes and type your notes in the field that appears below the slide 
canvas.

Saving Your Work

To save a Keynote document:

1 Choose File > Save As.

2 Type a title for the document and choose the location where you want the document to 
appear.

3 If you have added sound or movies to the slideshow that you wish to include as part of the 
Keynote document, select “Copy movies into document.” If you do not select this option 
then sound and movie files will not appear in the presentation if it is transferred to another 
computer.

Note:  For fonts to be displayed in a Keynote presentation, they must be in the Fonts folder 
of the computer where you are playing the presentation when you first open Keynote. If 
fonts are not available on the computer, an alert message appears. To correct the situation, 
install the fonts you need on the computer from which you will play your Keynote slideshow.

4 Click Save.

If you want to save progressive versions of your document as you continue to make changes, 
select that option in Keynote Preferences.

To back up the previous versions of your Keynote document:

1 Choose Keynote > Preferences.

Warning  If you delete the first slide in a group of slides, all the slides indented below it 
are also deleted. If you accidentally delete slides, you can recover them immediately by 
choosing Edit > Undo Delete.
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2 Select the checkbox labeled “Backup previous version when saving.”

3 Choose File > Save.

Each time you save your document with this preference selected, the current version of the 
document (including your changes) appears. In the same folder, another file with the word 
“backup” appended to the filename appears. The backup file does not include any changes 
you made since you last saved the document. (The backup version does not appear the first 
time you save a document.)

Step 4: Play your slideshow

You can show your finished slide presentation on your computer’s display, or project it onto 
a screen for a larger audience.

To play the presentation on your computer:

1 Open the Keynote document that you want to play by double-clicking its icon in the Finder.

2 Choose View > Play Slideshow (or click Play in the toolbar).

3 Click to advance to the next slide or through any object build on the slide.

4 Press Q or Esc to end the slideshow.

Keynote provides many options for sharing your slideshow, including viewing it on a 
projector or secondary display, creating a QuickTime movie, PDF file, or PowerPoint 
presentation, or printing it. For more details about viewing and sharing your slideshow, see 
Chapter 8, “Viewing Your Slideshow.”
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Working With Text, Graphics,
and Other Media

 

In the Keynote slide canvas you can easily manipulate text, graphics, and other types of 
media all in the same workspace. Placing and editing text in Keynote is as easy as working in 
any text editor. Manipulating graphics, sound, and movie files is just as simple. This chapter 
describes in detail how to add different media elements to your slides.

 

Editing Text and Text Properties

 

Choose a master slide with the layout that suits your needs and enter your text by typing in 
the title text box or body text box on the slide. (To learn about choosing a master slide, see 
“Using Master Slides” on page 21.)

 

To enter and edit text in a text box:

 

1

 

Double-click the text box to place the text cursor inside the box.

 

2

 

If the text box is empty, type your text.

 

3

 

If you are editing text already in the box, double-click to select it and make your changes.

 

4

 

Adjust the text color, alignment, and font using the Text Inspector or Fonts window, as 
described in “Changing Text Properties,” next.

If you want a text box without bullets, you can add a “free text box” to the slide.

 

To create a free text box:

 

1

 

Choose Edit > Place > Text. A text box appears in the center of the slide. ( You can also click 
Text in the toolbar.)

 

2

 

Double-click in the text box and type the text you want to add to the slide.

 

Note:  

 

You cannot use formatted bullets in free text boxes. To get formatted bullets, you 
must use a body text box. See “Adding Title Text and Body Text” on page 39.
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3 Click outside the text box when you’re finished typing, or press Command-Return to stop 
editing text and select the text box. Selection handles appear on the sides of the text box.

4 Drag the selection handles to make the text box wider or more narrow.

Note:  Free text boxes automatically grow or shrink vertically to accommodate the length of 
your text. You cannot make them taller by dragging. If you want to make a free text box 
longer without expanding its contents, drag the selection handles to make the box more 
narrow and force it to grow vertically.

Text boxes can be moved to any position on the slide. See “Resizing, Moving, and Layering 
Text or Graphic Objects” on page 40.

Changing Text Properties

Once you have added text to your slide, you may want to adjust its look, including the font, 
color, or spacing of lines and words. For bulleted text, you can select from a range of bullet 
and numbering styles. You can even use small pictures as bullets. You make most text 
changes using the Text Inspector and Fonts window.

You can also create engaging visual effects with text by changing its color, shadow, opacity, 
and orientation on the screen. To learn more about these, see Chapter 4, “Changing Object 
Properties.”

To change the font:

1 Choose Format > Fonts > Show Fonts (or click Fonts in the toolbar). The Fonts window 
opens.

2 Select the text you want to change.

3 Select a font type and size in the Fonts window.
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Using the Text Inspector

In the Text Inspector, you can adjust all basic text properties in your slides. Use it to change 
the color, alignment, and spacing of selected text. If you select bulleted text, you can also 
change the bullet style.

To open the Text Inspector:

m Choose View > Show Inspector (or click Inspector in the toolbar) and click the Text 
button.

To change text color:

1 Select the text you want to change.

2 In the Text Inspector, click the color well. The Colors window opens.

3 Select a color in the Colors window.

Text within a text box can be justified left, right, center, or evenly spread across the box. 
Bulleted text can also be placed near the top, center, or bottom of the text box.

To adjust text alignment:

1 Select the text you want to change.

2 Click the horizontal or vertical alignment buttons at the top of the Text Inspector.

To adjust the spacing between lines of text:

1 Select the text you want to change.

2 In the Text Inspector, drag the Line slider to adjust the line spacing. Dragging the slider to the 
left brings the selected lines closer together; dragging it to the right moves them farther 
apart.

Drag the sliders
to adjust character

and line spacing for
selected text.

Click the color well to
change the color of

selected text.

Click a button to justify text left, 
right, center, or across a text 
box, or to place it at the top, 
center, or bottom of the text box.

Make selections to format the bullet 
image, style, position, and size.
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To adjust the character spacing:

1 Select the text you want to change.

2 In the Text Inspector, use the Character slider to change the space between the characters. 
Dragging the slider to the left brings the letters closer together; dragging it to the right 
moves them farther apart.

To adjust the spacing between lines of bulleted text:

1 Select the bulleted text you want to change.

2 In the Text Inspector, drag the Bullet slider. Dragging the slider to the left brings the selected 
lines of bulleted text closer together; dragging it to the right moves them farther apart.

Creating Bulleted Text

You can choose from a multitude of bullet styles to create the look you want. You can select 
numbered bullets, letters, or special characters. Or you can use an image of your own as a 
bullet.

When you select a style for a bullet, that style is applied only to the bullet or bullets you have 
selected; you can apply different styles to bullets in the same text box by selecting them and 
formatting them individually or in groups.

To create bulleted text:

1 Apply a master slide with bulleted body text. (To see how to apply a master slide, see “Using 
Master Slides” on page 21.)

2 Click in the body text box and type your text. Press Return to move to the next bulleted line. 
Press Tab to indent the line. Press Shift-Tab to move a bulleted line to a higher outline level, 
or select the bullet and text and drag to the left until a blue arrow appears above the bullet.

3 Click outside the text box when you’re finished typing, or press Command-Return to stop 
editing text and select the text box. Selection handles appear on the sides of the text box.

4 Drag the selection handles to make the text box wider or more narrow.

To change the style of bullets:

m In the Text Inspector, choose an option from the Bullets & Numbering pop-up menu.

You can choose text bullets, image bullets, or numbered bullets. You can also choose None if 
you prefer no bullets.
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If you choose Text Bullet, type the character or characters you want to use in the field below 
the pop-up menu. ( You can use any keyboard characters.) After typing your bullet character, 
press Return. Click the color well and select a color for the bullet. Then set the bullet size 
and vertical alignment using the fields on the right.

If you choose Number, you can choose from a variety of number formats in the Style pop-up 
menu.

If you choose Custom Image, you must select one of your own image files in the Finder. Your 
custom image appears in the image well. You can adjust size and vertical alignment using the 
fields on the right. Normally, even a large image is scaled very small to be used as a text 
bullet. Selecting the “Scale with text” checkbox will maintain the image–to–text size 
proportion you set in the Size field, even if you later choose a larger font.

To change the image used as a bullet, drag the new image from the Finder to the image well 
or click Choose to browse for the image using the Open dialog.

If you choose Image Bullet, you can select from a range of bullet designs. You can adjust the 
size and vertical alignment using the fields on the right. Selecting the “Scale with text” 
checkbox maintains the image–to–text size proportion you set in the Size field, even if you 
later choose a larger font.
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Setting Text Tabs

All text boxes have default tabs already set. You can see the tab stops on the horizontal ruler 
when you choose View > Show Rulers and select some text on a slide.

By changing the tabs, you can indent bulleted text as deeply as you want. You can also format 
paragraph text in free text boxes with your preferred tab stops.

To change tabs:

1 Select the text you want to adjust.

2 On the horizontal ruler, drag the blue tab icons to change the location of the tab stops.

To change a tab to a different type of tab, Control-click the tab icon and choose a type from 
the shortcut menu. Or click the tab icon in the ruler repeatedly until the type of tab you want 
appears.

In addition to regular tabs, you can also adjust tabs for bulleted text. You can adjust how far 
each outline level is indented and set the spacing between the bullet and its text. You can 
also set the margins for bulleted text that wraps to the next line.

To set bulleted text tabs:

1 Select the bulleted text you want to adjust.

2 Drag the small, square tab icon to the position where you want to indent the bullet.

3 Drag the rectangular tab icon to the position where you want the text to begin following the 
bullet.

4 Drag the downward arrow on the left side of the ruler to set the left margin for bulleted text 
that wraps to the next line.

5 Drag the downward arrow on the right side of the ruler to set the right margin.

Retaining or Undoing Your Style Changes

If you make style and formatting changes on a slide and then decide that you want to return 
to the theme’s default styles, you can reset the slide with the default styles.

Tab icons appear on the 
ruler when you select 
text on a slide.

Choose from among 
these tab types.
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To reset the slide with theme default styles:

m Choose Format > Reapply Master to Selection.

After you’ve set your preferred styles throughout your Keynote document, you may choose 
to change the entire document to another theme. Normally, when you apply a new theme, 
all styles are reset to the theme defaults. You can retain your changes when you apply a new 
theme by making a selection in the theme selection dialog.

To retain style changes when applying a new theme:

1 Choose File > Choose Theme to open the theme selection dialog.

2 Select a new theme.

3 Select the checkbox labeled “Retain changes to theme defaults.”

4 Click Choose Theme.

Adding Images

You can add many types of graphics to your slide presentation, including photos, graphic files 
created in other applications, and simple objects that you can draw directly in Keynote.

Keynote accepts all standard graphic file formats, including the following:

m PICT

m GIF

m TIFF

m JPEG

m PDF

m MOV

Drawing Simple Objects

You can draw basic rectangles, ellipses, triangles, arrows, and lines directly in Keynote.

To draw an object:

1 Choose Edit > Place > [Shape], choosing the shape you want from the list. The selected 
shape appears on the slide. You can also click Shapes in the toolbar and choose a shape from 
the pop-up menu.

2 Drag the selection handles to resize the shape.

You can change the line colors and fill colors of drawn objects. To learn more about changing 
an object’s colors and other properties, see Chapter 4, “Changing Object Properties.”
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Adding Pictures From iPhoto

You can drag images directly from your iPhoto library.

To add an image from iPhoto:

1 Open iPhoto.

2 Find the photo you want to add to your slideshow.

3 Drag the photo from the iPhoto library to the place where you want it to appear on your 
slide.

Adding Other External Graphics

You can easily add graphic files that have been created in other applications to your Keynote 
slides.

To add a graphic file from another source:

m Locate the file you want to add in the Finder and drag it to where you want it to appear 
on your slide. Or choose Edit > Place > Choose and locate the file in the Choose dialog.

You can also include other kinds of graphic objects, such as movies, charts, and tables. To 
learn more about these, see “Adding a Movie or Animation” on page 43, as well as Chapter 6, 
“Creating Charts,” and Chapter 5, “Creating Tables.”

You can adjust the opacity and shadow of graphic objects, as well as make precise 
adjustments to their location and orientation on the slide. To learn more, see Chapter 4, 
“Changing Object Properties.”

Using PDF Files as Graphics

If you intend to make a graphic file much larger or smaller than the original size, consider 
converting it to a PDF file before bringing it into Keynote. PDF files do not lose their 
crispness when they are resized to be much larger or smaller than their original size. Other 
file types may not retain their clarity when they are resized.

PDF files also provide a great way to move tabular data from Excel documents into Keynote. 
If you have extensively formatted tables in Excel that you want to display in your slideshow, 
you can save the Excel spreadsheet as a PDF file and then place that PDF file on a slide as you 
would any other external graphic file.

To convert an Excel file to a PDF file:

1 In your Excel spreadsheet, select the table range you want to display in your slideshow.

2 Choose File > Print.

3 In the Print dialog, choose Output Options from the Copies & Pages pop-up menu.
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4 Select the “Save as File” checkbox.

5 Choose PDF from the Format pop-up menu.

6 Click Save As PDF.

7 Type a name for the PDF file and select a location in the Save dialog, and then click Save.

Working With Photo Cutouts (or Alpha-Channel Graphics)

An alpha channel is an area of transparency within a graphic file. Alpha channels can be used 
to create transparency around irregularly shaped images, such as an image of a tree, so the 
images appear without a colored box around them. Alpha channels can also be used to 
create a transparent region within an image, so that the image acts as a frame. You can see 
this effect in some of the Keynote themes, where you can place your own background 
images behind a “mask” or a “picture frame.”

Choose Output
Options.

Click to save the file as a PDF.

Choose PDF.

Your photograph is placed behind the 
alpha-channel window and can be 
seen through its transparent region, 
so it appears that the photo is in the 
photo-corner frame.

This textured foreground with photo 
corners is an alpha-channel graphic. 
The area between the photo corners 
is a transparent alpha channel.
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To place an image behind a photo cutout window or mask in a Keynote theme:

1 Drag your own image from the Finder to the slide canvas and place it carefully so that it 
covers the cutout window.

2 Choose Arrange > Send to Back (or click Back in the toolbar) to place the new image at the 
bottom level of the slide canvas, behind the window frame.

3 Click the image behind the window to select it and drag to adjust its exact position in the 
window.

Importing Alpha-Channel Graphics Into Keynote

When you bring an alpha-channel image into Keynote, there’s nothing else you have to do to 
make the transparency work. Just place it, manipulate it, and move it to the back or front as 
you might with any other image.

Alpha channels are often found in PDF, TIFF, and PSD files. You can use several different 
applications to create alpha-channel images, including Adobe Photoshop, Corel Draw, Adobe 
Illustrator, and Adobe Acrobat. See the instructions that come with those applications to 
learn how to create alpha-channel images. To learn how to create your own mask or frame in 
Keynote with an imported alpha-channel graphic, see “Creating a Layered Background” on 
page 90.

Changing the Slide Background and Layout

You can use your own image as the background of any individual slide, or change the slide’s 
background color. Make these changes in the Slide Inspector.

To change the slide background:

1 Choose View > Show Inspector to open the Inspector window (or click Inspector in the 
toolbar).
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2 In the Inspector window, click Slide to open the Slide Inspector.

3 Choose a background type from the Background pop-up menu.

m Choose Image Fill to place your own image as a background. Select an image and click 
Choose.

m Choose Color Fill to give the background a single, solid color. Then click the color well 
and choose a color in the Colors window.

m Choose Gradient Fill to color the background with a color gradient. Then click each color 
well and choose colors in the Colors window.

To read more about working with image fills, color fills, and gradient fills, see “Using Color 
and Image Fills” on page 45.

To learn about slide transitions, see “Adding Transitions Between Slides” on page 73.

Adding Title Text and Body Text

Title text and body text are preformatted to match the styles of the theme you are working 
in. Body text includes formatted bullets. To create a slide that includes title text or body text, 
apply a master slide that has the title and body text layout that you need. You can apply a 
master slide in the Slide Inspector.

To change the slide layout:

m Select the slide whose layout you want to change, then choose a master slide from the 
Master & Layout pop-up menu in the Slide Inspector.

Choose a background 
color or image.

Choose a slide layout 
from among the 
master slides.
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You can also apply a new master slide layout by clicking the Masters button in the toolbar and 
choosing a master slide from the pop-up menu.

If none of the available master slide layouts meet your needs, you can apply a blank master to 
the current slide and then place title and body text boxes on it, positioning them as you 
prefer on the slide canvas.

To place a title or body text box on the slide canvas:

m Select the Show Title checkbox or Show Body checkbox in the Slide Inspector. A title or 
body text box appears on the slide.

To learn how to design your own master slide layouts, see Chapter 9, “Designing Your Own 
Master Slides and Themes.”

Resizing, Moving, and Layering Text or Graphic Objects

Once text and graphics are on the slide canvas, they behave very much the same. They can 
be moved in front or in back of one another, and formatted or manipulated in similar ways.

To move an object in front or in back of another object on the slide canvas:

1 Select the object you want to move.

2 Choose Arrange > Bring Forward or Send Backward (or click Front or Back in the toolbar).

3 Repeat step 2 to continue moving the object to the front or back until it occupies the layer 
where you want it to appear.

4 If you want to move an object to the very bottom or top of the stack, choose Arrange > 
Bring to Front or Send to Back.

To resize an object:

1 Select the object to make the selection handles appear. For a body text box, click one of the 
edges of its container box. If the text in a text box is selected, press Command-Return.

2 Move the pointer close to a selection handle until it changes to a double-headed arrow.

3 Drag the selection handle to expand or shrink the object in the direction of your drag. Hold 
down the Option key as you drag to resize the object from its center. Hold down the Shift 
key as you drag to constrain the object’s proportions as it enlarges or shrinks.

To move an object:

1 Click outside the object and then click inside it to make the selection handles appear.
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2 Place the pointer somewhere towards the center of the object and drag the object to a new 
location. Avoid dragging the object by the selection handles because you may inadvertently 
resize the object.

To rotate an object:

1 Select an object to make the selection handles appear.

2 Hold down the Command key and move the pointer toward the selection handles. The 
pointer changes to a curved, double-headed arrow.

3 Drag a selection handle to rotate the object.

Grouping and Locking Objects

You can group objects together so that they can be moved, copied, and oriented as a single 
object. Lock objects to the canvas to avoid inadvertently moving them as you work.

To group objects:

1 Hold down the Command key as you select the objects you want to group on the slide 
canvas. Or drag across the slide canvas until the objects you want to group are selected.

2 Choose Arrange > Group.

To lock objects to the slide canvas:

1 Hold down the Command key as you select the objects you want to lock to the slide canvas 
or drag across the slide canvas until the objects you want to lock are selected.

2 Choose Arrange > Lock (or click Lock in the toolbar).

You cannot edit the individual objects that are part of a group or that have been locked to the 
slide canvas. To edit the objects individually, you must ungroup them by choosing Arrange > 
Ungroup and unlock them by choosing Arrange > Unlock.

Including Sound and Other Media Types

You can add sound files to your project so that recorded music or a narration can accompany 
each slide. In addition, you can add video or Flash movies that will play within a slide.

Keynote accepts any QuickTime file type, including the following:

m MOV

m FLASH

m MP3

m AIFF
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Once you have added a sound file to your slideshow, it remains external to your Keynote 
document. This means that if you transfer your slideshow to another computer or disk 
without also transferring the sound file, the sound will be lost from the slideshow. To prevent 
this, add the file to the slideshow document when you save.

To include a sound file as part of your Keynote document:

1 Choose File > Save As.

2 Select the checkbox labeled “Copy movies into document.”

3 Type a title and choose a location for the document, then click Save.

Adding Music From iTunes

You can bring in music from your iTunes music library.

To add a file from your iTunes music library to your Keynote slideshow:

1 Locate your iTunes music folder on your hard disk. It is usually found in the following 
location:

[Home]/Music/iTunes/iTunes Music

2 Drag a file from the iTunes music folder to the slide canvas.

You can also drag a music file from any other Finder folder to the canvas. A sound icon 
appears on the canvas.

This icon will not be visible when you play the slideshow.

When your slideshow plays, the music will start at the moment this slide appears on the 
screen; the music will stop when you move to the next screen. You can choose to delay 
playing the music or stop playing the music by moving it on or off the screen in an object 
build. To learn more about producing object builds, see “Creating Object Builds” on page 75.

Adding a Slide Narration

One way to add sound to your slideshow is to record a narration for each slide as an MP3 file. 
You can then place the recorded sound files on each slide so that when each slide appears 
during the slideshow presentation, it is accompanied by its prerecorded narration. This may 
be especially useful if you plan to export the slideshow as a self-playing QuickTime movie. To 
read more about exporting your slideshow as a QuickTime movie, see “QuickTime” on 
page 84.
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Adding a Movie or Animation

You can include movies within your slide presentation. You can place movies anywhere on a 
slide so that they play within the visual context of the slide on which they appear.

To add a movie to a slide:

m Drag the movie file from the Finder to the slide canvas where you want it to appear, or 
choose Edit > Place > Choose to browse for the movie file using the Choose dialog.

When your slideshow plays, the movie will start the moment this slide appears on the screen.

Note:  When you add a movie to your slideshow, it remains external to your Keynote 
document. If you transfer your slideshow to another computer or disk without also 
transferring the movie, the movie will be lost from the slideshow. To prevent this, add the file 
to the document when you save it, the same way you would for sound files. To learn how, see 
“Including Sound and Other Media Types” on page 41.

Setting Media Playback Preferences

In the Media Inspector, you can set the playback volume for sound and movies in your 
slideshow and choose to have the media files play through only once, repeat continuously, 
or loop back and forth.

To set the media playback preferences:

1 Choose View > Show Inspector (or click Inspector in the toolbar).

2 In the Inspector window, click Media to open the Media Inspector.

3 Drag the Volume slider to the right to increase the playback volume of your media file; drag 
it to the left to decrease the volume.

4 Choose a repeat option from the Repeat pop-up menu.

Set the
playback volume.

Set playback repeat options.

Select the frame of your
movie that is visible until

you begin playing it.

Use these controls to view the 
movie as you edit your slideshow.
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You can also choose which frame of a movie appears as the first, still frame until you begin 
playing the movie. This is called the poster frame.

To set the movie poster frame:

m In the Media Inspector, drag the Poster Frame slider until the movie displays the image 
you want.
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4

4 Changing Object Properties

If you really want to take your creativity to the next level, Keynote is the tool for you. With 
the design support of Keynote’s themes and the robust graphics of Mac OS X, you can get 
just as much flexibility as you want to work with. This chapter describes more advanced 
features for manipulating graphics and other objects in your presentation.

You can directly manipulate object properties such as color, line style and thickness, shadow, 
opacity, and orientation using the inspectors and the Fonts and Colors windows, as described 
in the following sections.

Using Color and Image Fills

You can create interesting effects with color in Keynote. Objects that you draw using the 
drawing tools can be filled with solid colors, color gradients, or even with an image, such as a 
photo or other graphic, that you drag in from the Finder or from iPhoto. You can also adjust 
the opacity of an object. Giving an object a lower opacity makes it more transparent. You can 
even use these fill and opacity effects to enhance charts by selecting an individual bar or pie 
wedge in the chart and then selecting the desired effect.
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To change the color of an object, you use the Graphic Inspector and the Colors window.

To open the Graphic Inspector:

m Choose View > Show Inspector (or click Inspector in the toolbar), and then click 
Graphic in the Inspector window.

Filling an Object With Color

Objects can be filled with solid color or a color gradient, in which two colors blend with each 
other. You can choose colors using the standard Mac OS X Colors window.

To set the solid fill color of an object:

1 On the slide canvas, select the object whose color you want to change.

2 In the Graphic Inspector, choose Color Fill from the Fill pop-up menu.

3 Click the color well below the Fill pop-up menu to open the Colors window.

4 Select a color in the Colors window.

Choose a solid color, a color 
gradient, or an image to fill a 
drawn object.
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Color Gradients

If you want to fill an object with a color gradient, select Gradient Fill from the pop-up menu, 
and then follow the steps listed above, making two separate color selections. For example, if 
you want the color of your object to blend from green into blue, select a shade of green for 
one color well, and a shade of blue for the other color well. You can also set the direction of 
the gradient using the Angle wheel.

Selecting Colors

The Colors window is used to make color selections for text, shapes, backgrounds, and 
shadows in Keynote.

To open the Colors window:

m Choose View > Colors (or click Colors in the toolbar).

m Or click a color well in one of the inspector panes.

This circle has a 
gradient fill set at an 
angle of 32º.

Click each color well to
make color selections.

Set the direction of the gradient with 
the Angle wheel, or type in a value.

Click the double-headed 
arrow to invert the gradient.

The color selected in the color 
wheel appears in this color box.

Use the slider to set lighter or 
darker hues in the color wheel.

Drag colors from the color box to 
store them in the color palette.

Click to select a color in the 
color wheel.
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You can use the color wheel in the Colors window to select colors. Your color selection 
appears in the box at the top of the Colors window. You can save that color selection for 
future use by placing it in the color palette.

To open the color palette:

m Drag the handle at the bottom of the Colors window.

To save a color in the color palette:

m Drag a color from the color box to the color palette.

To apply your color selections from the Colors window to an object on the slide canvas, you 
must place the color selection in the appropriate color well of an inspector pane.

To apply your color selection to an object on the slide canvas:

m Select a color well in one of the inspector panes and then click a color in the color wheel.

m Drag a color from the color palette to a color well in one of the inspector panes.

Filling an Object With an Image

You can place an image inside of a drawn shape or inside a table cell.

To set an image fill for an object:

1 Select the object in which you want to place an image.

2 In the Graphic Inspector, choose Image Fill from the Fill pop-up menu.

3 Locate your image in the Open dialog and click Open.

The image appears inside the selected object on your slide canvas.

To later change the image, drag the new image from the Finder to the image well or click 
Choose to browse for your image using the Choose dialog.

4 Select a size for the image fill.

Use the pop-up menu to 
set the size of the image 
within the object.

To change the image, drag 
an image from the Finder 
into the image well.
48 Chapter  4  



m Scale to Fit makes the image appear larger or smaller to fit into the object’s dimensions as 
well as possible. If the object has a different shape than the original image, parts of the 
image will not appear; blank space may also appear around the image.

m Scale to Fill makes the image appear larger or smaller, sizing it to leave no space around 
the image, even if the object and image have different shapes.

m Stretch sizes the image to fit the object’s dimensions but distorts it if the object has a 
different shape than the original image.

m Original Size places the image inside the object without altering its original dimensions. If 
the image is larger than the object, you will see only a part of the image in the object. If 
the image is smaller than the object, there will be blank space around it.

This circle object has an 
image fill scaled to fit.

This circle object has an image fill 
scaled to fill. The white background 
behind the flower is part of the original 
image, which is rectangular.

This circle object has an 
image fill scaled to stretch.

This circle object has an image 
fill scaled at original size.
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m Tile makes the image appear repeatedly inside the object, if the original image is smaller 
than the object. If the image is larger than the object, you will see only part of the image 
inside the object.

Changing the Line Style

For drawn objects, you can choose a style and color for the line that delineates the object (or 
the stroke). Or you can choose to have no line around the object. Line style and color are set 
using the Graphic Inspector and the Colors window.

To set line style and color for an object:

1 Select the object that you want to modify.

2 Choose a line style, or None, from the Stroke pop-up menu in the Graphic Inspector.

3 To change line thickness, type a value in the Stroke size field.

4 To change the line color, click the color well to open the Colors window and select a color.

5 To give the line shaped end points, such as arrowheads or circles, choose left and right end 
points from the pop-up menus.

This circle object has a very 
small image fill scaled to tile.

This circle object has a 
large image scaled to tile.

Choose a solid line, dotted 
line, dashed line, or no line.

Choose line end points from 
these pop-up menus.

Click the color well to 
choose a line color.

Enter the line thickness 
in this field.
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Adding Shadows

Shadows give your slide an appearance of depth. An object’s drop shadow is visible on any 
object behind it. You can create a variety of shadow effects, or remove the shadow from an 
object.

To create or remove a shadow for an object:

1 Select the object you want to modify.

2 Select the Shadow checkbox in the Graphic Inspector to add a shadow to your object. 
Deselect the Shadow checkbox to make the shadow go away.

3 Set the angle that you want the shadow to appear at using the Angle wheel.

4 Adjust the shadow offset by typing a number in the Offset box. A high shadow offset value 
will make your object’s shadow appear longer and slightly separated from the object.

5 Set the shadow blur by typing a number in the Blur box. A high blur value will make the 
object’s shadow appear more diffuse; a low value will give the shadow more sharply defined 
edges.

6 Set the shadow opacity by typing a number in the Opacity box. (Shadow opacity is separate 
from object opacity, which is set using the Opacity slider at the bottom of the Graphic 
Inspector.)

7 To change the color for the shadow, click the color well to open the Colors window and 
select a color.

This object has default
shadow properties.

This object’s shadow is
set to a different angle.

This object’s shadow has 
a high offset value.

This object’s shadow has 
the lowest blur factor.

This object has a different 
shadow color.

This object’s shadow has a 
high blur factor.

Change the shadow
color in the color well.

Select the checkbox to give a
shadow to a selected object.

Change the angle of the 
shadow with the Angle wheel.

Offset, Blur, and Opacity fields can change 
the look of the shadow, as shown above.
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Adjusting Opacity

Object opacity can be used to create very interesting effects. When an object of low opacity is 
placed on top of another object, the object beneath remains visible. Depending on how high 
or low you set the opacity, the objects beneath can be highly visible, partly obscured, or 
completely blocked from view (at 100% opacity). You can change opacity settings for any 
visual object on the slide canvas, including drawn shapes, pictures and other image files, and 
movies. Set object opacity using the Graphic Inspector.

To set object opacity:

1 Select the object whose opacity you want to change.

2 In the Graphic Inspector, drag the Opacity slider to adjust the opacity.

Note:  For drawn shapes, you can set the opacity of the object’s fill color separately from the 
object opacity. When you select the fill color for an object, set the color opacity with the 
Opacity slider in the Colors window. This color opacity value becomes 100% object opacity. 
When you reduce the object opacity in the Graphic Inspector, you are only reducing it 
relative to the opacity you set in the Colors window.

Changing the Orientation

You can flip or rotate any object by using the Metrics Inspector. For instance, if you have a 
nice image of an arrow that you want to use in your slideshow, but you need it to point in 
different directions, you can reverse its direction vertically or horizontally, or point it at any 
angle.

This circle is set to 100% opacity. 
The fill color was set to 50% 
opacity in the Colors window. The 
circle’s outline was set to 100% 
opacity in the Colors window.

This circle is set to 
100% opacity.

This circle is set to 
50% opacity.
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To open the Metrics Inspector:

m Choose View > Show Inspector (or click Inspector in the toolbar), and then click Metrics.

To flip or rotate an object:

1 Select the object you want to rotate.

2 In the Metrics Inspector, use the Angle wheel to set the direction of the object, or click the 
horizontal or vertical Flip buttons to flip it horizontally or vertically.

Adjusting Size and Position

Use the Metrics Inspector to make precise adjustments to the size and position of objects on 
the canvas.

To set the precise size of an object:

1 Select the object you want to resize.

2 Type a height and width in the Size fields in the Metrics Inspector.

Be sure the Constrain Proportions checkbox is selected if you want to keep the same height/
width proportions for images and movies.

Resize images and movies to 
exact dimensions by specifying 
height and width.

Flip an image sideways or upside 
down using these buttons.

Find the name of the selected 
image or movie here.

Rotate an object with this wheel.

Place an object precisely on the canvas 
by specifying X and Y coordinates.
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To return an image or movie to its original size:

m Select the image or movie and click Original Size in the Metrics Inspector.

To set the precise position of an object:

1 Select the object you want to position.

2 Enter X and Y values in the Position fields in the Metrics Inspector.

The object is positioned with its upper-left corner at the specified coordinates.

m The X value is measured from the left edge of the slide canvas.

m The Y value is measured from the top edge of the slide canvas.

If the object is not rectangular, then the object is positioned with the upper-left corner of its 
container box at the specified coordinates. If an object has been rotated, it is positioned with 
the upper-left corner of its “rotated” container box at the X and Y coordinates. That is, the 
rotated shape is considered to have a new container box around it that encompasses it as 
though it were a new shape (for example, a square rotated 25º appears as a diamond), 
though you cannot see or manipulate selection handles for this rotated container box.
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5 Creating Tables

Tables can be designed in a number of ways to visually compare sets of data or conceptual 
information. Although they present information systematically, they can be designed for 
visual appeal. In addition, you can make the table data appear dynamically on the screen in 
object builds, so you can build your points step by step. This chapter covers the basics of 
designing and filling tables on the slide canvas. To learn more about creating dynamic object 
builds with tables in your slideshow presentation, see “Table Builds” on page 77.

Many of the tasks described in this chapter can also be accomplished through shortcut 
menus that are available right on the table you’re working on.

To access shortcut menus for tables:

m Hold down the Control key as you click a table.

Adding a Table

To place a table on a slide:

1 Choose Edit > Place > Table (or click Table in the toolbar). A table appears on the slide 
canvas and the Table Inspector opens.

2 To resize the table, place the pointer over the table selection handles and drag.

You can also hold down the Option key and click Table in the toolbar. Then move the pointer 
over the slide canvas until it becomes a crosshair. Drag across the slide canvas to create a 
table any size you want.

3 To reposition the table on the slide canvas, place the pointer on the table, avoiding the 
selection handles, and drag the table to where you want it.
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Filling Table Cells

You can place text and graphics inside table cells. You enter text in a table cell by typing it. 
Graphics, however, must be placed. When an object is placed properly inside a table cell, it 
will move when the table is moved. To read about adding graphics or setting background 
colors inside table cells, see “Adding Graphics or Background Colors” on page 59.

Selecting Table Cells

You can apply global settings to a table by selecting the entire table at once. But to place text 
inside individual table cells, or to place graphic objects within individual cells or groups of 
cells, you must select only the cells you want to work with. Use the following methods to 
work with tables.

To select the entire table:

m Click outside the table once and then click the table.

Selection handles appear on the edges of the table, which you can use to resize the table.

To select a single table cell:

1 Click outside the table once, and then click the table to select the table.

2 Click a table cell once to select the cell. The border of the selected cell is highlighted in 
yellow.

When you have selected a single cell, you can move between cells by pressing the arrow keys 
on your keyboard. If you type text in this mode, it will replace any text that already appears in 
the cell. After selecting a cell, you can place images, graphics, or change the cell background, 
as described in “Adding Graphics or Background Colors” on page 59.

To select one segment of a cell border:

1 Click outside the table once, and then click the table to select the table.

2 Click a border within the table to select the entire row or column border.

3 Click again to select a single border segment.

4 Hold down the Shift key as you click to select noncontiguous border segments.

To place or edit text inside a table cell:

m Select an individual cell and then click that cell again. A text cursor appears inside the cell.

When the text cursor appears in a table cell, you can move the cursor between table cells by 
pressing the Tab key.

To select a contiguous group of table cells:

m Double-click a single cell, and then drag across the adjacent cells, or hold down the Shift 
key as you select the adjacent cells.
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To select a discontinuous group of table cells:

m Hold down the Command key as you select cells.

To switch the contents of two cells:

m Select a single cell and drag it to another cell. The contents of the two cells are switched.

To copy the contents of one cell into another:

m Select a single cell and hold down the Option key as you drag it to another cell.

Formatting Tables

You can design tables in a variety of creative ways simply by changing the thickness and color 
of cell borders, selectively removing cell borders, or merging and splitting cells to create 
useful asymmetries within the table. All table formatting is done in the Table Inspector.

To open the Table Inspector:

1 Choose View > Show Inspector (or click Inspector in the toolbar).

2 In the Inspector window, click Table.

Formatting Rows and Columns

To change the number of rows and columns:

1 In the Table Inspector, type the number of rows you want in the Rows field.

2 Type the number of columns you want in the Columns field.

Merging table cells combines adjacent cells into one, eliminating the border so that they 
behave as a single cell.

Combine adjacent cells or 
split rows and columns.

Type the number of table 
rows and columns.
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Splitting cells divides each selected cell into two equal parts, horizontally (rows) or vertically 
(columns), depending on your choice.

To merge table cells:

1 Select a group of two or more adjacent table cells. You must choose a rectangular set of cells.

2 In the Table Inspector, click Merge Cells.

To split cells horizontally or vertically:

1 Select a table cell or cells. To split an entire row or column, select all the cells in the row or 
column.

2 In the Table Inspector, click Split Rows or Split Columns. The selected cells are split down the 
center by rows (horizontally) or by columns (vertically).

You can continue to select the split rows or columns and perform the split operation again, 
to create smaller and smaller units within a table cell. If you want to rejoin any adjacent parts 
of the split cells, select them and click Merge Cells.

Aligning Text in a Table Cell

You can place text wherever you want in a table cell.

To justify text within a table cell:

m Select the cell and click one of the Alignment buttons in the Table Inspector.

To align text vertically within a cell:

m Select the cell and click one of the vertical alignment buttons in the Table Inspector.

Justify text right.

Distribute text evenly.Justify text left.

Justify text center.

Place text at bottom of cell.

Place text at top of cell.

Place text in center of cell.
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Formatting Cell Borders

You can change the line thickness and color of cell borders. Or you can choose to hide the 
cell border for any given cell.

To set line thickness:

m Select a cell border or set of cell borders and type a value in the Cell Border field of the 
Table Inspector.

To set line color:

1 Select a cell border or set of cell borders.

2 Click the Cell Border color well in the Table Inspector. The Colors window opens.

3 Select a color in the Colors window.

To hide the cell border:

1 Select a cell border or set of cell borders.

2 Choose None from the Cell Border pop-up menu.

Adding Graphics or Background Colors

You add graphics or other media objects to a table cell by placing them as an image fill within 
the table cell. If they are not placed as image fills, they will not move with the table or adjust 
their positions within the cells when you resize the table.

To add an image to a table cell:

1 Select a table cell, a group of cells, or the whole table.

Choose to show or hide the 
selected cell borders. Set border 
thickness and color.

Choose a color for 
selected cell borders.

Enter a line thickness for 
selected cell borders.
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2 In the Table Inspector, choose Image Fill from the Cell Background pop-up menu. An Open 
dialog appears.

3 Locate the image or movie you want to use in the Open dialog and click Open.

4 Scale the image to fill the cell the way you want by using the Scale pop-up menu.

For more details about working with image fills, see “Filling an Object With an Image” on 
page 48.

To add a background color or gradient fill to a table cell:

1 Select a table cell, a group of cells, or the whole table.

2 In the Table Inspector, choose Color Fill or Gradient Fill from the Cell Background pop-up 
menu.

3 Click the color well (or wells) and select a color or colors in the Colors window.

For more details about working with color and gradient fills, see “Using Color and Image 
Fills” on page 45.

Set the size of the 
image within the cell.

Drag a new image to the well to 
change it, or click Choose.

Choose an image fill, color fill, or 
gradient fill for any cell.
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6 Creating Charts

Use charts to display complex data visually. You can import data directly from your 
spreadsheet into Keynote’s Chart Data Editor to create and edit stunning charts right on the 
slide canvas. This chapter outlines the basics of placing and formatting a chart on a slide.

Charts can also be made to appear one part at a time as you make your points during your 
slide presentation. To read about setting up such “object builds” for charts, see “Chart Builds” 
on page 77.

Many of the tasks described in this chapter can also be accomplished using shortcut menus 
that are available right on the chart you’re working on.

To access shortcut menus for charts:

m Hold down the Control key and click a chart.

Adding a Chart

To place a chart on the slide canvas:

1 Choose Edit > Place > Chart (or click Chart in the toolbar). A chart appears on the slide 
canvas. The Chart Inspector and the Chart Data Editor open.

2 Drag across the slide canvas to draw a default chart with placeholder data.

You can also hold down the Option key and click the Chart button in the toolbar. Then move 
the pointer over the slide canvas until it becomes a crosshair. Drag across the slide canvas to 
create a chart any size you want.
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3 In the Chart Inspector, choose a chart style from the chart style pop-up menu.

4 Type your data into the Chart Data Editor, or copy and paste from a spreadsheet application.

To resize the chart on the slide canvas:

m Select the chart in the slide canvas and drag the selection handles.

Editing Chart Data

To edit chart data, open the Chart Data Editor and enter your data by typing it or copying and 
pasting from Excel, AppleWorks, or other spreadsheet applications.

To open the Chart Data Editor:

m Choose Format > Chart > Show Data Editor (or click Edit Data in the Chart Inspector).

To edit the names of rows and columns or the data in a cell:

m Double-click a cell or a row or column label and type.

To reorder rows or columns in the Chart Data Editor:

m Select the row or column label and drag it to a new position.

To resize columns in the Chart Data Editor:

1 Select the column you want to resize by clicking its label.

Choose from eight 
different chart styles in 
the Chart Inspector.

Click these buttons to 
add another row or 
column for data.

Type chart data directly into 
these spreadsheet cells.
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2 Place the pointer over the right or left edge of the column. The pointer becomes a vertical 
line flanked by arrows pointing in opposite directions.

3 Drag the border to make the column wider or narrower.

To add rows or columns in the Chart Data Editor:

m Click Add Row or Add Column to place a row above the selected row or a column to the 
left of the selected column. If no row or column is selected, the new row or column will 
appear at the bottom or right edge of the table. You may have to press the Return key or 
the Tab key to see the new row or column.

m Select any blank cell and type your data. A new row or column is automatically created.

To delete rows or columns:

m Select the row or column label and press Delete.

Transposing Data Series and Data Sets

Charts show the relationship of two types of data with respect to each other. For example, if 
you chart business growth over time, you are showing the relationship between the size of 
the business versus the passage of years. If you chart voting results among different 
demographic groups, you are showing the relationship between the number of people who 
voted a certain way versus their demographic affiliation. When you enter data for a chart, the 
two different types of data are represented as data series and data sets.

In a business chart, an example of a data series could be the profits for one region over four 
successive quarters; the data sets could be all the regional profits for only one of those 
quarters. In the illustration below, the data series (each region’s profits) are in rows, and the 
data sets (each quarter’s profits) are in columns. Each individual value (for example, 17 for 
Region 1, Q1) is a data point.

Notice the colored marks next to the row labels (Region 1 and Region 2). These marks show 
the colors that will represent the data series in the chart.

These marks indicate the colors that 
represent each data series.
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The illustration below shows how this data would appear when plotted as a column chart.

In this chart, the data series are represented by rows in the Chart Data Editor. The data 
points are represented as a series of dark-colored bars and a series of light-colored bars.

You can quickly transpose the data series and data sets in your charts by using the Plot Row 
vs. Column button in the Chart Inspector.

The data sets contain one data point 
(one bar) from each of the data series.

These four bars represent 
one data series.

The chart legend denotes 
the two data series.

This button makes the columns of data 
in the Chart Data Editor the data series.

This button makes the rows of data in the 
Chart Data Editor the data series.
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The illustration below shows how the same data shown earlier would appear in a column 
chart if you transposed the data sets and data series.

For this chart, the data series are now represented by columns in the Chart Data Editor 
pictured on page 63. There are now four data series represented as four different-colored 
bars.

In column charts and bar charts, a data series is represented by a series of bars in the same 
color (as shown above). In a line chart, a data series is represented by a single line. In an area 
chart, a data series is represented by an area shape. For pie charts, only a single data set—the 
first data point in each series—is represented on the chart (whichever is listed first in the 
Chart Data Editor).

Transposing data series and data sets between rows and columns makes it easy to present 
your data to best effect without having to retype the data.

Formatting Charts

The elements of any chart can be formatted to fit your preferences. You can change the fonts, 
colors, and markings along the axes. You can also choose to show or hide the chart legend 
on your slide. Most of the chart formatting tasks are done using the Chart Inspector.

To open the Chart Inspector:

1 Choose View > Show Inspector (or click Inspector in the toolbar).

2 In the Inspector window, click Chart.

To show the chart legend:

1 Select the chart.

These two bars represent 
one data series.

The data sets contain one data point (one 
bar) from each of the four data series.
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2 Select the Show Legend checkbox in the Chart Inspector to make the legend appear on the 
same slide as the chart.

To hide the legend, deselect the Show Legend checkbox or select the legend and press 
Delete.

3 Select the legend and drag to reposition it on the slide canvas, or drag the selection handles 
to resize it.

When a legend is placed on a slide, it behaves somewhat independently from the chart. You 
can format the fonts or move it around the slide canvas. You can even copy and paste it onto 
another slide. However, once you have copied and pasted the legend, it is no longer 
connected to the data in the chart. So if you change the chart, the change will not be 
reflected in the legend. To update the legend, you must select the chart and recreate the 
legend.

Setting Chart Colors

You can format the bars, wedges, and area shapes that appear on each style of chart just as 
you format any other drawn object. You can give them color fills, gradient fills, image fills, 
shadows, opacity, or different line styles. These attributes are set in the Graphic Inspector.

To change the color or image in a bar, wedge, or area shape:

1 Select the item (bar, wedge, or area shape). If you select one bar in a bar chart, all the bars in 
that data series are selected.

2 Choose properties as you would for any drawn object. For more information about changing 
object properties, see Chapter 4, “Changing Object Properties.”

Changing Chart Fonts

You can change the fonts and text colors used for axis labels, data labels, and legends.

To change chart fonts:

1 Select the text you want to change. If you select the text for one data point or axis label, all 
the text of that kind is also selected.

2 Choose Format > Fonts > Show Fonts (or click Fonts in the toolbar) to open the Fonts 
window.

3 Select a font in the window.

For information about changing text colors, see “Changing Text Properties” on page 30.
66 Chapter  6  



Adding Labels and Axis Markings

Use the Axis pane in the Chart Inspector to format the grid and general look of the axes for 
bar charts, line charts, and area charts. You can set the range of values to be displayed along 
the value axis, the axis from which you read the data point values. For column charts 
(vertical bars), line charts, and area charts, the Y-axis is the value axis. For horizontal bar 
charts the X-axis is the value axis. Pie charts do not have a value axis. To read about 
formatting pie charts, see “Pie Charts” on page 69.

To show or hide chart borders:

1 Select the chart.

2 Click the Axes & Borders buttons in the Axes pane of the Chart Inspector to show or hide the 
corresponding chart borders.

To set the range of numerical values displayed on the chart grid:

1 Select the chart.

2 In the Chart Inspector, type a number in the Minimum field under Value Axis Format. This 
will be the value at the chart origin. The minimum value cannot be higher than the minimum 
value of your entire data set.

3 Type a number in the Maximum field. This will be the highest number displayed on the grid. 
It cannot be lower than the highest value in your data set.

4 Type a number in the Steps field. This marks the axis with values at equal intervals. The 
number of steps you specify determines the number of axis markings.

To specify units for axis values:

1 Select the chart.

2 Type text or a text symbol in the Prefix or Suffix field under Number Format (or choose a 
symbol from the pop-up menus).

In the Prefix and Suffix fields, you cannot use the characters 0 through 9, nor the comma (,), 
period (.), or number sign (#).

Set styles for labels and tick 
marks along the chart grid.

Select units for values 
in the chart.

Show or hide chart borders.

Set the range of values that 
appear on the chart grid.
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Placing Grid Labels and Tick Marks

The X-Axis and Y-Axis pop-up menus in the Axis pane of the Chart Inspector provide an array 
of options for placing tick marks and labels along the value axis or the series axis. These pop-
up menus, pictured below, contain different options depending upon which kind of chart 
you have selected.

For vertical bar charts (column charts), line charts, and area charts, the Y-axis is the value 
axis, while the X-axis is the series axis; for horizontal bar charts, the X-axis is the value axis. 
Here, pop-up menus are pictured as they appear when a column chart is selected.

X-Axis Markings (or Series Axis Markings)

To place grid labels and tick marks along the series axis:

m For a column chart, choose options from the X-Axis pop-up menu in the Axis pane of the 
Chart Inspector. (For horizontal bar charts, choose from among these same options in the 
Y-Axis pop-up menu.)

Y-Axis Markings (or Value Axis Markings)

To place grid labels and tick marks along the value axis:

m For column charts, choose options from the Y-Axis pop-up menu in the Axis pane of the 
Chart Inspector. (For horizontal bar charts, choose from among these same options in the 
X-Axis pop-up menu.)

Place tick marks along 
the X-axis.

Show or hide the X-axis gridlines.

Set the text direction for 
the series axis labels.

Show or hide the minimum 
data value on the series axis.

Place tick marks 
along the Y-axis.

Show or hide the 
Y-axis gridlines.

Show or hide the value axis labels.
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To display the minimum data value along the value axis:

1 Choose one of the major tick-mark display options from the X-Axis (series axis) pop-up menu 
(Major Tick Marks Inside/Centered/Outside).

2 Select Show Minimum Value.

Formatting the Elements in a Data Series

To show the values for each of the data points in a data series:

1 Select the chart or one element in a data series in the chart.

For bar and column charts, selecting one element (bar) of a series automatically selects the 
full series. For pie charts, you can select individual elements in a series (pie wedges).

2 In the Chart Inspector, click the Series tab. 

3 Select the “Show value” checkbox.

4 Type a number in the Decimals field to specify the number of decimal places you want to 
display.

5 Choose a placement for the numbers on the chart from the Position pop-up menu. You can 
set a different position for the numbers in each of the series.

Some chart styles offer further options for formatting the series elements in the chart. See 
the following sections for details on formatting options in pie charts, bar charts, line charts, 
and area charts. 

Pie Charts

For pie charts, Keynote charts only the first data set in the Chart Data Editor (the first data 
point for each data series). If the data series are in rows in the Chart Data Editor, only the 
first column is charted; if the data series are in columns in the Chart Data Editor, only the 
first row is charted. Thus, one pie chart represents a single data set, and each wedge is one 
element in that set. Other data sets that you have typed or pasted into the Chart Data Editor 
are maintained, but they are not used. You can choose to chart any data set by moving it to 
the first position in its row or column.

To select individual pie wedges:

1 Select the chart, and then click to select a single wedge.

2 To select additional wedges, do the following:

m Hold down the Command key as you select each wedge, to select noncontiguous wedges.

m Hold down the Shift key as you select the first and last wedges in a range, to select all the 
wedges in between.
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Press Command-A to select all the wedges.

 

To show pie chart values as percentages of the whole:

 

1

 

Select the chart, then select the “Show value” checkbox in the Series pane of the Chart 
Inspector.

 

2

 

Select the checkbox labeled “Show pie values as percentages.”

Use the Series tab of the Chart Inspector to show or hide pie chart series labels. You can also 
choose to display the data point values as percentages of the total or as absolute values.

 

To place series labels in pie charts:

 

1

 

Select the chart or individual pie wedges in the chart.

 

2

 

Select the “Show series name” checkbox in the Series pane of the Chart Inspector.

 

3

 

Choose Inside or Outside from the Position pop-up menu.

Choosing Outside places the label outside the selected wedges and the pie chart. Choosing 
Inside places the label directly on top of the selected pie wedges. You can choose to place 
the label outside small wedges and inside large ones. If a pie wedge is not selected when you 
select the “Show series label” checkbox, it will not be labeled.

 

To separate individual pie wedges:

 

1

 

Select the chart or individual pie wedges. (To select more than one pie wedge, hold down 
the Command key as you select each wedge.)

 

2

 

Drag the “Explode wedge” slider until the pie wedges are separated as far as you want, or 
drag the pie wedges.

Separate and add shadows 
to individual wedges.

For pie charts, place the data point 
values and series label inside or 
outside the selected pie wedge. 
Display as percentages or numbers.
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You can separate any or all of the pie wedges.

 

To separate pie wedges for shadowing:

 

1

 

Select the chart or individual pie wedges.

 

2

 

Choose Individual from the Shadow pop-up menu in the Series pane of the Chart Inspector.

Layering the wedges for shadowing puts shadows on all of the pie wedges, rather than the 
entire pie as a whole. It also allows you to apply opacity to individually selected wedges. If 
you select Group from the pop-up menu, you can apply shadows or opacity to the pie as a 
whole in the Graphic Inspector. To change shadow and opacity attributes, see “Adding 
Shadows” on page 51 and “Adjusting Opacity” on page 52.

 

Bar and Column Charts

 

Data series elements in bar and column charts can also be layered for shadowing. However, 
in these chart types, you must layer all the elements in all of the data series, or none at all. 
You can also adjust the spacing between data sets or individual bars.

 

To layer bars for shadowing:

 

1

 

Select the chart.

 

2

 

Choose Individual from the Shadow pop-up menu in the Series pane of the Chart Inspector.

Layering the bars for shadowing lets you add shadows to each of the individual bars in the 
chart. If you select Group from the pop-up menu, you can apply shadows to the chart as a 
whole in the Graphic Inspector. To read more about the Graphic Inspector and changing 
shadow attributes, see “Adding Shadows” on page 51.

Set a pie wedge apart by using the 
“Explode wedge” slider and giving 
it a series label.

Separate the individual bars in the chart.

Separate the data sets in the chart.
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Selecting the checkbox also allows you to apply opacity to each data series. If you deselect 
the checkbox, you can only adjust the opacity of all the elements on the chart together. To 
read about changing opacity of objects, see “Adjusting Opacity” on page 52.

To adjust spacing between individual bars or data sets:

1 Select the chart.

2 In the Chart Inspector, type a percentage value in the “Gap between bars” field to increase or 
decrease the space between the individual data elements.

3 Type a percentage value in the “Gap between sets” field to increase or decrease the space 
between the data sets. The value you enter is the percentage of the bar thickness.

Area Charts and Line Charts

In area and line charts, data points can be denoted by symbols: circles, squares, triangles, and 
so on.

To denote the data points using a symbol:

1 Choose a data series (area shape or line).

2 In the Chart Inspector, choose a symbol from the Data Point Symbol pop-up menu.

3 Format the symbol by choosing one of the options in the Symbol Fill pop-up menu, shown 
below.

The data points in this series 
are denoted by squares.

The data points in this series are 
denoted by circles.

Choose a symbol to 
denote the data points.
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7 Slide Transitions and Object Builds

Once you’ve designed and organized your slides, it’s time to put the whole presentation 
together with slide transitions and object builds that add motion and visual appeal to your 
slideshow. Add transitions to move smoothly from one slide to the next. Use object builds 
within each slide to animate how elements appear on the slide.

Adding Transitions Between Slides

Keynote gives you several types of transitions to choose from. Modern, 3D transition styles 
can add flair to your presentations. Classic, 2D transition styles are also available. Some 
examples are described below.

Transition style What it looks like

Cube Old slide angles and turns off screen as new slide angles on 
screen, as though they are sides of a revolving cube.

Mosaic Large New slide builds on in square tiles that shimmer across the 
screen.

Flip Old slide angles and turns off screen as new slide angles on 
screen, as though they are two sides of a revolving coin.

Move in New slide moves in from one direction to cover the 
contents of the previous slide. Choose a direction from the 
direction pop-up menu.

Wipe New slide draws in a sweep from one direction, as the 
previous slide is erased from the same direction. Choose a 
direction from the direction pop-up menu.
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Slide transitions are set in the Slide Inspector.

To add a transition from one slide to the next:

1 Choose View > Show Inspector (or click Inspector in the toolbar) to open the Inspector 
window.

2 In the Inspector window, click Slide to open the Slide Inspector.

3 Choose a transition style from the Transitions pop-up menu, shown below.

4 If applicable, choose a direction from the pop-up menu.

5 Drag the Speed slider to the right to make the transition happen more quickly, or to the left 
to make it happen more slowly.

Scale New slide grows from the center of the previous slide 
outward to fill the screen, if you choose Up from the 
direction pop-up menu. Previous slide shrinks away to 
center of the screen, revealing the next slide, if you choose 
Down from the direction pop-up menu.

None New slide appears suddenly on screen, replacing the 
previous slide.

Transition style What it looks like

Set the transition 
direction and speed.

Preview the transition.
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Slide transitions that you select in the Slide Inspector are applied only to the selected slide. 
To apply a transition to another slide, you must first select it and then repeat steps 1 through 
5.

Creating Object Builds

To add visual interest to your slide presentation, you can create object builds on each slide. 
Object builds allow you to animate the elements on a single slide one at a time or in groups 
in any order you like. For instance, you might have an image move in from the left side of the 
screen and then, line by line, display the bulleted text that goes alongside it. To build two 
objects at the same time, you must group them. (To read about grouping objects, see 
“Grouping and Locking Objects” on page 41.) Keynote makes it easy to create a variety of 
object builds.

Follow these steps to create an object build.

Step 1: Set “Build In” styles and sequence

1 Choose View > Show Inspector (or click the Inspector button in the toolbar) to open the 
Inspector window.

2 In the Inspector window, click Build to open the Build Inspector.

3 Click the Build In tab.

4 Select an item on the slide and then choose an animation from the Build Style pop-up menu. 
You can select graphic objects; bulleted text, labels, or other text objects; and sound objects 
(represented with an audio icon).

5 Choose the direction from which you want the object to move onto the slide from the 
Direction pop-up menu.

Set the animation style, direction, 
order, and speed for each object.

Select this to make the object 
build start when you click the 
mouse during your presentation.

Use Build In
animations to move

slide elements on the
screen, and Build Out

animations to move
elements offscreen.

Preview the build styles.
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6 Drag the Speed slider to the right to make the object appear more quickly during the build. 
Move the slider to the left to make the object appear more slowly.

7 Once you have selected a build style for each of the items on the slide that you want to 
animate, select each item again and assign it an order using the Order pop-up menu.

When you play your presentation, objects will move onto the slide in the order you specified 
as you click the mouse.

To make the object build start automatically without clicking:

m Deselect the “First build requires click” checkbox in the Build Inspector.

If you deselect this checkbox, the first stage of the object build will happen as soon as a slide 
appears on the screen. To advance the slide through the subsequent stages of the build, you 
must click the mouse.

You can also make objects exit the slide in any order by making selections in the Build Out 
pane of the Build Inspector. To read more about this, see “Set “Build Out” styles and 
sequence” below.

Step 2: Set “Build Out” styles and sequence

1 In the Build Inspector, click the Build Out tab.

2 Select an element on the slide and choose an animation from the Build Style pop-up menu.

3 Choose the direction you want the item to move off the slide from the Direction pop-up 
menu.

4 Drag the Speed slider to the right to make the object move more quickly. Drag the slider to 
the left to make the object move more slowly.

5 Once you have selected a build style for each of the elements on the slide that you want to 
animate, select each one again and assign it an order using the Order pop-up menu.

If you have elements on the slide that build in and elements that build out, you can mix the 
build in and build out orders, so that any individual element might move on and off the 
screen before another one moves on the screen.

Bulleted Text Builds

To move bulleted text points onto the screen as you talk, you can use bulleted text builds.

To set up a text build:

1 Select the bulleted text box and assign it a build style, direction, speed, and order, as 
described in the previous section.

2 Choose a delivery style from the Delivery pop-up menu. You can move all the text onto the 
screen at once, or move the bullet points onto the screen one at a time or in groups.
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Table Builds

You create object builds for slides with tables just as you would create any other object 
builds. However, with tables, you have the option of animating the table itself. You can 
choose to make it enter the screen row by row, column by column, as individual cells, all at 
once, or in a variety of other ways.

To set up a table build:

1 Select the table and assign it a build style, direction, speed, and order, as described earlier.

2 Choose a delivery style from the Delivery pop-up menu.

m All At Once moves the whole table as a single object.

m By Row moves the table onto the screen row by row.

m By Column moves the table onto the screen column by column.

m By Cell moves the table onto the screen one cell at a time.

m By Row Content moves the empty table onto the screen, followed by each row of the cell 
contents.

m By Column Content moves the empty table onto the screen, followed by each column of 
the cell contents.

m By Cell Content moves the empty table onto the screen, followed by the cell contents, 
one cell at a time.

If you choose a delivery style that builds the table by rows, columns, cells, or content, each of 
those pieces will use the build style that you assigned to the whole table.

You can preview a table build in the preview screen of the Build Inspector.

Chart Builds

Like table builds, chart builds offer a variety of ways to move chart elements on and off the 
screen during your presentation.

To set up a chart build:

1 Select the chart and assign it a build style, direction, speed, and order, as described earlier.
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2 Choose a delivery style from the Delivery pop-up menu.

m All At Once moves the whole chart as a single object.

m Background First moves the chart axes onto the screen, followed by all the data elements 
at once (bars, lines, or area shapes).

m By Series moves the chart axes onto the screen and then the data elements, one full series 
at a time.

m By Set moves the chart axes onto the screen and then the data elements, one full set at a 
time.

m By Element in Series moves the chart axes onto the screen, and then each separate data 
element, one series at a time.

m By Element in Set moves the chart axes onto the screen, and then each separate data 
element, one set at a time.

For more information about data series and data sets, see Chapter 6, “Creating Charts.”

If you choose a delivery style that builds the chart by its elements, each of those elements 
will use the build style that you assigned to the whole chart.

You can preview the chart build in the preview screen of the Build Inspector.

Note:  The chart legend is separate from the chart and can be assigned its own build style 
and order. If you want it to appear with the chart, group it with the chart before you set the 
chart’s build style. To learn about grouping objects, see “Grouping and Locking Objects” on 
page 41.
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8 Viewing Your Slideshow

There are several ways you can share your Keynote presentation. You can view it from your 
computer on your own display or projected on a large screen. You can share it across 
platforms by exporting it as a QuickTime movie or even as a PowerPoint presentation. Finally, 
slides can be converted to PDF files for viewing or printing, or can be printed directly from 
Keynote in a variety of page layouts.

Full-Screen Presentations

Full-screen presentations make the most of Keynote’s capacity to provide crisp graphics and 
smooth animations. You can give full-screen presentations directly on your computer’s 
display, a secondary display, or projected onto a large screen.

Viewing on Your Display

The simplest way to view your slideshow presentation with a small audience is by watching it 
directly on your computer’s display.

To view a full-screen presentation on a single display:

1 Open the Keynote document by double-clicking its icon in the Finder.

2 Choose View > Play Slideshow (or click Play in the toolbar).

3 Press the Space bar or click the mouse to move to the next slide or to advance the object 
build as the slideshow plays.

4 Press the Esc key or Q key to end the show.

Viewing on a Projector or Second Display

If you have a larger audience, you may want to play the slideshow on a second display or 
projector. If you do this, you can choose to show your slide notes discreetly on your display, 
while others see only the slideshow playing on the second display. To do this, you set up 
your second monitor or projector as a dual monitor.
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You can also choose to play the slideshow on both screens. This is called video mirroring.

Note:  Before you begin video mirroring or using a dual-monitor setup, attach the second 
display or projector according to the instructions that came with the display or projector, and 
the instructions that came with your computer (search online help for video mirroring, 
displays, or dual monitors). You will not be able to do the setup until after the second display 
or projector is attached.

Video Mirroring

After you have connected a second display or projector, you must configure your computer 
for video mirroring. Some computers have video mirroring built-in. If yours does not, you 
must configure it in the Displays pane of System Preferences.

To set up video mirroring:

1 Choose Apple () > System Preferences to open the System Preferences window.

2 In System Preferences, click Displays to open the Displays pane.

3 Set both displays to the same resolution and color depth.

4 Click the Arrange tab and select Mirror Displays.

To play your slideshow on a mirrored system:

1 Open the Keynote document by double-clicking its icon in the Finder.

2 Choose View > Play Slideshow (or click Play in the toolbar).

3 Press the Space bar or click the mouse to move to the next slide or to advance the object 
build as the slideshow plays.

Note:  Keynote generally plays back very smooth animations. However, since the two 
displays used in a video mirroring configuration may have different refresh rates, one of the 
screens may appear to “stutter.” This is because Keynote can only synchronize with the 
refresh rate of one screen. PowerBooks and iBooks will display the smoothest animation on 
the external display when they are in mirrored mode.

4 Press the Esc key or the Q key to end the show.

Both monitors display identical images.

Dual Monitors

With the dual-monitor configuration, you can play the slideshow on one screen, while 
controlling the slideshow and viewing your notes on another display.

To set up dual monitors:

1 Choose Apple () > System Preferences to open the System Preferences window.

2 In System Preferences, click Displays to open the Displays pane.

3 Click the Arrange tab and follow the onscreen instructions.
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Note:  If there is no Arrange tab, then your system does not support a dual-monitor 
configuration.

To play your slideshow on a dual-monitor system:

1 Choose Keynote > Preferences to open the Preferences window.

2 Select “Present on primary display” or “Present on secondary display” to specify on which 
screen you want to display the slideshow. The primary display is the one which shows the 
menu bar.

3 To view the slide notes on the alternate display, select the checkbox labeled “Use alternate 
display for feedback.” Close the Preferences window.

If you do not select the option to view notes on the alternate display, that display will be 
blank (black screen) during the slideshow presentation.

For slideshows with very complex charts or object builds, selecting this option may cause the 
slideshow to play slightly more slowly.

4 Choose Slide > Play Slideshow (or click Play in the toolbar).

5 If you selected the option to view notes on the alternate display, on one display you will see 
the Keynote window with the notes field open. Play through the slides in the slide organizer 
by using the Up and Down Arrow keys or by pressing the Space bar on the keyboard. Click 
the mouse to advance object builds. The Keynote window is inactive except for moving 
forward or back in the slideshow.

Note:  When viewing your notes during slideshow playback, the viewing window for the 
notes field is not scrollable. If you have long notes in the notes field, before you play the 
slideshow be sure to open the notes field to its maximum height and adjust the font size so 
that all of your notes are visible without scrolling.

6 Press the Esc key or Q key to end the show.

Select this to exit full-screen mode after 
the slideshow ends.

Select this to resize 
slides automatically.

Select this to view your slide notes on 
the alternate display during slideshow 
playback with a dual-monitor setup.

Select the top button for video 
mirroring. Select the bottom button 
for dual monitors.
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Changing the Presentation Slide Size

For the highest quality playback, your slide sizes should match the screen resolution of the 
display where the slideshow will be played. Most projectors work best with slides set at the 
800 x 600 size; only newer projectors can display slides at a resolution of 1024 x 768. Most 
Keynote themes come optimized for either of these sizes.

If your slide size is too large to fit the display, Keynote automatically scales it down to fit the 
screen.

If you have a monitor that is larger than one of these sizes, you can set a custom slide size for 
your Keynote document.

To change the slide size in your Keynote document:

1 In Keynote, choose File > Slide Size.

2 Type the slide dimensions you want in the Height and Width fields.

3 Click OK.

If you are not certain of the best slide size or you do not want to change the original slide 
size in your document, Keynote will play the slideshow at its original size with black 
letterboxing to fill the extra space on the screen. Or you can have Keynote resize the 
slideshow to fit your screen as the slideshow plays. 

To fit the presentation to the display only during slideshow playback:

1 In Keynote, choose Keynote > Preferences.

2 Select the “Scale slides up to fit monitor” checkbox.

This does not actually change the slide size of your Keynote document. Some video quality 
may be lost during playback by using this option.

Printing

You can print your Keynote slideshow in a variety of ways to meet different needs. You can 
print full slides with or without notes, or you can print just the slideshow outline.

Printing Slides and Notes

There are several options for printing your full slides.

To print slides:

1 Choose File > Print Slides. The Print dialog opens.
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2 Choose Keynote from the Copies & Pages pop-up menu.

3 Select the slide layout you want.

m To print one full slide per page, select Slides.

m To print one slide per page with the slide notes, select Slides With Notes.

m To print four slides per page, with space for handwritten notes, select Producer Script.

4 Select the print formatting options that apply.

m “Print dark backgrounds as white” reverses light text against dark slide backgrounds to 
improve readability: dark slide backgrounds print as white and light text prints as black. 
This is especially useful for printing colorful slides on black-and-white printers. On color 
printers, imported graphics files on each slide will still print in color.

m “Print each stage of builds” prints one slide image at each stage of its object build. If a 
slide has a three-stage object build, it will print as three slides.

m “Include skipped slides” prints all the slides in the slide organizer, even if they are marked 
as skipped.

m “Add borders around slides” prints a border around the edge of each slide.

m “Include slide numbers” prints the number at the bottom of each slide.

Printing Outline View

To print just the bulleted text on all of your slides:

m Choose File > Print Outline.

The printout shows the outline of bulleted items that appears in outline view in the slide 
organizer.

Convert the set of slides to a PDF file.

Select print formatting options.

Choose Keynote from this pop-up menu.

Select which layout of
slides and notes you

want to print.
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Exporting to Other Viewing Formats

Other viewing options allow you to share your presentation across different platforms.

PDF Files

Your slideshow can be converted to a PDF file, which can be viewed or printed in Adobe 
Acrobat Reader or any PDF viewer. To save your Keynote slides as PDFs, use the Keynote 
Export dialog.

To create PDF files of your slides:

1 Choose File > Export

2 In the Export dialog, select PDF.

3 Click Next.

4 Type a name and choose a location for the files.

5 Click Export.

QuickTime

You can create a QuickTime movie of your slideshow, which includes all the transitions and 
animated object builds you added to the show. If you create a self-running QuickTime movie, 
you can send your slideshow out as a self-running demo, with object builds and slide 
transitions timed just as you set them. If you create an interactive QuickTime movie, 
slideshow viewers can advance through the slides and slide builds at their own pace.

To create a QuickTime movie of your slideshow:

1 Choose File > Export.

2 In the Export dialog, select QuickTime and then click Next. The QuickTime export dialog 
opens.

3 Choose an option from the Playback Control pop-up menu:

For self-playing movies,
set slide and object

build durations.

Choose an interactive movie 
or a self-playing movie.

Choose to play the movie 
once, repeat, or loop.

Choose a compression 
format to optimize movie size 
and playback quality.
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m If you choose Interactive Movie, the viewer will be able to advance the slideshow by 
clicking Play in the QuickTime controls, clicking the mouse, or pressing the Space bar on 
the keyboard.

m If you choose Self-Playing Movie, the viewer has no control over the speed at which the 
slideshow advances. You determine the speed of object builds and how long slides linger 
on the screen by typing values in the Slide Duration and Build Duration fields.

m There is no delay between the moment a slide first appears on the screen and the first 
stage of an object build. But you set the delay for the subsequent stages of a build. The 
number of seconds you enter in the Build Duration field is the number of seconds 
between the beginning of one build stage and the next in each object build.

m The number of seconds you enter in the Slide Duration field is the time the fully-built 
slide remains on the screen after the object build is complete.

4 In the Repeat pop-up menu, choose to make the slideshow play through only once, loop 
continuously, or loop back and forth.

5 Choose a playback quality and file size from the Formats pop-up menu.

m Full Quality, Large movies preserve the best playback quality, but can’t be easily 
transferred to viewers through email or the web because of their large file sizes.

m CD-ROM Movie, Medium movies are quite high in quality but somewhat smaller in file 
size than full-quality movies. This option is best if you are using a CD to send the 
slideshow to another viewer.

m Web Movie, Small movies generally have poorer playback quality but are small enough to 
be shared across the web or through email.

m Custom Settings allows you to determine the tradeoff between file size and quality by 
choosing your own QuickTime compression settings.

PowerPoint

Keynote documents can be converted to PowerPoint files, to be viewed and edited by 
PowerPoint users on Windows or Mac OS computers.

To export to PowerPoint:

1 Choose File > Export. The Export dialog opens.

2 Select PowerPoint and then click Next.

3 In the Export dialog, type a name for the file and choose a location.

Note:  Since Windows and Mac OS X do not work with graphics in the same way, you may 
notice a slight variation in your slideshow graphics when you open the exported PowerPoint 
document on a Windows computer.
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9 Designing Your Own Master Slides and 

Themes
This chapter is for theme designers who want to use Keynote’s powerful graphics capabilities 
to design their own master slides and themes.

Themes are predesigned sets of master slide layouts, backgrounds, charts, tables, and text 
styles that come with the Keynote application. Within each theme, master slides define the 
following slide attributes:

m title and body text box layouts

m background graphics

m default fonts

m default bullet styles

m object fills and line styles for drawn objects and tables

m chart style

m slide transition style

m alignment guides

As you work with Keynote’s themes, you may find that you want to set up your own master 
slide layouts or create your own background designs and default styles. You can modify any 
of these attributes to customize any master slide within a theme. The new styles appear on 
every slide in the slideshow for which you use the customized master slide.

You can modify a master slide within an existing theme for a particular Keynote project. This 
will not affect other uses of the theme in other Keynote documents. If you want to customize 
and save a set of master slides, you must save it as a custom theme, as described in “Saving a 
Custom Theme” on page 96.

You can also modify and save a whole set of master slides to create your own theme, 
customizing it with your company logo or styling it with your own, unique designs.

To begin working on master slides, you must open the master slide organizer and select a 
master slide.
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To open the master slide organizer:

m Choose View > Show Master Slides (or click View in the toolbar and then choose Master 
Slides).

An easy way to get a modified slide layout is to import a single slide or master slide from 
another slideshow into the current slideshow.

To import a single slide or master slide:

1 Open the Keynote document that contains the slide you want.

2 Select the slide and drag it from the source document to the slide organizer of the document 
you are working in.

A new master slide is created in your Keynote slideshow. You can find the new master slide in 
the master slide organizer.

Important  If you modify a master slide and then apply a new theme, your custom 
specifications will be overwritten by the new theme, unless you specify otherwise.

To retain your customized master slide settings when applying a new theme:

m Be certain the “Retain Changes to Theme Defaults” checkbox is selected in the theme 
selection dialog before you click Apply.

Modifying Master Slide Backgrounds and Layouts

The easiest way to design a new master slide is to start with an existing master that most 
closely resembles what you want. Scroll through the list of master slides in the master slide 
organizer and select and duplicate the one that you want to begin working with.

To duplicate a master slide:

1 Select the master slide in the master slide organizer.

2 Choose Slide > New Master Slide (or click New in the toolbar) or press Return on the 
keyboard.

Master slide layouts are created using the Master Slide Inspector pane.

To open the Master Slide Inspector pane:

1 Select a master slide in the slide organizer.

2 Choose View > Show Inspector (or click Inspector in the toolbar) to open the Inspector 
window.
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3 In the Inspector window, click Slide to open the Master Slide Inspector. ( You must have a 
master slide selected to see the Master Slide Inspector.)

Changing the Background

One way to create groups of related slides within a slide presentation (for example, to set 
apart different topic areas of the presentation) is to incorporate a subtle, systematic 
difference in the background of each set of slides. To do this, you would create a set of 
master slides with each of the different backgrounds you want to use.

To modify a master slide background:

1 Select the master slide you want to modify in the master slide organizer.

m If you are building a new background from scratch, you may want to begin with a blank 
master.

m If you want to retain a copy of the original master, choose Slide > New Master Slide (or 
click New in the toolbar) to create a duplicate of the master slide.

2 If there are elements on the slide background that you do not want to use, select them and 
press the Delete key.

3 Use any of the Keynote tools to place background elements on the master slide. You can add 
drawn objects, text, charts, or tables. Or, you can use a simple fill color or a gradient fill. Any 
objects that you add to this master slide will appear on every slide to which you apply this 
master. While working in a master slide, any objects that you create can be manipulated and 
formatted just as on regular slides. To learn about setting object properties such as fill color, 
opacity, and shadow, see Chapter 4, “Changing Object Properties.”

Once you’ve placed an element where you want it, you can choose Arrange > Lock (or click 
Lock in the toolbar) to prevent it from being accidentally moved as you work.

Choose a default 
transition style.

Layer or flatten background graphics.

Set master slide background 
color, gradient, or image fill.

Place title and body text boxes and 
slide numbers on master slides.
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4 Add external objects to the slide as you need them. This can include movie files, sound files, 
or other graphic elements. Drag external files from the desktop to the master slide canvas 
and place them where you want.

Note:  Any graphics, movies, or sound files that you add to this master slide will appear in 
every slide based on this master.

While working in the master slide, you can move any element from back to front, or vice 
versa, arranging the elements on the master slide in exactly the same way you would on a 
regular slide. To read about grouping, positioning, and orienting graphics, see “Adjusting Size 
and Position” on page 53, and “Changing the Orientation” on page 52. To read about creating 
a layered background, see “Creating a Layered Background,” next.

Creating a Layered Background

Creating a layered background allows you to layer objects on the slide with objects on the 
slide background. The most obvious use of multiple layers is when using an alpha-channel 
graphic or mask as a background layer to place images behind. However, you can place non-
transparent images in background layers, as well. For instance, you might place a logo in one 
corner of a master slide and then layer its corner over the edges of nearby objects on the 
slide for visual interest.

To use layers in master slide backgrounds, you must create a layered background.

To create a layered background:

1 Place objects on the master slide canvas, positioning and layering them as you want.

2 In the Master Slide Inspector, select the checkbox labeled “Allow objects on slides to layer 
with master.”

Note:  When you create a slide using a master with a layered background, objects placed on 
the slide canvas can be moved behind the background layers. To read about moving objects 
between layers, see “Resizing, Moving, and Layering Text or Graphic Objects” on page 40.

Adding Alignment Guides

You can create your own alignment guides to help you place your text and graphics 
consistently on each slide. Alignment guides created on a master slide are available when you 
are placing objects on any slides based on that master.

To create alignment guides on a master slide:

1 Select the master slide to which you want to add the alignment guides.

2 Choose View > Show Rulers to make the rulers appear at the top and left side of the slide 
canvas.

3 To create a vertical alignment guide, place the pointer on the ruler on the left side of the 
slide canvas. When you click, the pointer changes to parallel lines.
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4 Drag to the right. A yellow alignment guide appears. Drag it to wherever you want on the 
slide canvas.

5 To create a horizontal alignment guide, place the pointer on the ruler at the top of the slide 
canvas and drag downward. Drag the alignment guide that appears to where you want it on 
the slide canvas.

Designing Title and Body Text Layout and Styles

Default styles for title and body text boxes are defined on the master slide on which they 
occur. To set the title or body text defaults on a master slide, you must first place title or body 
text boxes on the master slide, and then select the text and set its attributes using the 
Inspector panes, as you would set text attributes on any slide. As you change the text 
settings, you should preview the new settings by creating a slide in the slide organizer, 
applying the new master slide settings, and trying them out with some text.

To place title and body text boxes on a selected master slide:

1 In the Master Slide Inspector, select the Show Title checkbox to place a title text box.

2 Select the Show Body checkbox to place a body text box. This gives you bulleted text by 
default. (To set a default style of no bullets, see “Creating Bulleted Text” on page 32.)

3 Resize and rearrange the text boxes until they are positioned the way you want.

4 If you want to include subtitle text, resize the body text box and place it under the title text 
box. Format it without bullets.

5 Select the placeholder text in the title or body text box and format it with your preferred 
styles. In the body text box, you can define attributes for up to five levels of bulleted text.

You can set the tab positions to determine how far each level of text in your outline is 
indented and how much space there is between the bullet and the text.

To set bulleted text tabs:

1 Choose View > Show Rulers.

2 To set the tab stop for bulleted text:

a Select a bullet.

b In the ruler at the top of the slide canvas, locate the square blue tab icon that lines up 
with the selected bullet.
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c Drag the tab icon to the position where you want the bullet to indent.

3 To set the distance between the bullet and its associated text:

a Select a bullet.

b In the ruler at the top of the slide canvas, locate the rectangular tab icon that lines up with 
the text of the selected bullet.

c Drag the icon to change the space between the bullet and its text.

Applying Your Changes as You Work

As you work on a master slide, you will want to try out your changes on a slide in the slide 
organizer to get a better sense of how the changed layout will look. By going back and forth 
between the “test” slide and the master slide, you can make fine adjustments such as making 
lines longer or shorter, or adding multiple indent levels. Create a slide in the slide organizer 
that is based on this master and reapply the master to the test slide each time you make an 
adjustment. This is especially useful when adjusting tab stops and line spacing.

To reapply the master slide to a selected slide in the slide organizer:

m Choose Format > Reapply Master to Selection.

Setting Default Slide Transitions

You can choose a transition style to be the default transition for any master slide. Slides based 
on this master will leave the screen using this default transition style.

To set the default transition style for a master slide:

1 Select the master slide you want to modify in the master slide organizer.

2 In the Master Slide Inspector, choose a transition style, direction, and speed. For more 
information about slide transitions, see “Adding Transitions Between Slides” on page 73.

This tab sets the distance 
between the bullet and its text.

This tab sets the stop for bullet 
indentation.
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Setting Default Styles for Free Text, Shapes, Tables, and 
Graphics

Default attributes for free text boxes, shapes, tables, and graphics need not be set on the 
master slides. For these objects, create a sample slide in the slide organizer based on the 
master whose defaults you want to modify, place a free text box, shape, table, or graphic on it 
to set the attributes, and then use the Format menu commands to define these new 
attributes as the defaults for the selected object.

Defining Attributes for Free Text Boxes and Shapes

Setting the default attributes for free text boxes and for shapes is very similar. Design text and 
shapes just the way you want them, with your preferred fonts, colors, opacity, shadows, and 
so on. Then set these as the default styles for the current master slide, or for all master slides 
in the theme.

To set default free text and shape attributes:

1 In the slide organizer, create a new slide based on the master slide you are designing.

2 On the slide canvas, place a text box or a shape. (To read about placing text or drawn objects, 
see Chapter 3, “Working With Text, Graphics, and Other Media.”)

3 For the free text box, type text into the box and then select the text and set its attributes. To 
read about setting text attributes, see “Editing Text and Text Properties” on page 29.

4 For the shape, select it and set its attributes. To read about setting object properties, see 
Chapter 4, “Changing Object Properties.”

5 Once you have formatted the text or shape, define the new properties as the defaults by 
selecting each one and doing one of the following:

m Choose Format > Define Defaults for Master Slides > Define Text (or Shape) for Current 
Master to define the default free text box or shape properties for only the master slide 
you are working on.

m Choose Format > Define Defaults for Masters Slides > Define Text (or Shape) for All 
Masters to define the default free text box or shape properties of all the master slides in 
the theme you are working in.

6 Delete the text box or shape from the slide.

Defining Attributes for Tables

You can design an entire table the way you like it, setting the number of rows and columns, 
line styles and colors, merged or split cells, text styles, shadows, and so on, and then set your 
table design as the default for any master slide, or all master slides in a theme.

To set default table attributes:

1 In the slide organizer, create a new slide based on the master slide you are designing.
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2 On the slide canvas, place a table. (To read about placing and formatting tables, see 
Chapter 5, “Creating Tables.”)

3 Select the table and set its attributes.

4 Size and place the table as you want it to appear on the slides.

5 Once you have formatted and positioned the table, define the new properties as the defaults 
by selecting each one and doing one of the following:

m Choose Format > Define Defaults for Master Slides> Define Table for Current Master to 
define the default table properties for only the master slide you are working on.

m Choose Format > Define Defaults for Master Slides> Define Table for All Masters to 
define the default table properties of all the master slides in the theme you are working 
in.

6 Delete the table from the slide.

Setting Default Chart Styles

You can set the default styles for charts on a master slide in the same way you set default 
object properties (described above), designing and placing them where you like on the slide 
canvas. However, you can define the default chart styles separately from the default chart 
position on the slide.

Default attributes must be set individually for each chart type.

To set default chart styles and placement:

1 In the slide organizer, create a new slide based on the master slide you are designing.

2 Place a chart on the slide canvas. (To read about placing and formatting charts, see Chapter 6, 
“Creating Charts.”)

3 Select the chart and set its attributes.

4 Size and place the chart as you want it to appear on the slide.

5 Copy and paste the chart to a new slide, based on the master you are designing. In the Chart 
Inspector, change the chart to a different chart type. Set the chart properties and styles.

6 Repeat step 5 for each of the chart types.

7 Once you have formatted and positioned all the charts, select each of them, one at a time, 
and set its attributes as the defaults by doing one of the following:

m Choose Format > Define Defaults for Master Slides> Make Default Chart Type to define 
this chart as the default type for all master slides in the theme you are working in.
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m Choose Format > Define Defaults for Master Slides > Set Size and Placement for All 
Charts for Current Master to mark this chart size and placement as the default for only the 
current master slide you are working on.

m Choose Format > Define Defaults for Master Slides > Set Size and Placement for All 
Charts for All Masters to mark this chart size and placement as the default for all master 
slides in the theme you are working in.

m Choose Format > Define Defaults for Master Slides > Define [chart type] for Current 
Master to set the color, font, shadows, axes, and other properties as the default properties 
for the master slide in the theme you are working in.

m Choose Format > Define Defaults for Master Slides > Define [chart type] for All Masters 
to set the color, font, shadows, axes, and other properties as the default properties for all 
the master slides in the theme you are working in.

8 A dialog appears.

a In the field labeled “Number of Initial Series,” type the number of series that you want to 
show in the default chart, which appears when you initially create a chart on a slide 
canvas.

b In the field labeled “Total Number of Series Defined,” type the total number of series for 
which you are defining attributes. You can define attributes for as many series as you 
expect might be needed by those who use your custom theme.

9 Delete the charts from the slides.

Defining Default Attributes for Imported Graphics

For imported graphics, you can set shadows, opacity, and outline (stroke) color. Then set 
these as the default styles for the current master slide, or for all master slides in the theme.

To set default image attributes:

1 In the slide organizer, create a new slide based on the master slide you are designing.

2 Place an image on the slide canvas.

3 Select the image and set its attributes.

4 Once you have set the shadow, opacity, and outline for the image, define the new properties 
as the defaults by selecting each one and doing one of the following:

m Choose Format > Define Defaults for Master Slides > Define Image for Current Master 
to define the default image properties for only the master slide you are working on.

m Choose Format > Define Defaults for Masters > Define Image for All Masters to define 
the default image properties for all the master slides in the theme you are working in.

5 Delete the image from the slide.
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Saving a Custom Theme

If you have made modifications to master slides in any theme, and you want to use these 
modifications again in other slide presentations, you can save the modified theme as a 
custom theme. Once you save your custom theme, master slides with your modifications will 
be available in the theme selection dialog. You can then select the custom theme as you 
would select any theme in the dialog.

To save the current theme as a custom theme:

1 Choose File > Save Theme.

2 Type a name for the theme. You can also type a few notes about the theme in the Description 
field.

3 If you want to save the theme in a different location, choose the location using the Where 
pop-up menu.

4 Click Save.

Unless you save your theme in a special location, custom themes are found in the following 
folder on your hard disk:

[Home]/Library/Application Support/Keynote/Themes/[Custom Theme]

Only themes found in this location are available in the theme selection dialog. However, if 
you choose to store your theme outside of this location, you can open it as a blank Keynote 
document and work directly in it to create a slideshow.

Restoring Original Theme Defaults

If you have made modifications to master slides in one of your Keynote documents and you 
later decide you want to return to the original theme defaults, you can do so by reapplying 
the theme to your document.

To restore the theme defaults:

1 Choose File > Choose Theme.

2 In the theme selection dialog, select the original theme.

3 Choose a presentation size from the pop-up menu.

4 Make sure the checkbox labeled “Retain changes to theme defaults” is not selected.

5 Click Choose Theme.
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Creating a New Theme From Scratch

If you want to create an entirely new theme that is not based on any of the existing Keynote 
themes, the easiest way is to start in a new Keynote document with only a single, blank 
master slide. Delete all the other slides in the theme. It may be helpful to keep the following 
tips in mind as you work:

m Start with a new Keynote document on a blank master slide. Delete all other master slides 
from the document.

m Design and place shared background elements and body and title text first.

m On a sample slide, test your text layouts to be sure they work with wrapped text lines. 
Consider how many bullets you want to fit in a body text box when you set its size and 
placement.

m Set up all text and background attributes before creating new master slides.

m Create a variety of body and title text layouts using copies of the original master slide. 
New master slides made from copies of that first one will automatically inherit all of its 
text and background attributes. Then you only have to adjust the text box layouts (for 
example, remove the title text box and expand the body text box for a “body only” master 
slide).

m Create sample slides in the slide organizer based on each master you have designed and 
place free text boxes, shapes, tables, and images on each one, if you want the default 
object attributes to be different on different master slides. (If you want to set the default 
object attributes the same for all masters, you only need to do this for one master slide.)

m Create eight sample slides in the slide organizer based on each of the master slides you 
have designed. Design a chart on one of the slides, then copy and paste it onto each of 
the slides. For each slide type, convert the charts to each of the eight different chart types, 
setting its size and position. Do this before you define the default chart styles using the 
commands in the Format menu.
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