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Chapter 1

Overview

Introduction

DBS Manager™ is a Windows-based software application that lets you manage Panasonic DBS telephone
systems from a personal computer. With DBS Manager, you can connect to a DBS system via modem or
direct connection and modify the DBS’ programming parameters from your PC or laptop. You can also
maintain programming databases for any number of different phone systems in your PC and make modifi-
cations to a database for uploading to that phone system at a later time. DBS Manager replaces the need
for most on-site FF key programming procedures (you will still need to use FF keys for programming new
features, "any keys", Call Forwarding ID digits, etc.).

How DBS Manager works

DBS Manager stores the programming information for a DBS system in database files based on the
Microsoft Access™ format . Using DBS Manager, you can easily view or modify a system’s
programming parameters as stored in the database and then upload any changes to that DBS either
immediately or at a later time. You can also download a DBS’ programming parameters to DBS Manager
for analysis and modification, or for use as a system backup.

It is important to understand that a database for a particular phone system exists in DBS Manager
independently from the actual system programming for that DBS. If programming for the system is
changed in a DBS database, the phone system will be unaffected unless you are connected to the DBS at
the time the changes are made, or those changes are uploaded to it from your PC.

Likewise, if any system parameters are changed via on-site FF key programming, those changes will not be
reflected in the DBS Manager database for that system until the changes are downloaded from the DBS to
your PC, or you open that database in DBS Manager and make the same changes.

Note: It is not necessary that a database exist in DBS Manager in order to make changes to a DBS’
programming. If desired, you can connect to the DBS using DBS Manager and modify its programming
without maintaining a copy of its database in the DBS Manager application.

Using this manual

This manual is designed to assist you in getting started with DBS Manager. It is not intended to replace
DBS Manager’s extensive interactive On-line Help files.

Users should have a thorough working knowledge of Panasonic DBS programming procedures and
terminology and a good understanding of modem functionality. Users should also be familiar with basic
PC and Windows functionality and terminology.
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Conventions used in this manual

The following conventions are used throughout this manual:
1. Items to be selected from a menu are indicated as follows:
Select File > Exit to exit the application (Choose the File menu, then click on Exit).

2. Names of menus and menu items are printed in boldface. Letters that you can use to access the
menu and menu item from the keyboard are underlined.

3. Reference to DBS Manager and its features appear in boldface.

4. Words requiring special emphasis are italicized.
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Chapter 2

Installation Procedures

System requirements

DBS Manager is a powerful application which requires a powerful PC in order to run effeciently. The
following are minimum system requirements.

» A 486-33 or higher IBM-compatible PC with a 3.5" floppy drive.

* 8 MB or more RAM.

« 20 MB or more free disk space - see Note 1.

» Windows-compatible Mouse.

VGA or higher resolution Monitor.

» Hayes-compatible modem (required for remote connections - see Note 2).

» Microsoft Windows version 3.1 or higher.

Note 1: Installation of DBS Manager requires about 6 MB of disk space. You will also need at least
10 MB free work space on your hard disk to be used during database conversions. In addition, each
phone system database to be administered through DBS Manager requires an additional 3.0 MB of
disk space. Example: If you are administering three different DBS databases, you will need at least 25

MB of disk space - 6.0 MB for DBS Manager, 10 MB to be used during database conversions, and 9.0
(3.0 MB each) for the three phone system databases being administered.

Note 2. A modem is not required if you have the End-User version of DBS Manager, or if you have
the Dealer version but intend to do only direct (i.e., not remote) connections.

Before you begin

Check the following before you begin installation of the DBS Manager software.

1. If running Windows 3.1 or 3.11, make sure your virtual memory (swap file) is set to Permanent (not
Temporary). The recommended size for virtual memory is 25 MB or greater.

2. For Windows 3.1 and 3.11, set the Buffers parameter in your config.sys file to 40 (unless you use
applications which require a higher setting).

3. If you are running Windows 3.1 (not 3.11), DBS Manager requires the presence on your system of
a file named share.exe. DBS Manager will install this file during the installation process, but you
must manually edit your autoexec.bat file to add the following line:

share. exe /L:500

Refer to your DOS and Windows user guides if you need help making the above changes.

DBS Manager Issued April 2000 7
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Installing the DBS Manager hardware key

DBS Manager is supplied with a hardware key which attaches to your PC’s parallel port via a 25-pin
connector. This hardware key must be installed in order to use DBS Manager to connect to a DBS.

If using a printer, attach the hardware key to the parallel port, then plug the printer cable into the hardware
key. (On some computers, if the printer is turned off when using DBS Manager, the system will not
recognize the hardware key and will therefore not allow a communication session to be established.)

Figure 1. The DBS Manager Hardware Key

to PC parallel port

Note: Two different versions of the hardware key are available: a dealer version and an end-user version.
The dealer version allows remote connections to a DBS. The end-user version is limited to local (on-site)
connections only (i.e., no external modem communications with a DBS are allowed). Both versions allow
full database functionality. The version type is displayed just above the phone graphic on the DBS
Manager Main window.

Installing the DBS Manager software

You should make backup copies of the DBS Manager disks before beginning the installation procedure.
Use the backup disks for the installation.

1. Close out all other Windows applications.
2. Insert Disk 1 into floppy drive A or B.

3. For Windows 3.1, select File, then Run from the Program Manager screen. For Windows 95, select
Start, then Run from the Windows desktop. In the Command Line box, type a:setup or b:setup
(depending on which drive you placed the disk in), then press <ENTER>. You will be asked to
confirm the directory DBS Manager should be installed to.

4. After the installation is complete, you should open DBS Manager using the default User 1D
(System) and password (System) and immediately set up a new user account. See page 27 for
information on setting up and modifying user accounts.

Note 1: The default User ID and password are case-sensitive and must be entered exactly as shown
above.

Note 2: To protect against unauthorized use of DBS Manager, you may want to change the default
password (System) after your new user account is established. Be aware however that once the
default password is changed, there is no way to open DBS Manager should you forget your
personal User ID and/or password.
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Chapter 2

DBS Manager Communications Addendum

Introduction

DBS Manager provides the ability to connect to the DBS and DBS 824 either
directly or by using modem connections. Modem connection allows for easy
remote maintenance without having to travel to the phone system site.

Figure 1. Direct Communications

DBS DBS or ~
Manager DBS 824 .
N\ L7 e

PC % %%Qj/

Figure 2. Remote Communications

Manager DBS 824

Connecting remotely to the DBS or DBS 824 involves two modems; 1) a

modem at the DBS Manager PC and 2) a modem at the DBS or DBS 824.
With the DBS, the modem may be either the internal modem built into the
RAI card, or an external modem connected to the DBS external serial port
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(CN®6). With the DBS 824, an external modem must be connected to the SIU
“MAINT” connector CN2.

Regardless of your configuration, the modems at both ends must be
properly configured to communicate. There are often differences in
configuration commands between various modem models. Fortunately, DBS
Manager contains custom-tailored modem setup configurations to reduce or
eliminate modem-related problems. However, if you have a modem with dip
switches that control setup, they must be set to support DBS Manager
communications.

Note: Make certain you have complete documentation on the modems you
use. There are certain settings that must be correctly set to operate.

Connecting either directly or by an external modem to the DBS or DBS 824
requires special customized modem cables. These cables are described later
in this document.

Note: Make sure to use cables configured as described in this document. The
cables listed here differ from previously defined cables.

Requirements

The following items are required for DBS Manager to communicate with the
DBS or DBS 824.

DBS Manager PC Requirements:
DBS Manager Version 1.1 or later (with hardware key)
Internal, PCMCIA, or External Modem (if connecting remotely)
Standard Modem Cable (if using an external modem)

DBS Requirements for Direct Communications:
Customized Direct Connection Cable

DBS Requirements for Remote Communications:
RAI or External Modem
Customized Modem Cable (if using an external modem)

Trunk Access to Modem (if calling unassisted) (i.e, DISA trunk, dedicated
modem trunk, voice mail, automated attendant, etc.)

MFR (if using DISA)

10
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DBS 824 Requirements for Direct Communications:

Serial Interface Unit (SI1U)
Customized Direct Connect Cable

DBS 824 Requirements for Remote Communications:
Serial Interface Unit (SIU)

External Modem

Customized Modem Cable

Direct Connection

Customizing the Direct Connection Cables

A customized cable must be used with a direct connection. The cable required
to connect to the DBS is shown in Figure 3. The cable required to connect to
the DBS 824 is shown in Figure 4.

Figure 3. DBS Customized Direct Connection Cable

Note: Some PC COM ports require a 9 pin connector and
others require a 25 pin connector. Choose the approriate
cable for your PC.

DB 25 DB 9 DB 25 DB 25
Male Female Male Female
To SMDR Port (CN6) To PC Com Port To SMDR Port (CN6) To PC Com Port
2 < > 2 2« >3
3 < >3 3 < » 2
4 < > ] 4 > 8
5« 5 <
6 < >4 6 < » 20
7 < > 5 7 < > 7
8« >7 ] < >4
> 8 »5
20 « > 6 20 « > 6

DBS Manager
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Figure 4. DBS 824 Customized Direct Connection Cable
Note: Some PC COM ports require a 9 pin connector and
others require a 25 pin connector. Choose the approriate
cable for your PC.
DB 9 DB 9 DB9 DB 25
Male Female Male Female

To MAINT Port (CN2)

To PC Com Port To MAINT Port (CN2) To PC Com Port

<« > 2 2« >3
3« >3 3 < >
< » 4 « » 20
5« > < »>
8 < » < »
»1 »8
Operation

o M LN

6
7.
8.
9

Note: Prior to connecting to the DBS 824, dial #91 at an attendant
telephone to disable SMDR and set the DBS 824 serial communications
port to CN2 - “Maint”.

Attach the appropriate direct connection cable to the DBS or DBS 824.
See “Customizing the Direct Connection Cables” on page -11.

Start DBS Manager and login.

Select File then Communications.

Select the PC COM Port for the direct connect cable.

Select 9600 Baud, 8 bit data length, 1 stop bit, None for parity.

Note: The above values MUST match the DBS FF1 2#,2#,1-4# or the
DBS 824 FF1 2#,9#,1-4# settings. The default settings in the DBS is even
parity and should be changed if DBS Manager is set up for no parity.

Select RTS/CTS for Flow Control.
Select Direct Connection.
Select Save. DBS Manager will return to Communication Setup.

Select Cancel to return to the main menu.

10. Select Connect to DBS.

11. Select Connect.

12
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Remote Communications

DBS Manager Modem Considerations

Before any remote connection to the phone system can be made, the DBS
Manager modem must be configured and installed. (This procedure is only
required before the first connection, it does not have to be repeated for each
connection.)

Note: The DBS Manager modem must be configured one way for connecting
to a DBS or DBS 824 with an external modem and another way for
connecting to a DBS with an RAI card. DBS Manager provides a way to
support two settings that may be used for the same modem - Modem #1
Setup and Modem #2 Setup (see step 10 below). If the DBS manager
modem requires both configurations, it is recommend that the following steps
be performed twice with Modem #1 Setup used for connecting to an RAl and
Modem #2 Setup used for connecting to an External Modem. Then
connecting to a DBS only requires selecting the correct Modem Setup before
connection.

1. If using an external modem, attach the DBS Manager Modem to a PC
communication port (usually COM1 or COM2) using a standard modem
cable.

2. If using an internal modem, follow the modem installation instruction to
install the modem in the DBS Manager PC.

Start DBS Manager and login.
Select File then Communications.
Select the PC COM Port for the modem.

If connecting to a DBS or DBS 824 external modem, select 9600 Baud, 8
bit data length, 1 stop bit, none for parity. (These values MUST match the
DBS FF1 2#,2#,1-4# or the DBS 824 = FF1 2#,9#,1-44# settings. The
default settings in the DBS is even parity and must be changed if DBS
Manager is set up for no parity.)

o 0 &~ w

or

If connecting to a DBS RAI, select the RAI Baud rate (1200 or 300 Baud
for RAI-B or 300 Baud for RAI-A), 8 bit data length, 1 stop bit and none
for parity. (The baud rate MUST match the DBS FF1 2#,2#,10# setting.
The default setting in the DBS is 300 baud.)

7. Select RTS/CTS for Flow Control.

8. If connecting to a DBS with an external modem, select Operator
Assisted External Modem or Unassisted External Modem. If
connecting to a DBS using the internal RAI, select either Unassisted RAI
or Operator Assisted RAL.

DBS Manager
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10.
11.
12.

13.
14.

15.
16.

17.
18.

Select Save.
Select Modem #1 Setup or Modem #2 Setup.
Select the modem manufacturer from the modem manufacturer list.

Select the correct modem. (Make sure to check the entire list for your
modem. Some modems are not in alphabetical order.)

Select Advanced Setup.

Check the Initialization string. If necessary, make changes. It should not
be necessary to make changes unless you are setting up to connect to an
RAI modem and no preconfigured RAI setup is available. See RAI
Considerations below for more information.

Select OK.

Select Configure Modem. When DBS Manager has configured the
modem, it will display “Configuration completed successfully”.

Select OK. DBS Manager will return to Communication Setup.

Select Cancel to return to the main menu.

RAI Considerations

Unlike a DBS external modem, the RAI does not need to be configured.
However, the DBS Manager modem must be configured appropriately to
connect to a DBS with the RAI installed.

When configuring a DBS Manager modem to connect to an RAI, follow the
steps in “DBS Manager Modem Considerations” on page -13. When
Configurations - Advanced Setup is chosen, the following parameters must
be set in the initialization string for the DBS Manager modem as described in
your modem manual:

» All data compression must be disabled

« All error control must be disabled.

Note: If using DBS Manager to connect to phone systems using DBS
external modems and RAIs, you must choose the correct modem setup for the
type of connection (either for DBS external modem or RALI), and then select
Configure Modem before connecting.

14
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DBS or DBS 824 External Modem Considerations

If using a external modem attached to the DBS or DBS 824, the modem must
be configured at the DBS Manager PC and then attached to the DBS or DBS
824 using the appropriate customized cable before the first remote
communication can be made.

Configuring the DBS or DBS 824 External Modem using DBS
Manager

1. Attach the modem to be configured as the external modem to a DBS
Manager PC com port using a standard modem cable.

Start DBS Manager and login.
Select File then Communications.

Select the PC COM port connected to the DBS external modem.

o &M LN

Select Operator Assisted External Modem or Unassisted External
Modem.

Select Ext Modem.
Select the modem manufacturer from the modem manufacture list.

Select the modem model.

© o N o

Select Advanced Setup.

10. Check the Initialization string. If necessary, make changes. (It should not
be necessary to make changes unless you have trouble connecting.)

11. Select OK.

12. Select Configure Modem. When DBS Manager displays “The DBS Ext
modem was successfully configured, now connect it to the DBS
SMDR port...,” click OK. The screen will return to the Communication
Setup.

13. Select Cancel to return to the main menu.

14. Attach the modem to the DBS SMDR port or the DBS 824 Maintenance
port.

Note: VERY IMPORTANT! For the DBS, disable SMDR printing for every
installed port (FF3 # (Ext No.)# 14# 0#) when attaching an external modem.

DBS Manager Issued April 2000 15
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Customizing the External Modem Cable

A customized cable must be used with an external modem. The cable required
to connect to the DBS is shown in Figure 5. The cable required to connect to

the DBS 824 is shown in Figure 6.

Figure 5. DBS External Modem Customized Cable
DB 25 DB 25
Male Male
To SMDR Port (CN6) To Modem
< > 2
3 < » 3
4 +— — 4
5 «— — 5
6 +«— — 6
20 «—— — 20
7 < » 7
Figure 6. DBS 824 External Modem Customized Cable
DB 9 DB 25
Male Male
To MAINT Port (CN2) To Modem
2 < > 2
3 < > 3
5 « » 1
4 +— — 6
8 «— —— 20
— 4
) 5
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Operation

Operator-Assisted External Modem Connection

1.

o o > w

~

Confirm under Communications that Operator Assisted Modem
Connection is selected.

Check all other communication parameters to make sure they are
configured properly.

Return to the main menu.
Plug a phone into phone connector on the DBS manager modem.
Select Connect to DBS.

Enter the DBS remote password. (This must match the DBS setting in
FF1 4#.)

Go off-hook on the phone and dial the DBS operator.

With the DBS, when the call is answered at the remote end, ask the
operator to place the call on hold and dial the extension of the external
modem.

With the DBS 824, when the call is answered at the remote end, ask the
operator to place the call on hold, dial #91, dial the extension of the
modem and hang up.

When you are placed on hold, select Connect and hang up phone. The
far end modem answers and talks to the DBS manager modem.

Unassisted External Modem Connection (DBS Only)

Before an Unassisted External Modem Connection can be performed, the
DBS must be configured to allow unassisted transfer of an incoming call.
This can be accomplished in a number of ways including DISA access, Auto
Attendant, Voice Mail or VAU.

1.

Confirm under Communications that Unassisted External Modem
connection is selected.

Check all other communication parameters to make sure they are
configured properly.

Return to the main menu.
Select Connect to DBS.

Enter the DBS Remote Phone number followed by commas (for pauses)
and the dial string required to transfer the call to the external modem. For
instance, 5554000,1111,104 would dial a DBS DISA line (5554000),
pause 1 second (,) enter the DISA inbound ID code (1111), pause 1
second (,) and call the modem (104).

DBS Manager
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6.
7.

Enter the DBS Remote Password. (This must match the DBS setting.)

Select Connect. DBS Manager dials the phone number. The far end
modem answers and talks to the DBS Manager modem.

Unassisted RAI Connection (DBS Only)

Before an Unassisted RAI Connection can be performed, the DBS must be
configured to allow unassisted transfer of an incoming call. This can be
accomplished in a number of ways including DISA access, Auto Attendant,
\Voice Mail or VAU.

1.
2.
3.

Confirm under Communications that Unassisted RAI is selected.
Ensure DBS Manager modem is configured for RAI connection.

Check all other communication parameters to make sure they are
configured properly.

Return to the main menu.
Select Connect to DBS.

Enter the DBS Remote Password (if different than the default). (This
must match the DBS setting.)

Enter the DBS phone number followed by the dial string required to
transfer the call to the RAI. For instance, 5554000,1111 would dial a DBS
DISA line (5554000), pause 1 second (,)and dial the DISA inbound ID
code (1111).

Select Connect. The far end RAI modem answers and talks to the DBS
manager modem.

Operator Assisted RAI Connection (DBS Only)

1.

© N o 0 b~ w

Confirm under Communications that Operator Assisted RAI
Connection is selected.

Check all other communication parameters to make sure they are
configured properly.

Return to the main menu.

Plug a phone into the DBS manager modem.

Select Connect to DBS.

Enter the DBS remote password. (This must match the DBS setting.)
Go off-hook on the phone and dial the operator.

When the call is answered at the remote end, ask the operator to place the
call on hold and dial #69999.

18
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9. When you are placed on hold, select Connect. The far end modem
answers and talks to the DBS manager modem.

DBS Manager Issued April 2000 19
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DBS Manager Quick Tour

The Main Window

When you start DBS Manager, you will see the main window shown below. The main window consists of
four sections: the menu bar, the button bar, the DBS Administration section, and the information bar. The
main window also shows what type of hardware key is connected to your PC (Dealer Key, End User Key,
or No Hardware Key.)

An example of the DBS Manager main window is shown below.

Note: Most items in the DBS Administration section of the main window will be dimmed and therefore
unavailable until either a DBS database has been opened or a connection established to a DBS.

Figure 7. The DBS Manager Main Window

menu bar
button bar — 5
| Dealer Key DBS Adminisiration

{Fie Database DBS Administialion Fcpic Help

type of hardware key —

| Customer/Site Szlupl ‘ Extensions |

[Srtomparametore | [ sows | DBS Administration
| DID/DNIS I ‘ Toll Restiictions | SeCtiOn

| T I‘Leall: t R Igl

Trunks I
Disconnec 1085
com1 | Please select an option... [Mon 01-Apr96 9:36:25 a information bar
OFFLINE C:WINDBS\CUST_DB\SOUTHCOM.MDB CPCB V700995
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The Menu Bar

DBS Manager provides four menus in the menu bar of the Main screen: File, Database, DBS
Administration, Reports, and Help.

The File Menu

The following menu items are available from the File menu.

Menu Item Description

New Creates a new customer database.

Open Opens an existing customer database.

Copy Copies an existing customer database.

Close Closes an open customer database.

Connect to DBS Connects to a DBS.

Disconnect DBS Disconnects from a DBS.

Communications Sets communication parameters.

External DBS Modem | Configures the modem on the DBS system.

User Accounts Sets passwords and other access parameters for users of DBS
Manager.

Print (Not supported at this time.)

COM Status Monitors the connection session between DBS Manager and a
DBS phone system.

New Function Reset | Initializes SRAM after upgrading CPC-B software to a new
release (such as from 5.0 to 6.0).

Exit Exits DBS Manager.

The Database Menu

The database menu contains items pertaining to database management. The following items are contained
in the Database Menu.

Menu Item Description

Download Raw Data from | Transfers programming parameters from a DBS to a .raw data file
DBS in DBS Manager.

Convert Raw Data to Converts a .raw data file to a .mdb database file that can be opened
Database in DBS Manager.

Upload Raw Data to DBS | Transfers programming parameters from a .raw data file in DBS
Manager to the appropriate DBS.

Convert Database to Raw | Converts an existing .mdb database to a .raw data file for upload-
Data ing to a DBS.

Upgrade Database Upgrades a .mdb database to a newer CPC version.
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Menu Item

Description

Repair Database

have been corrupted by an incorrect log-off procedure, power

Attempts to repair a .mdb database file in DBS Manager that may

interruption, etc. This option is unavailable if a database is open.

Compact Database

pact Database should be run after a database has been repaired.

Rebuilds a .mdb database file to reduce the file size. Note: Com-

The DBS Administration Menu

Items contained under the DBS Administration Menu are the same as those displayed in the DBS
Administration section of the main window. These items are available only when a database file is open or
when connected to a DBS.

The following items are contained in the DBS Administration Menu:

ltem

Description

Customer/Site Setup

Contains customer name, address, DBS modem #, CPC type, etc.,
for a DBS.

System Parameters

Defines various DBS system-wide parameters, such as serial ports,
paging relay, timing, absence messages, system speed dial, classes
of service, verified account codes, and call waiting/

OHVA.

DID/DNIS Defines DID/DNIS name and ringing assignments.

T1 Defines T1 trunk parameters, timing parameters, master/slave des-
ignations, alarm timer and relay parameters, etc.

Trunks Defines many CO trunk parameters for the DBS, such as trunk port
#, port usage, trunk operational status, trunk type, inbound ring pat-
tern, etc.

Extensions Defines parameters for DBS extensions, including station port#,
extension #, Class of Service, call waiting, auto redial, paging
groups, call forward, Personal Speed Dial #s, Flexible Function
keys, etc.

Groups Defines parameters for Hunt Groups, Group Ringing Assignments,

and Coverage Groups

Toll Restrictions

Defines Toll Restriction parameters for the DBS such as TRS types,
maximum dialed digits allowed, operator access, N11 restrictions,
etc.

Least Cost Routing

Defines LCR trunk groups, time priority parameters, routing, and
other LCR parameters.
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The Reports Menu
Not available at this time.
The Help Menu

This menu provides access to DBS Manager’s online help files. Help is described in detail in Chapter 5.

The Button Bar

The button bar on the main screen contains small icons which represent certain DBS Manager functions.
To perform a function, click on its corresponding button.

Exit
Exits DBS Manager. You will be asked to confirm before exiting.

screen will appear.

Open File

New File
D I Creates a new file using system defaults. The Create New Customer File Using Defaults
E

Opens an existing database file. The Open Existing Customer File screen will appear,
allowing you to select a file from any drive/directory. Each file represents an existing
customer database.

Print
Not supported at this time.

Sets the parameters of the communication link between the computer and the DBS phone
system. The Communications Setup screen will appear, with prompts for specifying the
COM port, baud rate, modem, etc.

E Communications Setup

ID Entry

Maintains user names and passwords for DBS Manager. The Maintain User Accounts screen
will appear, which allows you to create, change, or delete User Accounts.

Connect

E Connects your PC to a DBS. The Connect to DBS screen will appear, allowing you the
opportunity to change the connection type, remote phone number and/or DBS password. A
customer database does not have to be loaded before connecting to a DBS.
Disconnect

_'I Disconnects your PC from a DBS.
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Reports
E Not available at this time.

Help
% I Provides access to DBS Manager online help files.

The DBS Administration Section

This section of the DBS Manager main window contains the same items as those found in the DBS
Administration Menu. These items are available only when a DBS database is open or when connected to
a DBS. You can open a DBS Administration item by either selecting it from the drop-down menu or by
clicking on its corresponding button on the screen.

Items in this section are described under DBS Administration Menu on page 23.

The Information Bar

The information bar located at the bottom of the DBS Manager main window provides status information
and other data about DBS Manager. This section is described below.

designated com port system prompts & messages system date & time
['com1 | Loading' requested database... | Thu 09-Nov 95 9:05:21 a
| | OFFLINE |C:\WINDBS\CU‘ST_DB\SOUTHCOM.MDB | (CPCBV700995
connection status customer database name CPC type & version
Item Description

designated com port The commmunications port on your PC. The com port is desig-
nated in the File menu, under Communications. Note: This
item will display in black if you are set

system prompts & Contains various prompts & messages to help you with DBS
messages Manager. For instance, may read "Please select an option..."
when DBS Manager needs you to indicate an option choice.

system date & time Indicates your PC’s date & time.

DBS Manager Issued April 2000 25



Chapter 3

ltem

Description

connection status

Indicates whether or not your PC is currently connected to a
DBS via modem.

customer database
name

Indicates the name of the currently open DBS database. If no
database is open, this section will read *No customer database
selected...”

CPC type & version Indicates the CPC type & software version for the currently
open DBS database. If ho database is open, this section will
read "CPC version not set..."
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DBS Manager Basic Operations

This section contains information on performing basic DBS Manager operations. You can obtain
additional help at any point within DBS Manager by pressing F1 or by clicking on the Help button.

Note: Items in this section are not necessarily in the same order in which they appear on the various DBS
Manager menus, or in the same order in which they are used.

Starting DBS Manager

To start DBS Manager in Windows 3.1, double-click on its icon on the Windows Program Manager
screen. To start DBS Manager in Windows 95, click Start > Programs, then choose Panasonic DBS >
DBS Manager.

You will be asked to enter your DBS Manager user ID and password. Available menu items and options
depend on how your user account is configured.

Exiting DBS Manager

To exit DBS Manager, select File, then Exit, or click on the Exit button on the DBS Manager
button bar.

Modifying user accounts

User Accounts are used to maintain user ID and password information for DBS Manager. Only individu-
als with a valid user 1D and password can start DBS Manager.

To add or modify a DBS Manager user account, choose File > User Accounts, or click on the ID Entry

button.

The Maintain User Accounts window will open. You will need to re-enter your DBSManager log-in ID
before you can make any modifications to user accounts.

To add a user, click the Add User button and enter the new user 1D and password. You will be asked to
enter the password twice to confirm it. Click OK to add the user. After the new user is added, you will
need to indicate which areas of DBS Manager the user is allowed access to. In the User Access section of
the Maintain User Accounts window, click on each area the user will be allowed to access (be sure the
correct user is highlighted in the Select User window). A check mark in the box indicates that the user has
access to that area. Be sure to save the new user information before closing the Maintain User Accounts
window.
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To delete a user, select the user 1D from the Select User window (click the down arrow button to open the
window and click on the desired user ID). Click the Delete button. You will be asked to confirm the
deletion.

To change a user password, select the user ID from the Select User window (click the down arrow button

to open the window and click on the desired user ID). Click the Change Password button and enter the
new password information. Be sure to click OK to save the new data.

Setting communications parameters

To change your communications parameters, choose File > Communications, or click on the Communi-
cations Setup button E on the DBS Manager button bar.

Enter the appropriate settings for the communications session in the Communications Setup window and
click Save.
Notes:
1) The DBS Manager parity setting must match that of the DBS before a communications session can
be established. (The DBS’s default parity setting is Even. DBS Manager’s default parity setting is

None.)

2) DBS Manager allows you to set communications parameters for two different modems. Be sure
you have the right connection type and modem selected before attempting to initiate a connection.

3) Any changes made to communications parameters while a database is open will be saved with that
database.

Connecting to a DBS

Note: You must have a DBS Manager hardware key installed on your PC in order to connect to a DBS.
The dealer version hardware key allows remote connections. The end-user version is limited to local (on-
site) connections only (i.e., no external modem communications with a DBS are allowed). The version
type is displayed just above the phone graphic on the DBS Manager Main window.

Before connecting to a DBS, be sure to check File, then Communications to verify that the correct
communication parameters are set for the communications session. Information on setting
communications parameters can be found in the preceding section.

After verifying the communication parameters, use any of the following methods to initiate a connection to
a DBS.

 Choose Connect to DBS from the DBS Manager File menu.

* Click on the Connect to DBS button on the DBS Administration section of the main window.

« Click on the Connect button on the DBS Manager menu bar.
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The Connect to DBS window will open, showing the Connection Type as currently set under File -
Communications.

You will need to enter the DBS’ remote programming password for the following connection types:

* Unassisted RAI

* Unassisted External Modem

* Operator Assisted External Modem
* Direct (i.e., without a modem)

You will also need to enter the remote phone number for the DBS for the following connection types:

« Unassisted RAI
 Unassisted External Modem

If a database is open, the remote programming password and phone number as specified in the database
will be displayed (see Note 1 below).

If the connection type is Operator Assisted RAI, you will need a modem phone attached to your PC. You
will not need to enter a phone number or password into DBS Manager, but you will need to dial the DBS
Attendant from your modem phone and ask him/her to dial #6 and the Remote Programming Password for
the DBS.

Once the connection parameters are correct, click Connect to initiate the connection process. The
connection status portion of the information bar on the DBS Manager main window will change to reflect
"On-line" and various communication messages will flash across the system message portion of the
information bar.

Notes:

1) The remote phone number for a DBS is specified in the database under Customer/Site Setup. The
remote password for a DBS is specified in the Remote Programming Security Code field under
System Parameters - General Parameters - Security Codes.

2) If a database is open in DBS Manager when a connection is established, DBS Manager will
compare the software version of the DBS Manager database with the software version of the DBS.
If a mismatch is found, an error message will be displayed. You must then disconnect from the
DBS and open the correct database in DBS Manager before re-establishing the connection.

3) Any changes made to programming parameters while connected to a DBS will be transmitted
immediately to that DBS. If you do not wish the DBS to be updated immediately, enter the changes
into the database for that DBS without connecting to it. You can then establish the connection and
upload the changes later at a more convenient time.

4) Changes made to an open database while connected to the DBS will update both the database and
the DBS.
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Disconnecting from a DBS

To disconnect from a DBS, choose File > Disconnect, or click on the Disconnect button on the DBS
Manager main window. If a DBS Manager database was open, it will close automatically during a
Disconnect.

Modifying system parameters

To modify system parameters, click on the appropriate button in the DBS Administration section of the
main window, or select the desired item from the DBS Administration menu. A new window will open
containing additional buttons for the selected option. Click on the button for the area containing the
parameters to be modified. After modifying the appropriate parameter(s), click Save to save your changes.

Note: Some screens require that you enter a trunk or extension port # or a hunt goup # in the first dialog
box, then click the Display button to display the settings for that port or group #.

Working with Databases

Creating a new database

To create a new database for a DBS, choose File > New, or click on the New File button D I on the
DBS Manager button bar.

The Create New Customer Database Using Defaults window will open. Select the appropriate CPC type
and software version for the new database, then select the directory the database will reside in and specify
a name for the database. Database names must be 8 characters or less and have .mdb for an extension.
Typically the database name reflects the identity of the customer.

DBS Manager will automatically open the new .mdb database after it has finished creating it.
Notes:

1) Each new database is based on a default database for the specified CPC type and software version.
These default databases are shipped in a raw format to save disk space and must be converted to a
.mdb format before a new database can be opened. This conversion process may take some time
(approximately 15-30 minutes, depending on the speed and power of your system). The conversion
only occurs, however, the first time a new database is created for a particular CPC type and version
- additional new databases based on that CPC type and version will not need to go through the
conversion process.

2) It is not necessary that a database exist in DBS Manager in order to make changes to a DBS’
programming. If desired, you can connect to the DBS using DBS Manager and modify its
programming without maintaining a copy of its database in the DBS Manager application. See
""Databases and Connecting to a DBS - Special Considerations™ on page 33 for additional
information on databases.
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Opening an existing database

Ful
To open an existing database, choose File > Open, or click on the Open File button E' on the DBS
Manager menu bar.

The Open Existing Customer File window will open. Select the appropriate database and click OK.

Note: You cannot open a database while connected to a DBS. Open the desired database first, then connect
to the DBS.

See ""Databases and Connecting to a DBS - Special Considerations’ on page 33 for additional
information on databases.

Modifying customer/site information in a database

To modify general site information for a database, open the database and click on the Customer/Site
Setup button in the DBS Administration section of the main window, or select Cutomer/Site Setup form
the DBS Administration menu. The Customer Site Information window will open, allowing you to
modify the customer’s name, address, and remote phone #.

Modifying a remote phone number in a database

To modify the remote phone number in a DBS database, open the database, then click Customer/Site
Setup. Enter the new phone number in the appropriate field and click Save.

Note: The remote phone number in a DBS database must match that of the modem attached to the DBS in
order for a successful connection to occur.

Modifying a remote programming password in a database

To modify the remote programming password for a DBS database, open the database, then click System
Parameters. Select General Parameters, then Security Codes. Enter the new password in the Remote
Programming Security Code field and click Save.

Copying a database

To copy all parameters in one database to another database, choose File > Copy from the main window.
The Copy Existing Customer File window will open. In the Copy From section, select the appropriate
source file (the file to be copied). In the To section, type in the name of the destination database (the
database to be copied to). Be sure to indicate the appropriate directory where the new database will reside.
Click Save when finished.

Note: You can copy a database to either another existing database or a new database. If an unknown
database name is entered in the To section, a new database with that name will be automatically created.
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Closing a database
To close an open database, choose File > Close from the main window.

Note: You cannot close an open database while connected to a DBS. Disconnect from the DBS first, then
close the database.

Deleting a database

DBS Manager does not provide a function for deleting a database. If you find it necessary to delete an
existing database, use Windows File Manager (if using Windows 3.1) or "My Computer" (if using
Windows 95).

Uploading a database to a DBS

To upload a database from DBS Manager to a DBS, you must first convert the .mdb database file to a .raw
file. In DBS Manager, choose Database > Convert Database to Raw Data. Select the appropriate
database and click OK. The conversion process will take approximately 10-30 minutes, depending on the
speed and power of your PC.

After converting the database, connect to the DBS and choose Database > Upload Raw Data to DBS.
The Upload Database window will open. Select the .raw file to be uploaded and click OK to begin the
upload. It may take several minutes for the upload to finish, depending on the size of the database being
uploaded and the speed of your modem - an upload at 9600 bps, for instance, usually takes 10-12 minutes.
Various messages will flash across the system message portion of the DBS Manager main window
information bar during the upload.

Downloading data from a DBS to DBS Manager

To download programming data from a DBS to DBS Manager, you must first connect to the DBS. Once a
connection is established, select Database > Download Raw Data. The Download Data window will
open.

Type in the name of the .raw file the data should be downloaded to. If the .raw file already exists, you will
be asked to confirm that the file should be overwritten by the new data. If the .raw file does not exist, it will
be created during the download process.

It may take several minutes for the download to complete, depending on the size of the database being
downloaded and the speed of your modem - a download at 9600 bps, for instance, usually takes 10-12
minutes. Various messages will flash across the system message portion of the DBS Manager main
window information bar during the download.

After the download is complete, you must convert the .raw file to a .mdb file before the database can be
opened. To convert the file, select Database > Convert Raw Data to Database. Select the .raw file to be
converted and click OK. The conversion process will take approximately 10-30 minutes. After the
conversion is finished, you can open the database in DBS Manager.

Note: If you are downloading a database just for backup purposes, it may not be necessary to convert the
.raw database to a .mdb format.
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Upgrading a database to a higher CPC version

To upgrade an existing database to a higher CPC version, select Database > Upgrade Database. The
Upgrade Database CPC Version window will open. Select the database to be upgraded from the list in
the first window, then select the appropriate conversion from the second window. In the third window,
enter a new name for the database (DBS Manager keeps the old database under the original name as a
backup). Be sure to use a .mdb extension for the new database.

Notes:
1) DBS Manager does not support converting an existing database to an earlier software version.

2) When upgrading to a new CPC version, new features added subsequent to your current CPC
version must be individually programmed into the DBS, either via DBS Manager or FF key
programming.

3) When upgrading CPC-B software to a new release, you must initialize the SRAM (Static Random
Access Memory) immediately after changing out the EPROMS on the CPC-B card. This clears out
unused registers and adds new programs, but retains all current DBS program settings. To
accomplish this using DBS Manager, choose File > New Function Reset.

» A RAMCLR is not needed at this point.

* New Function Reset is needed only when a major CPC-B upgrade is done (such as from CPC-
B 6.0 to 7.0). It is not needed for minor upgrades from one "point" release to another (such as
from 6.0 to 6.1), nor is it needed for any other CPC other than CPC-B.

4) If upgrading to CPCAII/B 7.0 or later from a version prior to 7.0, you must perform a RAMCLR
after the 7.x software is installed.

5) Any feature settings activated by a station set user (such as Background Music, Call Forwarding,

Do Not Disturb, Headset Mode, Extension Lock, Reminder Alarm, Absence Messages, Call
Forward ID, etc.) are lost when an upgraded CPC is installed in the system.

Databases and Connecting to a DBS - Special
Considerations

It is possible that parameters in a DBS database may not always match those of the DBS. This can occur in
any of the following ways:

 Parameters in the DBS were modified by on-site FF key programming.

 Parameters in the DBS were modified by a connection through DBS Manager without a database
being open.

 Parameters were modified in a DBS Manager database without being connected to a DBS, but those
changes were never uploaded to the DBS.

To ensure that a database always matches its DBS, you should therefore be sure to open the database
before connecting to the DBS. It is also a good idea to download a DBS’ programming parameters back to
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your PC if you have reason to suspect that a DBS may have been modified independently of the DBS
Manager database.

Remember that you can connect to a DBS either with or without a database being open. If a database is
open, any changes made to programming parameters while connected will be updated immediately to both
the DBS and the open database. If a database is not open, changes made while connected will update only
the DBS and will not be reflected in the database unless those same changes are made in the database at a
later time, or you download the entire DBS programming to the database.

Furthermore, when you connect to a DBS while a database is open, only those parameters changed while
connected will be updated back to the database. If there are other parameters in the database that do not
match those in the DBS, these parameters will not be updated in the database unless you reenter them in
DBS Manager while connected, change the parameters in the database at a later time, or download the
entire DBS programming to the database.
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Using Help

DBS Manager contains extensive on-line help files. You can access Help at any time via any of the
following means:

* by pressing F1
* by clicking the Help button on the screen
* by clicking on the Help button located on the Menu bar.

The Help system is structured the same way as DBS Manager. For each DBS Manager screen of
parameters and/or buttons, there is a corresponding Help screen that lists the parameters/buttons in green,
underlined text. These are called "jumps". Click on a jump - anywhere in the green underlined text - to
display either a Help window for the selected parameter or another list of jumps.

Each Help window reflects the name of the Help topic, which area of DBS Manager it pertains to (e.g.,
Trunks, Extensions, Groups, etc.), and the corresponding FF key programming for that topic.

Locating a Help Topic

DBS Manager follows standard Windows Help file conventions. You can either navigate to the desired
topic by selecting the appropriate item from the Help Contents screen, or you may use Help’s powerful
search function to help you locate a specific topic. Procedures for using Search are as follows:

1. While in Help, click on the Search button and enter the first few letters of the desired topic in the
first window. Notice that as you type, the second window scrolls up or down to display an
alphabetical list of topics.

2. Select the desired topic from the list in the second window and click Display. If a secondary list
appears, select the appropriate topic and click Display again.The Help file for the selected topic
will then be displayed.

About Bookmarks

DBS Manager’s Help files allow you to quickly jump to commonly referenced Help topics by creating
Bookmarks for them. This allows you to go directly to a desired topic without having to search for it. For
instance, suppose you find that you often need to view Help on System Speed Dials. Instead of navigating
through several screen levels to reach the System Speed Dial Help screen, you can create a bookmark that
will take you straight to the appropriate section of DBS Manager Help with a click of your mouse.

Creating Bookmarks

Bookmarks are created as follows:
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1. Go to the DBS Manager Help topic that you want to mark with a Bookmark.

2. From the Menu bar, click on Bookmark, then Define. You can either accept the default Bookmark
name shown in the window or enter a different name.

3. After entering a name for the Bookmark, click OK to save the Bookmark or Cancel to exit without
saving the Bookmark. If saved, the new Bookmark will be listed on the Bookmark menu.
Using Bookmarks

To jump directly to a Help topic that already has a Bookmark, click on Bookmark, then click on the
desired Bookmark from the list.

Deleting Bookmarks

To delete a Bookmark, click on Bookmark, then Define. Select the desired Bookmark from the
displayed list and click Delete.

Copying and Annotating Help Topics

You can "edit" or expand on Help topics by attaching annotations to them. Annotations are notes which
you create to help you perform DBS Manager operations. Annotated items are indicated by a small paper
clip icon next to them. To view an annotation, click on the paper clip.
Creating an Annotation

1. Click Edit from the Menu bar (be sure the Help topic you want to annotate is displayed).

2. Choose Annotate and enter your notes in the annotation window.

3. Click Save to save your annotation or Cancel to exit without saving your annotation.

Copying an Annotation

1. To copy an annotation, open the annotation window by clicking on the paper clip icon next to an
annotated item.

2. Select the desired text in the annotation window, then click Copy.

3. Close out that annotation window and navigate to the Help topic where you want the annotated text
copied to.

4. Choose Edit, then Annotate, then click Paste to insert the copied information into the annotation
window. You can then edit the copied information if desired. Be sure to click Save before exiting
the Annotation window.

Copying an entire Help topic into an Annotation

1. To copy an entire Help topic into an annotation, choose Edit, then Copy from the Help Menu bar
(be sure the Help topic you want to copy is displayed).

2. Navigate to where you want the information copied to and choose Edit, then Annotate.

3. Click Paste to insert the copied information into the annotation window. You can then edit the
copied information if desired. Be sure to click Save before exiting the Annotation window.
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Deleting an Annotation

To delete an annotation, click on the paper clip icon next to the annotated item, then click Delete. The
paper clip will disappear as the annotation is removed.

Printing Help Topics

You can print Help topics either by selecting File, then Print Topic, or by clicking on the Print button on
the Help button bar. Some Help items also display a printer icon in the Help window. You can print these
topics by clicking on this icon.
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